• Welcome to Simple Machines Community Forum. Please login or sign up.
November 29, 2021, 11:38:08 PM

News:

SMF 2.1 RC4 has been released! Try it out and help us test! :) Read more.


Anti-Bot: Are You Human/Bot?

Started by vbgamer45, October 31, 2007, 04:17:06 PM

Previous topic - Next topic

raaja

im getting this error msg....

"Session verification failed. Please try logging out and back in again, and then try again"

how to fix this?



MacGig

I must of installed wrong, I did the edits, then registered a test account with NO selected. and it let me register? whats the point? I must of done something wrong.

TDNY

Just installed this after reading the thread called spam nightmare. I have vers. 1.1.8 default core. used package manager not a hint of a glitch, very easy to use for this new computer user. Installed without having to edit anything. Thanks for this mod karlbenson.

TD

additude

Question: On the package page it states:
"Installation
Any previous versions of this mod MUST be uninstalled BEFORE installing this version.

Simply install the package to install on the SMF Default Core Theme ONLY.

A Manual edit will be required for ALL themes (other than SMF Default Core Theme) which have a custom Register.template.php
If you don't perform the manual edit, nobody will be able to register using those themes.

OPEN Register.template.php (in each folder Themes/{themename/ )"

I have theme Babylon installed and apparently it doesn't have a "Register.template.php" file. Does that mean, 1. This package will not work with this theme? or 2. This file is not required for this package to work with this theme?

Thanks.

bburg5

I too have a theme that must share the default php files. It is the DB_Theme. I also noticed that it does not ask during registration. Please let me know where I need to add manual coding.

Thanks

MacX

Wow, i was getting crazy with the manual instalation of it...

There was an error in the code you show on the mod page...

In this line you need ":

Insted of this:

<select name="',$_SESSION['areyouhuman'],' tabindex="', $context['tabindex']++, '" class="select">


This:
<select name="',$_SESSION['areyouhuman'],'" tabindex="', $context['tabindex']++, '" class="select">

With semicolons after:
<select name="',$_SESSION['areyouhuman'],'

It would be nice if you correct it here:
http://custom.simplemachines.org/mods/index.php?action=parse

.LORD.

May 02, 2009, 12:35:55 PM #126 Last Edit: May 02, 2009, 12:39:34 PM by .LORD.
Hi

This MOD have been updated.

Now work fine in SMF 1.1.X and SMF 2 and have new features

More info in the changelog   :)

spitstickler

On the installation instructions is states that at the bottom in the Code Section, "This file should not be able to execute standalone. You may have to run the following queries manually." I'm not a database guy, but it looks like the insert code is incomplete to me. I'm running mysql version 5.0.67

I have cut and pasted the query below and I get an error when I run the query on my database.

INSERT IGNORE INTO
{$db_prefix}settings
(variable, value)
VALUES   ('are_you_human_s', '1'),
('are_you_human_q', '0'),
('are_you_human_a


This is the error message I get:

Error
There seems to be an error in your SQL query. The MySQL server error output below, if there is any, may also help you in diagnosing the problem

ERROR: Unclosed quote @ 118
STR: '
SQL: INSERT IGNORE INTO
{$db_prefix}settings
(variable, value)
VALUES   ('are_you_human_s', '1'),
('are_you_human_q', '0'),
('are_you_human_a

SQL query:

INSERT IGNORE INTO {$db_prefix}settings (variable, value) VALUES   ('are_you_human_s', '1'), ('are_you_human_q', '0'), ('are_you_human_a

MySQL said:

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '{$db_prefix}settings
(variable, value)
VALUES    ('are_you_human_s', '1'),
('are' at line 2


.LORD.

Try install automatically

Then, only you should edit manually the Register.template in your themes customize. (only if is necessary).

The SMF Package Parser don't shows all the content of the php files.

The error is, you haven't used all the code, because the SMF Package Parser don't shows the complete code.  Also you should replace {$db_prefix} for your prefix DB.

ie try install automatically, is more easy :)

spitstickler

May 02, 2009, 02:45:21 PM #129 Last Edit: May 02, 2009, 02:59:03 PM by spitstickler
Quote from: .LORD. on May 02, 2009, 02:31:53 PM
Try install automatically

Then, only you should edit manually the Register.template in your themes customize. (only if is necessary).

The SMF Package Parser don't shows all the content of the php files.

The error is, you haven't used all the code, because the SMF Package Parser don't shows the complete code.  Also you should replace {$db_prefix} for your prefix DB.

ie try install automatically, is more easy :)

I tried to download with the package manager (v1.3 was the only option available) It said it was incompatible with this version of smf. I'm running 1.1.8 Is there another way to install automatically?

..or if I had the complete code to run the query with, that would hook me up too.

I've also downloaded the "Are_You_Human_v2_0" zip. There aren't any instructions on what directory I should put the enclosed files in. I suspect if you've done this for a while you sort of just know that, but I'm pretty new to this. Just need a little more direction and I'm sure I'll be in the swing of things shortly.

thx!

Tiribulus

I'm nor sure I'm following. You have to run the database entries manually or no?

Mystiquo

Scuse me i have a problem i can select and save random answer but when i select random question and i save  i have always question are you human??
Thanks

.LORD.

Quote from: Mystiquo on May 08, 2009, 07:39:27 PM
Scuse me i have a problem i can select and save random answer but when i select random question and i save  i have always question are you human??
Thanks

Version SMF?

Have you install manually?

Mystiquo


.LORD.

A new version have been released.

Fix a bug in Register.Template in SMF1.1.X (tranks Mystiquo for report)

This version improve the security (tranks szcoder for notify). Please update.




Quote from: spitstickler on May 02, 2009, 02:45:21 PM
Quote from: .LORD. on May 02, 2009, 02:31:53 PM
Try install automatically

Then, only you should edit manually the Register.template in your themes customize. (only if is necessary).

The SMF Package Parser don't shows all the content of the php files.

The error is, you haven't used all the code, because the SMF Package Parser don't shows the complete code.  Also you should replace {$db_prefix} for your prefix DB.

ie try install automatically, is more easy :)

I tried to download with the package manager (v1.3 was the only option available) It said it was incompatible with this version of smf. I'm running 1.1.8 Is there another way to install automatically?

..or if I had the complete code to run the query with, that would hook me up too.

I've also downloaded the "Are_You_Human_v2_0" zip. There aren't any instructions on what directory I should put the enclosed files in. I suspect if you've done this for a while you sort of just know that, but I'm pretty new to this. Just need a little more direction and I'm sure I'll be in the swing of things shortly.

thx!

Sorry for forget

Check this info:
How to Installed Packages

:)

Mystiquo


Sabre™

Hi mate, nice additions to this mod :)

It looks like you've forgotten to add the text for this
$txt['stopspammer_show01_sub']

No text appears under
Order Rand the Answers:
Do NOT give admin and/or ftp details to just anybody, see if they are trust worthy first!!  Do your homework ;)


stp46and2

Oops.

Installed this mod and am now getting this error


How do I correct this?

Thanks

Uhura!

I received the following error when I installed this:

Quote2: packageinstall(/home/ourmo0/public_html/community/Packages/temp/install1.php) [<a href='function.packageinstall'>function.packageinstall</a>]: failed to open stream: No such file or directory
File: /home/ourmo0/public_html/community/Sources/Packages.php
Line: 556

Also, the Are you human question appears two times in the registration area.

Please help!
:) Our Parenting Spot is an online parenting community for fathers, mothers, grandparents, teachers, and family service professionals. 8) We also provide low cost advertising options for authors, family service providers, and businesses with family friendly products and services. ;D Visit us @ www.OurParentingSpot.net!

.LORD.

A new Version hav ebeen released with two bug repaired (I hope that everything is okay  :-[)




Quote from: Mystiquo on May 12, 2009, 07:25:29 AM
thanks for all

Thanks you too for report :)




Sabre™, stp46and2 Thanks for report :)




stp46and2, sorry for delay.

You should open the Modifications.english-utf8.php

Search
<add><![CDATA[

And Delete

And if you use SMF2, you should clean the SMF cache.



Quote from: Uhura! on May 16, 2009, 11:40:23 AM
I received the following error when I installed this:

2: packageinstall(/home/ourmo0/public_html/community/Packages/temp/install1.php) [<a href='function.packageinstall'>function.packageinstall</a>]: failed to open stream: No such file or directory
File: /home/ourmo0/public_html/community/Sources/Packages.php
Line: 556


Also, the Are you human question appears two times in the registration area.

Please help!


1. Have you enable the debbuger mode?
This error ocurr in debbuger mode. Isn't important

2. Attach your files (Register.template.php, Register.php, ManageRegistration.php) for  deleted the duplicated.

Sorry for delay :)


Advertisement: