News:

SMF 2.1.2 has been released! Take it for a spin! Read more.

Main Menu

Banner Mod

Started by Midgard, January 08, 2005, 12:32:16 PM

Previous topic - Next topic

Midgard

Support for this mod has stopped.

TarantinoArchives

i used the SSI but the problem is that i use it OUTSIDE smf, so the banner mod doesnt allow me to see the banner, because i am not registered, and not a guest, either

Midgard

You should setting guest group permissions for seen SSI banners by guests. You must set "allow" to "can you see" for unregistered guest group. It's working on this shape.

TarantinoArchives


TarantinoArchives

and how can I update from 2.4 to 3.0 without losing my statistics and already on banners?

Midgard

1 - Are you sure? It's still working on my site...

2 - This updates only html and php coding. Don't data losing.

TarantinoArchives

Quote from: Midgard on January 08, 2005, 12:56:21 PM
1 - Are you sure? It's still working on my site...
yes.
this is what i use:

Quote<?php
require("forum/SSI.php");
ssi_banners();
?>
correct?

Quote
2 - This updates only html and php coding. Don't data losing.

can i just upload through package manager? do i have to uninstall or delete the old package?

Midgard

1- <?php ssi_banners(); ?> yes it's correct..

2- yes, you can

TarantinoArchives

Quote from: Midgard on January 08, 2005, 01:03:29 PM
1- <?php ssi_banners(); ?> yes it's correct..

2- yes, you can

thanks.
i forgot to create a "for ssi only" banner. it works now, thank you. great mod!!!

Midgard


TarantinoArchives

i uninstalled the 2.4 and then i got this error when trying to continue surfing:

QuoteFatal error: Call to undefined function: showbanner() in /var/www/web2/html/forum/Sources/Load.php(1096) : eval()'d code on line 313

i searched Load.php and i really didnt find it... where's the problem? i cant install 3.0 now because i cant surf anymore

Midgard

showbanner(); remove this function from index.template.php file

TarantinoArchives

Quote from: Midgard on January 08, 2005, 01:17:12 PM
showbanner(); remove this function from index.template.php file

found it. i was using a custom template. thats where the mistake came from.
works now.
thanks for the quick support. you rock!

TarantinoArchives

damn.
Now I found another problem.

The banner I inserted by SSI does not open in Parent Window. But I have set parent window. It opens a new window.....
i think i'm gonna add this manually to SSI.php

Midgard

Thank you, i fixed this problem, on next release...

Aravot

Hi I just downloaded and installed the Banner Mode 3.0, but I can only see it when I login as Administrator, what am I missing.
I want all the members even guest to see the banner.
thanks

Midgard

Did you setup member groups permissions?
You've set unregistered guest members permissions...

Regards, Midgard

Aravot

I don't understand can you please elaborate, THX

Nidoking

I think, in order to allow everyone, even guests to see your banner, you have to allow unregistered members to view all your boards.

Aravot

Under Edit Permissions, I have Unregistered Guest and Ungrouped Members, but not unregistered members both groups can view the forum.

Advertisement: