News:

SMF 2.1.3 has been released! Take it for a spin! Read more.

Main Menu

nneonneo's Shoutbox

Started by nneonneo, December 26, 2006, 06:58:11 PM

Previous topic - Next topic

Gobo

if u need to uninstall it and the uninstall link isnt appearing
then do this:

in the Packages page (when ur on it)
put this in front of the address in the browser addressbar: ;version_emulate=1.1
it will get u the uninstall link back

Also if internal server error is occuring u just need to delete the package last uploaded in the Packages folder

powerPT

After install (or not) this mod, the link /index.php?action=packages don´t works, When I click it shows:
QuoteInternal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.


Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Can you help me?

brianjw

#62
This mod is working 100% for me. I think some of you need to do a fresh install of smf. Upload all your images and mods back up. Reinstall smf.

DEMO: http://brianjwilson.com
Username: test
Password: test
(this is a test account; please do not abuse this account)

Also it shout appear at the top of the page only in the themes alienation, smf default, and enterprise! You must be logged into see it!!!!

nneonneo

Quote from: RvG on December 29, 2006, 11:43:56 AM
For anyone with the "loading shoutbox..." problem, please go to http://domain.com/path/to/your/forum/yshout/yshout.php in your browser (replacing the path with yours of course) and see what comes up. If it says "nothing to do" then your setup is correct, and I'll need more information. If any sort of PHP error appears, then there is a problem.
Also check your webserver error logs.

wow! it works!!! "after saying nothing to do" I reload back the page then it works on my test board.

but when i installed it on my live board it shows "Internal Server Error"

error log:

[2006-12-29 11:58:45]: error: file is writable by others: (/home/******/public_html/v3/yshout/yshout.php)

these are my mods installed:

1.     TinyPortal      0.97       [ List Files ]  [ Delete ]
2.    Joined Date    1.0    [ Uninstall ] [ List Files ] [ Delete ]
3.    Post Count Warning    1.1    [ Uninstall ] [ List Files ] [ Delete ]
4.    Member Awards    1.0.2    [ Uninstall ] [ List Files ] [ Delete ]
5.    SMF Radio    1.0    [ Uninstall ] [ List Files ] [ Delete ]
6.    Inline Attachments    1.0.4.2    [ Uninstall ] [ List Files ] [ Delete ]
7.    Bear Tabs    1.0    [ Uninstall ] [ List Files ] [ Delete ]
8.    SMF Arcade    1.3.1-MOD-E1.5.1    [ List Files ] [ Delete ]
9.    Simple Blog    1.4.2    [ Uninstall ] [ List Files ] [ Delete ]
10.    SMF Staff Page    1.3    [ List Files ] [ Delete ]
11.    SMF TV    0.1    [ Uninstall ] [ List Files ] [ Delete ]
12.    Topic Ratings    1.03    [ Uninstall ] [ List Files ] [ Delete ]
13.    vReportBoard Mod    0.97    [ List Files ] [ Delete ]
14.    Custom Profile Field Mod    3.16    [ Uninstall ] [ List Files ] [ Delete ]
15.    Media Center    1.0    [ Uninstall ] [ List Files ] [ Delete ]
16.    Bookmark Mod By Leipe Po    1.3    [ Uninstall ] [ List Files ] [ Delete ]
17.    SMF 1.1.1 Update Package    1.1.1    [ Uninstall ] [ List Files ] [ Delete ]
18.    nneonneo's AJAX ShoutBox    1.03    [ Uninstall ] [ List Files ] [ Delete ]
19.    Tagging System    1.0.2    [ Uninstall ] [ List Files ] [ Delete ]
20.    SMF Gallery Lite    1.6.9    [ Uninstall ] [ List Files ] [ Delete ]
21.    SMF Shoutbox    1.15    [ List Files ] [ Delete ]
22.    Zodiac 13Moon    1.0    [ Uninstall ] [ List Files ] [ Delete ]
23.    Admin Notepad    1.0    [ Uninstall ] [ List Files ] [ Delete ]
24.    SMF Staff Page    1.5    [ Uninstall ] [ List Files ] [ Delete ]


It appears as if your server doesn't like having the permissions opened to all! It's rather odd that the server should check, but it could be a security thing.
Anyway, I recommend chmod'ing the file to "755" and see if that works.

@YenLoWang: The shoutbox looks fine (i.e. it looks like the CSS works) in all my browsers.
However, I think that it would be good if the shoutbox div did not show up at all for guests.
Check out the AJAX Shoutbox (my one and only mod to date :P)
Do you like SMF? Are you using ProBoards, InvisionFree, ActiveBoards or some other web-hosted forum? I can help you convert to SMF (without having to purchase a DB conversion)...contact me [nneonneo {at} gmail *dot* com], and see this topic
spammers here!

Geoff Mendicino

Can you help me install this on the Babylon template? It doesn't show when I try to copy the code in.

My forum: http://mega64ums.exehq.com

sasquatch

I'm getting something strange now... it constantly says "sorry, you must be logged in to post" - even though i'm logged in ?!?

RvG

Quote from: nneonneo on December 29, 2006, 01:19:26 PM
Quote from: RvG on December 29, 2006, 11:43:56 AM
For anyone with the "loading shoutbox..." problem, please go to http://domain.com/path/to/your/forum/yshout/yshout.php in your browser (replacing the path with yours of course) and see what comes up. If it says "nothing to do" then your setup is correct, and I'll need more information. If any sort of PHP error appears, then there is a problem.
Also check your webserver error logs.

wow! it works!!! "after saying nothing to do" I reload back the page then it works on my test board.

but when i installed it on my live board it shows "Internal Server Error"

error log:

[2006-12-29 11:58:45]: error: file is writable by others: (/home/******/public_html/v3/yshout/yshout.php)

these are my mods installed:

1.     TinyPortal      0.97       [ List Files ]  [ Delete ]
2.    Joined Date    1.0    [ Uninstall ] [ List Files ] [ Delete ]
3.    Post Count Warning    1.1    [ Uninstall ] [ List Files ] [ Delete ]
4.    Member Awards    1.0.2    [ Uninstall ] [ List Files ] [ Delete ]
5.    SMF Radio    1.0    [ Uninstall ] [ List Files ] [ Delete ]
6.    Inline Attachments    1.0.4.2    [ Uninstall ] [ List Files ] [ Delete ]
7.    Bear Tabs    1.0    [ Uninstall ] [ List Files ] [ Delete ]
8.    SMF Arcade    1.3.1-MOD-E1.5.1    [ List Files ] [ Delete ]
9.    Simple Blog    1.4.2    [ Uninstall ] [ List Files ] [ Delete ]
10.    SMF Staff Page    1.3    [ List Files ] [ Delete ]
11.    SMF TV    0.1    [ Uninstall ] [ List Files ] [ Delete ]
12.    Topic Ratings    1.03    [ Uninstall ] [ List Files ] [ Delete ]
13.    vReportBoard Mod    0.97    [ List Files ] [ Delete ]
14.    Custom Profile Field Mod    3.16    [ Uninstall ] [ List Files ] [ Delete ]
15.    Media Center    1.0    [ Uninstall ] [ List Files ] [ Delete ]
16.    Bookmark Mod By Leipe Po    1.3    [ Uninstall ] [ List Files ] [ Delete ]
17.    SMF 1.1.1 Update Package    1.1.1    [ Uninstall ] [ List Files ] [ Delete ]
18.    nneonneo's AJAX ShoutBox    1.03    [ Uninstall ] [ List Files ] [ Delete ]
19.    Tagging System    1.0.2    [ Uninstall ] [ List Files ] [ Delete ]
20.    SMF Gallery Lite    1.6.9    [ Uninstall ] [ List Files ] [ Delete ]
21.    SMF Shoutbox    1.15    [ List Files ] [ Delete ]
22.    Zodiac 13Moon    1.0    [ Uninstall ] [ List Files ] [ Delete ]
23.    Admin Notepad    1.0    [ Uninstall ] [ List Files ] [ Delete ]
24.    SMF Staff Page    1.5    [ Uninstall ] [ List Files ] [ Delete ]


It appears as if your server doesn't like having the permissions opened to all! It's rather odd that the server should check, but it could be a security thing.
Anyway, I recommend chmod'ing the file to "755" and see if that works.

@YenLoWang: The shoutbox looks fine (i.e. it looks like the CSS works) in all my browsers.
However, I think that it would be good if the shoutbox div did not show up at all for guests.

it was already in 755. Since it worked on my test board on the same server means that there's a conflict on one of the mods.

nneonneo

Hmm, weird. I can't really say which mod could interfere, seeing as the shoutbox has very little interaction with other mods.

Please check to see if there is a "SSI.php" file in the main forum directory - it may have been deleted by a mod (possibly)

@Geoff: what code did you try to copy in?
@sasquatch: Do you have cookies on? The shoutbox uses cookies to track logged-in status.
Check out the AJAX Shoutbox (my one and only mod to date :P)
Do you like SMF? Are you using ProBoards, InvisionFree, ActiveBoards or some other web-hosted forum? I can help you convert to SMF (without having to purchase a DB conversion)...contact me [nneonneo {at} gmail *dot* com], and see this topic
spammers here!

Gobo

if urpackage manager is not accessible

download the LAST package u uploaded via package manager (use FTP to download it) this is just for backup.

Then using FTP delete the package from ur servers Packages folder

Geoff Mendicino

Quote from: nneonneo on December 29, 2006, 02:41:53 PM
Hmm, weird. I can't really say which mod could interfere, seeing as the shoutbox has very little interaction with other mods.

Please check to see if there is a "SSI.php" file in the main forum directory - it may have been deleted by a mod (possibly)

@Geoff: what code did you try to copy in?
@sasquatch: Do you have cookies on? The shoutbox uses cookies to track logged-in status.

The same code that is inserted into the index.templates.php or whatever file, starting from //YSHOUT START to //YSHOUT END

Geoff Mendicino

I was also wondering if it's possible to only have the Shoutbox appear when you're viewing a certain forum.

nneonneo

It should be possible, just put in a check or something for the current board:
if(!empty($context['current_board']) && $context['current_board']==<board id>)
{
echo '<br><b>Shout Box.....[rest of that section]
}

There are 3 blocks of code that go from YSHOUT HERE to YSHOUT END; the first and the third are important (for Babylon, all three should be copied). See the modification file "install.xml" for details (Package Manager->"[List Files]"->install.xml) and for manual installation. Most of the elements should be in approximately the same place.
Check out the AJAX Shoutbox (my one and only mod to date :P)
Do you like SMF? Are you using ProBoards, InvisionFree, ActiveBoards or some other web-hosted forum? I can help you convert to SMF (without having to purchase a DB conversion)...contact me [nneonneo {at} gmail *dot* com], and see this topic
spammers here!

Erle

How do I change the Timestamp  (German time)?

the rest works awesome great work?

nneonneo

I am working on an update; I will release an update soon which will use forum settings for time.
Check out the AJAX Shoutbox (my one and only mod to date :P)
Do you like SMF? Are you using ProBoards, InvisionFree, ActiveBoards or some other web-hosted forum? I can help you convert to SMF (without having to purchase a DB conversion)...contact me [nneonneo {at} gmail *dot* com], and see this topic
spammers here!

nneonneo

Updated the shoutbox to 1.04. Changes:
Made the shoutbox parse times according to forum and user settings (so it will parse differently for each person according to what they wish to see in their profile).

1.04 is a direct upgrade from 1.02 or 1.03; simply upload and install. Chats, history, etc. will be saved, but there *may* be problems during installation.

In particular, if you have changed the timezone from "America/Regina" you are recommended to change it back before upgrading to avoid problems. That section will be deleted during the upgrade, so you will not have any timezone problems after the upgrade (hopefully!)
Check out the AJAX Shoutbox (my one and only mod to date :P)
Do you like SMF? Are you using ProBoards, InvisionFree, ActiveBoards or some other web-hosted forum? I can help you convert to SMF (without having to purchase a DB conversion)...contact me [nneonneo {at} gmail *dot* com], and see this topic
spammers here!

Daniel15

QuoteIt's rather odd that the server should check, but it could be a security thing.
Anyway, I recommend chmod'ing the file to "755" and see if that works.
More specifically, it's something called phpsuexec (or suPHP, but they're basically the same thing). Essentially, it means that PHP scripts run as the user that owns them, rather than the Apache user 'nobody'. Because of this, you can't run world-writable scripts (there's no use anyway - you could CHMOD it to 770 and it would still work, because they're being run/written to by you)

Quote[2006-12-29 11:58:45]: error: file is writable by others: (/home/******/public_html/v3/yshout/yshout.php)
That's indeed what it sounds like - The /home/******/public_html/v3/yshout/yshout.php file is writable by others (CHMODded to 0777). CHMODding the file to 0755 should fix this.

QuoteMade the shoutbox parse times according to forum and user settings
Nice to see you took my advice... Nice work! :)
Daniel15, former Customisation team member, resigned due to lack of time. I still love everyone here :D.
Go to smfshop.com for SMFshop support, do NOT email or PM me!

starsong

Hi I am having trouble with this shout box.
I have  zipped teh main and the fixed indexes.
My theme is roses.

I cant seem to get passed the Shoutbox loading....

I would be grateful of any help. TY
jodi

[email protected]

xyxis_fahim

#77
Hey thanks nneonneo  for the help earlier. I'm set with sb all the way i guess.
But one last thing I want is to get rid of the long time set when posting..

Ex.... [December 29, 7:52 pm] King Lara_400: :)
to something like [Today, 7:52 pm]


This is what i've it set ... on www.truforum.org/smf

You may log in with
User: test
Pass: test

Daniel15

QuoteEx.... [December 29, 7:52 pm] King Lara_400:
to something like [Today, 7:52 pm]
In yshout.php, find:

    return timeformat(intval($matches[1]));

Replace with:

    return timeformat(intval($matches[1]), true);

Make sure the 'Today' feature is enabled in SMF (Admin Panel --> Features and Options --> Layout and Options).

Not tested by me, but should work :). I still haven't had an in-depth look at this mod, so I don't know that much about how the code works ;)
Daniel15, former Customisation team member, resigned due to lack of time. I still love everyone here :D.
Go to smfshop.com for SMFshop support, do NOT email or PM me!

RvG

Quote from: nneonneo on December 29, 2006, 02:41:53 PM
Hmm, weird. I can't really say which mod could interfere, seeing as the shoutbox has very little interaction with other mods.

Please check to see if there is a "SSI.php" file in the main forum directory - it may have been deleted by a mod (possibly)

@Geoff: what code did you try to copy in?
@sasquatch: Do you have cookies on? The shoutbox uses cookies to track logged-in status.

sorry nneonneo :)

I got it worked now... hahahhaa! thank you thank you.

Advertisement: