News:

SMF 2.1.3 has been released! Take it for a spin! Read more.

Main Menu

Post Reply's nesting

Started by Rexg81, December 25, 2009, 03:42:05 PM

Previous topic - Next topic

Rexg81

Hello, we just installed SMF 2 (new install, new forum).  When the Post Reply button is selected from the bottom of the page, the reply posts as a nested message within the previous post.  If the Post Reply button is selected from the top of the page, the post appears normal.  Why is this?  How do we correct this?

N3RVE

"nested message", can we see a link, screenshot?

-[n3rve]
Ralph "[n3rve]" Otowo
Former Marketing Co-ordinator, Simple Machines.
ralph [at] simplemachines [dot] org                       
Quote"Somewhere, something incredible is waiting to be known." - Carl Sagan

Arantor

This is a bug in 2.0 RC2 concerning custom profile fields and if you have one set to be around the signature area. Only workaround for now is to move it, I believe.

Rexg81

Quote from: [n3rve] on December 25, 2009, 07:13:58 PM
"nested message", can we see a link, screenshot?

-[n3rve]

Here is a screen shot where you can see where the nested posts appear.  This only happen when the Post Reply button on the bottom of the page is clicked.  The replies appear normal only when the Post Reply on the top of the page is clicked.


Arantor

Quote from: Arantor on December 25, 2009, 07:46:11 PM
This is a bug in 2.0 RC2 concerning custom profile fields and if you have one set to be around the signature area. Only workaround for now is to move it, I believe.

Rexg81

Quote from: Arantor on December 26, 2009, 05:00:40 PM
Quote from: Arantor on December 25, 2009, 07:46:11 PM
This is a bug in 2.0 RC2 concerning custom profile fields and if you have one set to be around the signature area. Only workaround for now is to move it, I believe.

Your point is?  We don't have any custom fields in or around the signature area that I know of.  At least none that we created.  How do I verify that there are no custom profile fields that may already have been pre-defined with the software?

Rexg81

I think I figured it out.  The 'enable custom profile fields' was selected by default.  I de-selected that and that solved the issue. 

Rexg81

Another issue.  This nesting problem still exists when quoting a post.  What is the solution?

Antechinus


Antechinus

The custom profile field bug has been fixed in svn and is caused by this code in Display.template.php:

// Are there any custom profile fields for above the signature?
if (!empty($message['member']['custom_fields']))
{
$shown = false;
foreach ($message['member']['custom_fields'] as $custom)
{
if ($custom['placement'] != 2 || empty($custom['value']))
continue;
if (empty($shown))
{
$shown = true;
echo '
<div class="custom_fields_above_signature">
<ul class="reset nolist>';


The last line should be:

<ul class="reset nolist">';

Advertisement: