News:

SMF 2.1.2 has been released! Take it for a spin! Read more.

Main Menu

Hide Tag Special

Started by enik, April 11, 2005, 03:41:07 PM

Previous topic - Next topic

ディン1031

Quote from: Elmacik on November 22, 2005, 05:00:45 AM
So is 1.12a the last version to use with 1.0.5?
Correct :)

(For normal install without Faster Parser install).

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

VenimK

#121
Whereis this version 1.13 off Hide Tag for SMF RC 1.1

Can't find this anywhere !!!!

ディン1031

Quote from: VenimK on November 27, 2005, 05:08:49 AM
Whereis this version 1.13 off Hide Tag for SMF RC 1.1

Can't find this anywhere !!!!
Why should i add a buged version?

Version 1.15 is the newest version for 1.1RC1 ;D.
1.12a is bugfree version for 1.0.5 :).

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

tuga

Quote from: din1031 on November 28, 2005, 04:56:32 AM
Quote from: VenimK on November 27, 2005, 05:08:49 AM
Whereis this version 1.13 off Hide Tag for SMF RC 1.1

Can't find this anywhere !!!!
Why should i add a buged version?

Version 1.15 is the newest version for 1.1RC1 ;D.
1.12a is bugfree version for 1.0.5 :).

Bye
DIN1031

hello, so the 1.12a is for 1.0.5 right? where i found it?

what i need to do for work? just install?

ディン1031

http://mods.simplemachines.org/index.php?mod=118

There you could find it :x, Normal yes you need only to install it :).

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

daveb47

Tried to download rc1 version of this but when i try to install thru Pacman i get File is corrupted message.
Cheers
Dave
https://daveb47.co.uk

A Slinky is like Jeremy CorbynWinehouse,Weird looking,Not really of any use to anybody.
But its really funny when it falls down the stairs!!:D:D

croniksoft

hello everyone,i just finish installing this mob,but  when i use the hide option dosen"t work,anyone knows y this is happening.

i have  Hide Tag      1.13Fix2

install in  1.1 RC1.

thank you for your time.
i have a dream and you could be part of it


ディン1031

Quote from: croniksoft on November 30, 2005, 04:28:20 PM
hello everyone,i just finish installing this mob,but  when i use the hide option dosen"t work,anyone knows y this is happening.

i have  Hide Tag      1.13Fix2

install in  1.1 RC1.

thank you for your time.
You installed a fix?
Did you install the normal version before? ;D

Quote from: daveb47 on November 30, 2005, 04:01:34 PM
Tried to download rc1 version of this but when i try to install thru Pacman i get File is corrupted message.
Cheers
Dave

Hmmm what exactly stand there?
Are you sure that the file is downloaded correctly?

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

croniksoft

what fix,i read everyhting and i din"t see naything about installing a fix
if there is please link me  :)

by the way,I'm new to this web stuff but I'm really intrested in how to make mobs.i got some experience in C and python
i have a dream and you could be part of it


ディン1031

Quote from: croniksoft on December 01, 2005, 03:55:41 AM
what fix,i read everyhting and i din"t see naything about installing a fix
if there is please link me  :)

by the way,I'm new to this web stuff but I'm really intrested in how to make mobs.i got some experience in C and python
No, No, you installed 1.13Fix version this is only for fixing a error in old version 1.13 XD.
You must install Version 1.15 to made the mode workable :x.

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

VenimK

#130
using hide and code does 'nt work also not has it should

also does 'nt work has it should i think



Using on SMF 1.1 rc1

ディン1031

#131
Quote from: VenimK on December 07, 2005, 12:34:19 PM
using hide and code does 'nt work also not has it should

also does 'nt work has it should i think



Using on SMF 1.1 rc1

How did you use it?

[hide]blah blah[/hide]
and also [hide]hidden thing[/hide] should work.

[hide]blahahahahaha[/hide]
It's logic that this would not work, because the hide never beginn, because the parser don't parse the code tag... hmm i can remove it, i think... but this could made some very strange things in your post << because the code tag never closed...

I think about to fix it... but i'm sure this is not so fine :X...

if you not use one of the ways above, please tell it :).

Bye
DIN1031
and why should user do something like that?
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

Elmacik

din1031,
Default BBC tags close themselves ayutomatically even the user doesnt.
For example if you start with [color=red] and do not close the color tag, it will automatically close it and make all the post red... All other dtags are the same..
Just for your opinion ;)
Home of Elmacik

VenimK

When using

code - hide -here some text hide - code

i get this to see in my posting

Code:
[hide]blahahahahaha
[/hide]

When i use
code
hide - here some text - hide
code

i get this to see in my posting
Code:
[hide]Wat is de code tag ?[/hide]

Weird ain 't it !!!!!

ディン1031

hum... i hate the the code tag :P... okay i try to remove it this weekend ;).

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

VenimK

Quote from: din1031 on December 09, 2005, 05:19:14 AM
hum... i hate the the code tag :P... okay i try to remove it this weekend ;).

Bye
DIN1031

Thx in advance m8

souluna

This mods works great on my SMF 1.05 and i've modified the code to make it different from the other message. But when i try to insert the code i get over space between last text and code.

I use this text for posting
[hide]Download link: http://xxxxx.com/xxx/xx.zip[/hide]

And i get this screen


Too much space between last text [download link:] and unhidden/hidden image

How about others?

ディン1031

#137
Quote from: VenimK on December 09, 2005, 05:26:35 AM
Quote from: din1031 on December 09, 2005, 05:19:14 AM
hum... i hate the the code tag :P... okay i try to remove it this weekend ;).

Bye
DIN1031

Thx in advance m8
Sorry i can't remove this error, because i can not redone it... or rebuilt it... i use so many versions of cods an in all version it work....

@souluna
I don't know why this is XD, must be some error in you html code :X
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

souluna

Hi DIN, i'm just modifi the code at Subs.php with this code

<edit file>
$sourcedir/Subs.php
</edit file>

<search for>
// Nothing to parse... ?
if (!strstr($message, '[') && !strstr($message, '://') && !strstr($message, '@') && !strstr($message, '/me') && !strstr($message, '&lt;'))
return;
</search for>

<add before>

// The HideTag :)
if (!isset($modSettings['hide_hiddentext'])) $modSettings['hide_hiddentext'] = ' '; //A tiny little space =)
$codefromcache[] = "~\[hide\](.+?)\[\/hide\]~i";
if (!empty($context['user_post_avaible'])) {
if ($context['user_post_avaible'] == 1)
        $codetocache[] = '<table valign="top" width="95%" align="center">
<tr><td valign="top" align="center"><img src="http://souluna.com/forum/unhidden.png" width="242" height="76"></td></tr>
<tr><td valign="top">Hidden text:</td></tr>
<tr><td valign="top" style="border: 1px inset; padding: 5px; background-color: #e4e4e4;">$1</td></tr>
</table>';
        else
    $codetocache[] = $modSettings['hide_hiddentext'];
    }
else
    $codetocache[] = $modSettings['hide_hiddentext'];
</add before>


I'm still confuse until now  ???  :P

ディン1031


<table valign="top" width="95%" align="center" CELLSPACING=0 CELLPADDING=0>
<tr>
<td valign="top" align="center">
<img src="http://souluna.com/forum/unhidden.png" width="242" height="76">
</td>
</tr>
<tr>
<td valign="top">
Hidden text:
</td>
</tr>
<tr>
<td valign="top" style="border: 1px inset; padding: 5px; background-color: #e4e4e4;">
$1
</td>
</tr>
</table>


hmmm try this, i hope this solve the poblen... but i could also come from the hidden text :) because if you write
[hide]
blah
[/hide]

the retuns also come into the $1. They are not removed! (test it with [hide]test[/hide] to find out if this the problem.)

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

Advertisement: