• Welcome to Simple Machines Community Forum. Please login or sign up.
November 28, 2021, 09:28:57 PM

News:

Want to get involved in developing SMF, then why not lend a hand on our github!


[Solved] Four Or More [url] tags becomes a 403 Error When Posting

Started by oldbushie, January 10, 2013, 10:49:46 PM

Previous topic - Next topic

oldbushie

I'm not sure where in the code this is occurring, but if I try putting more than three url tags in a post on our forums I get a 403 error:
http://www.postudios.com/blog/forum/index.php [nofollow]

Strangely enough, I can put as many non-bracketed urls as I want in a post and it doesn't go nuts.

It seems to work fine here though...
Google [nofollow]
Google [nofollow]
Google [nofollow]
Google [nofollow]

What should I check in our theme? I'm not overriding very much and I only have a few basic mods installed.

mashby

QuoteI only have a few basic mods installed
Which ones?
What topic is giving you grief? The link you provided is to your board index. A link to the topic would be more beneficial.
Always be a little kinder than necessary.
- James M. Barrie

Arantor

I don't think it's anything to do with the way you have it configured. I'm pretty certain that it is your host's configuration, and specifically a thing called mod_security, which has a habit of fouling up pretty much anything by testing for arbitrary rules of content and preventing it from being used.
No good deed goes unpunished
All helpful urges should be circumvented

mashby

Sidenote: That's the best modification of the Anecdota theme I've seen ever. Without it being in the footer, I never would have known.
Always be a little kinder than necessary.
- James M. Barrie

Night09

Have you tried just enabling Automatically link posted URLs in the BB code settings? You dont need URL tags then.

Theres little point using the tags if the result is the same unless theres a specific reason you want them included.

oldbushie

They do automatically get printed out, if I post straight urls, yeah. The problem is that sometimes we like to, well, hide the url itself and just show the name of the site, as I pointed out above. And it's happening on any thread, or on a new thread, so it's not context-specific. The 403 only happens when I hit submit and subsequently the post doesn't get posted.

I'll definitely bug our network admin guy about mod_security, that might also be why stuff like --- is rejected from posts.

And I'm glad you like the modification, mashby! :D Our original forum guys modded Anecdota for SMF 1 but I had to wrassle with the SMF 2 version of the theme for the past 5 days to get it working the way it was before. Well worth the update.

Night09

I had URL issues on a forum until I turned of the WYSIWYG editor, theres a topic on the site here somewhere over it. Basically if it was on or off affected the URLs  when trying to do as you say and mask them in some text.

oldbushie

Turning off WYSIWYG doesn't help; it must be something on the server settings end.

Arantor

Quote from: Arantor on January 10, 2013, 10:54:35 PM
I don't think it's anything to do with the way you have it configured. I'm pretty certain that it is your host's configuration, and specifically a thing called mod_security, which has a habit of fouling up pretty much anything by testing for arbitrary rules of content and preventing it from being used.
No good deed goes unpunished
All helpful urges should be circumvented

oldbushie

Our network admin finally managed to find the right people at the webhosting company to fix the ModSec issues. We can now post multiple urls and discuss poker again!

Advertisement: