News:

SMF 2.0.19 has been released! Please update. Read more.

Main Menu

Bookmarks

Started by Matthew K., July 16, 2007, 01:07:24 PM

Previous topic - Next topic

searchgr

Quote from: Arantor on February 10, 2010, 04:15:21 AM
searchgr: The author is busy trying to work on SMF itself... which would you rather have, SMF 2.0 RC3 get a bit closer to release, or this mod updated for RC2?

I want to install it on smf 2.0 rc2

Arantor

So you'd rather delay RC3 then?

searchgr


Arantor

Great, so let me get this straight: you want to pull one of the remaining SMF team (developers, I might add) off working on RC3 which has hundreds of bug fixes and HOLDS EVERYONE ELSE UP, just because you won't follow the instructions in the last page on how to add the mod for RC2? Gee, I hope no-one else agrees with you. I'd much rather have RC3.

Do the parser for 2.0b4, and replace the 2.0 installer with the one I outline in http://www.simplemachines.org/community/index.php?topic=182923.msg2496503#msg2496503

searchgr

ok, i can wait... i'm not in a hurry

Eclipse16V

Nice Mod

Please update it for SMF 2.0RC3  ;)

Thanks
I worked with:
SMF 2 in German

Shop:
SID Giessen

jsamples


The problem I have is that I have is that I had the "Failed" warning with default/index.template.php, so I tried to install manually only to find this file did not have a string "if (in_array($context['current_action'], array('search'," anywhere inside. In fact the file did not even have a string of "search" anywhere in it.

For the most part I am up to date with ver 1.1.11, and I originally came here looking for a fix, but when I just now looked at the version of the "index.template" it said merely 1.1.  So I am now perplexed as to why the file was not updated in the first place to later versions, as well as why is it that I am missing the basic peices to apply your mod.   So, I guess this is just a heads up to you that your mod will not work if the Index.Template is v1.1.

Thanks for the mod anyways... :-)



Bugo

#527
It is updated mod, compatible with SMF 2.0 RC3 (added russian translation)


moderator note: Attachment has not been validated by the mod team, nor approved by the mod author. It has been removed pending review.

Eclipse16V

Thanks Bugo

Here the edit German UTF8
$txt['bookmarks'] = 'Meine Lesezeichen';
$txt['bookmark_list'] = 'Lesezeichen';
$txt['bookmark_list_empty'] = 'Du hast momentan keine Lesezeichen angelegt. Dies kannst Du mit \'Lesezeichen hinzufügen\' in den einzelnen Themen machen.';
$txt['bookmark_open_window'] = 'In neuem Fenster öffnen';
$txt['bookmark_delete'] = 'Lesezeichen löschen';
$txt['bookmark_delete_success'] = '%1$s Lesezeichen wurde(n) erfolgreich gelöscht!';
$txt['bookmark_delete_failure'] = 'Nicht alle Lesezeichen konnten gelöscht werden.';
$txt['bookmark_add'] = 'Lesezeichen hinzufügen';
$txt['bookmark_add_success'] = 'Thema erfolgreich zu Deinen Lesezeichen hinzugefügt!';
$txt['bookmark_add_exists'] = 'Dieses Thema befindet sich bereits in Deinen Lesezeichen!';
$txt['bookmark_add_failed'] = 'Es ist ein Fehler beim hinzufügen des Themas zu Deinen Lesezeichen aufgetreten!';
$txt['permissionname_make_bookmarks'] = 'Lesezeichen speichern';
$txt['cannot_make_bookmarks'] = 'Sorry, aber Du hast keine Berechtigung Lesezeichen zu speichern.';
I worked with:
SMF 2 in German

Shop:
SID Giessen

Eclipse16V

i`ve been update the template

look at the attachments
I worked with:
SMF 2 in German

Shop:
SID Giessen

kizer

Quote from: Bugo on March 21, 2010, 06:12:43 AM
It is updated mod, compatible with SMF 2.0 RC3 (added russian translation)

Thank you for your effort and covering the author un-offically. ;)
Works great.
Own a Jeep? Links4Jeeps.com

Kindred

Buggo,

1- please do not release mods which are currently owned by someone else
2- do not release mods as attachments in the thread. Only mods submitted to the mod site are validated  by the team. Attachments may contain poorly coded updates or malicious coding.

Pending approval by Aaron, I have removed your attachments
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Arantor

Bugo:
1. Kindred is incredibly busy trying to sort out the mess. I'm surprised he bothers to drop into the forum at all to be honest.

2. He personally hasn't insulted anybody.

3. I appreciate the effort you've put in to updating mods but strictly speaking he is correct; unless the author says they are happy for mods to be updated, any mod in a thread is at best unofficial, it can pose a security risk, and is of questionable legality because you are modifying a file that you do not hold the copyright on (especially since unless explicitly stated otherwise, mods fall pretty much into the SMF licence which says no redistribution except from original source)

4. Aaron, the mod's author, has not had time to update this officially for RC2 let alone RC3 because he's been busy working on SMF itself.

Kindred

sorry about the name... one g becomes two gs easily when you are typing fast. :P

Arantor has said the rest.
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

TurtleKicker

If this is the new policy a ton of unofficial updates for long-abandoned mods are going to get blacklisted and a ton of people who have become dependent on said unofficial updates are going to get very upset.

Considering how SMF mods need to be updated for every minor update/beta/RC/etc, and how many important and useful mods have been abandoned with no continuity established, it has been a long-standing tradition on these forums for other people to step up to the plate and post unofficial updates that contain the necessary fixes to make these mods continue to work with the latest SMF releases. I've lost track of how many dozens I've seen continue that way for months or even a year or more. It's gone on for so long with so many mods that I got the impression that it was "accepted" as a necessary consequence of SMF's license (or, lack of user-friend mod license) and SMF's version-dependent mod system.

I'd mention their names but now I fear for their safety.

Arantor

Actually, this is nothing new. Several mod authors do already ask for this anyway.

But actually mods don't always need to be updated for every minor update. Most of mine required little or no change going from 1.1.10 to 1.1.11 and with 80% of my mods I could have actually avoided doing anything at all by setting the version ahead of time, just I'm not that trusting.

It is perfectly OK - and always has been - to publish notes on making it compatible. Repackaging is borderline, depends on the author. I'd be offended if someone repackaged a mod of mine without asking me first. The key word is permission - if you have people who are long since gone, odds are they don't care.

But if they're still active, it would be prudent to ask first.

Kindred

this is getting off topic, but to address the issue

As Arantor says, this is nothing new. This has ALWAYS been the policy.
If a mod author has not been active in a long time, then a user may send a message to the customization team asking if the mod qualifies as "abandoned" and may be given permission to re-publish. Sometimes, the authors will specifically state that they have given up support of the mod: in which case there are two scenarios 1- the author gives up support but does not grant permission to continue. In this case, the mod will eventually be taken down from the site or 2) as in that case of my two mods, the author posts that anyone who is interested should step forward and be given permission to take it over.
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Prosoi

Thanks! Mod works on my SMF2.0 RC2 and RC3. I've just edited Subs/Display.php manually and language/Modifications.russian-utf8.php

$txt['bookmarks'] = 'Закладки';
$txt['bookmark_list'] = 'Закладки';
$txt['bookmark_list_empty'] = 'У Вас ещё нет закладок. Добавить закладки можно нажав на ссылку "Добавить закладку" внутри топиков.';
$txt['bookmark_open_window'] = 'Открыть в новом окне';
$txt['bookmark_delete'] = 'Удалить выделенные';
$txt['bookmark_delete_success'] = 'Было удалено закладок: %1$s!';
$txt['bookmark_delete_failure'] = 'Не все закладки удалились.';
$txt['bookmark_add'] = 'Добавить закладку';
$txt['bookmark_add_success'] = 'Топик был успешно добавлен в Ваши закладки!';
$txt['bookmark_add_exists'] = 'Этот топик уже есть в Ваших закладках!';
$txt['bookmark_add_failed'] = 'При добавлении закладки произошла ошибка.';
$txt['permissionname_make_bookmarks'] = 'Создавать закладки для топиков';
$txt['cannot_make_bookmarks'] = 'Извините, у Вас нет разрешения добавлять закладки.';

Eddy Matthews

Would it be possible to modify this mod so it bookmarks individual messages OR entire topics? It would be much more useful if it could be done?

Regards
Eddy

Bugo

Please update mod => translations for UTF8

Advertisement: