• Welcome to Simple Machines Community Forum. Please login or sign up.
October 20, 2021, 11:09:03 AM

News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord


Traduzione Spartana Mod

Started by dario1984, May 05, 2010, 09:12:39 AM

Previous topic - Next topic

dario1984

May 05, 2010, 09:12:39 AM Last Edit: May 12, 2010, 05:19:13 PM by dario1984
Ciao, una domanda che spero sia di facile soluzione...

Ho scaricato una mod, solamente disponibile in lingua inglese (nello specifico Download System o qualcosa di simile per la versione 2.0RC3).

Ho provato in una maniera del tutto spartana a copiare il file download.english.php tradurre le voci che mi interessavano, e caricarlo nella stessa cartella con nuovo nome Downloads.italian.php.

Il risultato ottenuto ovviamente è quello previsto. NON FUNZIONA

Cos'altro c'è da fare? Esiste una guida per tradurre le singole MOD?

Grazie a tutti

dario1984

Aggiornamento. Ho seguito la guida presente su questo sito ma non riesco ancora a visualizzare la lingua Italiana!!!

Grazie

dario1984

Aggiornamento 2: ho provato la stessa procedura per un'altra mod, la smf gallery, come descritto nel sito citato nel messaggio precedente. ma anche in questo caso non mi funziona. preciso che ho la versione smf 2.0RC3 e che la versione della mod descritta nelle istruzioni è differente da quella da me installata.

Consigli??

Grazie 1000

emanuele

La procedura è quella, se l'hai seguita deve funzionare...
Quote from: dario1984 on May 05, 2010, 09:12:39 AM
Ho provato in una maniera del tutto spartana a copiare il file download.english.php tradurre le voci che mi interessavano, e caricarlo nella stessa cartella con nuovo nome Downloads.italian.php.
?
I nomi dei due file non sono uguali. Errore nello scrivere qui o errore nel creare i file? (attenzione che se sei su linux vi è differenza anche tra lettere maiuscole e minuscole!! ;))

Questo potrebbe essere un motivo per cui non funziona.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

dario1984

Errore di trascrizione. i due file presi dalla cartella /forum/themes/default/languages/ sono i seguenti:


  • Downloads.english.php
  • Downloads.italian.php

Ad ogni modo uso Hosting Windows su Aruba.it

Grazie

emanuele

Ti da qualche errore mentre navighi oppure ne registra qualcuno nel log degli errori?


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

dario1984

No, semplicemente le 2 mod sono ancora in lingua inglese. Ho provato a cambiare lingua, passando all'inglese, poi ancora all'italiano ma nulla.

Il sito è www.urgenzaemergenza.it/public/forum ma le due sezioni sono visibili agli utenti registrati...

Ciao

emanuele

Il fatto che rimanga in inglese è strano, di solito dovrebbe mostrare spazi vuoti dove invece ci dovrebbero essere le scritte e errori nel log...

Due cose:
1) hai già provato anche con il tema di default?
2) sicuro di non aver magari caricato il file solo con il nome diverso, ma senza averlo tradotto? (Se faccio queste domande è perché sono io il primo a fare lavori simili... ;))

Per completezza, metteresti il link al mod?


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

dario1984

May 07, 2010, 04:08:35 AM #8 Last Edit: May 07, 2010, 04:12:39 AM by dario1984
Ciao, parto rispondendo alla domanda numero 2... Mi ci hai fatto pensare davvero a lungo, ho controllato, ma il file è tradotto e caricato

Domanda 1: passando al tema originale (curve) compare l'italiano, passando al core NO

ho provato a cercare il file Modifications.italian.php nella cartella /themes/core/languages ma non esiste. devo crearlo io oppure è proprio la cartella errata?

a che link ti riferisci esattamente??????

emanuele

Quote from: dario1984 on May 07, 2010, 04:08:35 AM
Domanda 1: passando al tema originale (curve) compare l'italiano, passando al core NO

ho provato a cercare il file Modifications.italian.php nella cartella /themes/core/languages ma non esiste. devo crearlo io oppure è proprio la cartella errata?
In teoria non dovrebbe essere necessario, ma...rispondi alla domanda dopo che voglio provare a controllare una cosa.

Quote from: dario1984 on May 07, 2010, 04:08:35 AM
a che link ti riferisci esattamente??????
Mi riferisco al link alla pagina da cui hai scaricato il mod...che sarà da qualche parte qui immagino. ;)


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

dario1984

Mod scaricata in lingua originale da QUI

La traduzione presa da QUI

emanuele

Domani faccio qualche prova.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

dario1984

grazie, per ora non son riuscito a risolvere!! spero a te vada meglio

Ciao

emanuele

May 08, 2010, 07:57:30 AM #13 Last Edit: May 09, 2010, 04:11:39 AM by emanuele
Visti i post successivi, ritratto quanto detto.

eh già, pare proprio che con SMF2 il meccanismo delle traduzioni sia cambiato...

Adesso devi mettere i file di lingua anche nella cartella "languages" del tema che stai usando.
Quindi nel tuo caso dovrai mettere le traduzioni nella cartella "languages" del tema "core"...


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

dario1984

Ma io l'ho gia fatto, o almeno così penso ;D.
Ho inserito nella cartella .../themes/core/languages i seguenti files

  • Downloads.italian.php
  • Modifications.italian.php

Solamente che le altre mod che hanno una traduzione rilasciata originariamente dall'autore mod, ossia che funzionano in italiano, non hanno creato file in questa cartella, cioè funzionano in italiano senza aver copiato le traduzioni nella cartella /themes/core/languages

non riesco davvero a capire.....

dario1984

May 08, 2010, 09:57:14 PM #15 Last Edit: May 08, 2010, 10:01:55 PM by dario1984
Stranezze della vita:

  • Ho cancellato i file delle modifiche
  • Ho disinstallato la mod, con alcune difficoltà (dava test fallito in alcuni passaggi)
  • Ho installato nuovamente la mod senza errori
  • Ho aggiunto i file delle traduzioni

Ora funziona.........

Per tutti: i files vanno copiati nella directory .../themes/default/languages indipendentemente dal tema utilizzato (almeno spero ;D ;D ;D)

Grazie Emanuele per le risposte e per la pazienza; ora provo a fare lo stesso con SMF Gallery  ;D

Ciao

emanuele

Ottimo!

I misteri restano spesso tali...ed ho già visto altri utenti con simili problemi di traduzione, ma non ne capisco la ragione... :-\


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

dario1984

Ciao, non ne posso più  ;D. Ho scoperto un piccolo bug con la versione Italiana, non vorrei dipendesse dalla disinstallazione precedente. Ad ogni modo ecco le immagini che spiegano tutto

foto versione inglese





foto versione italiana


a seguito di vari errori ho cancellato tutto e reinstallato tutto, forum compreso. ho impostato caratteri utf8 (novità, prima non li avevo), ho installato il download system, messo la traduzione in italianoe non funziona ancora............. ciao

emanuele

Appena posso provo ad installarlo in locale (l'altro giorno ho solo guardato il codice), ma non aspettarti niente da parte mia prima di martedì sera... ;)

Comunque confermi che con il tema Default funziona tutto?
Quando fai l'installazione selezioni anche il tema core? (beh, sì altrimenti non apparirebbe proprio niente...domanda stupida...  ::))


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

dario1984

No sinceramente ho dovuto disinstallare tutto, cancellare db e files e reinstallare tutto da zero :D

Ad ogni modo quella mod per il momento non l'ho installata, almeno fino a che non capisco la sequenza esatta, perche una volta funziona l'altra no.

Si quando installavo selezionavo anche il core. Ti aspetto dopo martedì sera... :D

Ciao

Advertisement: