[2.0.16] Authorization from the second time.

Started by Participant, January 14, 2020, 01:39:40 PM

Previous topic - Next topic

shawnb61

Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

live627

I fix one bug and create another. Damn. Savage.

Ulibka

Quote from: shawnb61 on February 19, 2020, 10:13:54 PM
I believe the fix outlined here will resolve this problem:
https://www.simplemachines.org/community/index.php?topic=571082.msg4042818#msg4042818

I'm have same problem.
User with russain letter need to print password twice.
If user and password have only english letters - all work ok.

I'm have SMF 2.017, all tables in UTF-8, language = Russian
I'm do initial installation using SMF 2.017 install and old database.
After installation I'm convert all database tables to UTF8.
and run upgrade.php

Theme is Japanes Red from this site.

I'm patch script.js as described above.

Test site:
https://woodtools.site/index.php

User: test2020
Password: 1234
login - OK

User name in russian letters:
User: Рамза
Password: 12345

In this case user must fill login and password twice.
You can check it byself.
Login in upper left corner

Separet login button have name : Вход

shawnb61

Quote from: shawnb61 on February 19, 2020, 10:13:54 PM
I believe the fix outlined here will resolve this problem:
https://www.simplemachines.org/community/index.php?topic=571082.msg4042818#msg4042818

Ulibka - the solution to your problem was 2 posts above your post.

EDIT:  You may need to force a refresh for that page on your browser.  Usually shift-F5, or shift-refresh.  Otherwise the new .js doesn't get loaded, you are still using the old one. 
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

Ulibka

I'm edit script.js exactly as you described :)
But nothing changes.
I make picture from chrome dev tools:


If I'm try to login :
User name in russian letters:
User: Рамза
Password: 12345

first login: invalid password,
second login: ok

I'm see login form - it's the same as default theme.

shawnb61

Did you refresh your browser as specified above?

Old version of script.js is likely cached.
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

Ulibka

Quote from: shawnb61 on June 05, 2020, 08:38:00 PM
Did you refresh your browser as specified above?

Old version of script.js is likely cached.

Yes, it is.
I'm publish photo from chrome dev tools - you can see that code was changed.

shawnb61

I have confirmed that the above fix works fine on a vanilla 2.0.17 install with the user ID and password you have provided.

You have something else going on...

Initial guess is that there is an issue with your UTF8 implementation somewhere. 

I would ensure that:
- All ***columns*** are utf8_general_ci; not just tables, look at the columns
- In your settings table, global_character_set is set to: 'UTF-8'
- In settings.php, you see the row for: $db_character_set = 'utf8';

If all of the above is true, you have some deeper problem somewhere...  You need to try all vanilla code + the fix above in a test environment.
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

shawnb61

Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

Participant


shawnb61

This issue was fixed.

Make sure yoir copy of script.js is current.

Sometimes you need to do a hard refresh on your browser to reload the current one.  (Shift-f5)
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

Participant

Quote:
Make sure yoir copy of script.js is current.

I just installed the Patch from the Admin.
(Shift-f5) did not help.

Participant

Clearing history, cache and everything else of the browser helped.

Advertisement: