News:

SMF 2.0.19 has been released! Please update. Read more.

Main Menu

Avatars Display Integration

Started by Pipke, February 15, 2020, 07:43:21 PM

Previous topic - Next topic

Michael Vail

Hello Everyone,

I'm running an SMF 2.1.2 forum using the default theme. My forum has this Mod installed as well.

Like in other forums, some of our members have avatars they've chosen from the SMF Avatar Gallery in the profile editor. Others have never selected an Avatar for their profile.

I recently noticed since upgrading to SMF 2.1 that a new "Initial Avatar" feature now exists in the profile editor area. I'm told that this new feature assigns a silhouette image (/forums/avatars/ default.png) for members who don't choose their own avatar.  What's weird is that even though I've enabled the features of this mod to replace that default image with a circle and the first letter of the display name, a significant number of the members on my forum who have not chosen a custom avatar and have the "Initial avatar" option selected by default are still displaying the default.png as their avatar.

I am able to resolve the issue for each member by  going into their profile and selecting an avatar for the user from the avatar gallery, saving, then reverting back to the the initial avatar setting. I don't have the time to go into a 100+ profiles to fix this that way, and I'm afraid new users will have the same problem. 

Does anyone know why only some users still have the default.png icon even though this mod is installed and the settings are correct to change this behavior? It's not the end of the world if I can't resolve it, it's just weird and I'd like to fix it if possible, 

I have attached a partial member list so you can see what it looks like.

Thank you for your time.

peter_mein

Hello
I use this mod Avatars Display Integration.
I installed this mod: https://github.com/SimpleDesk/Team-Mods-TopicSolved
But now if i solved a theme i can´t see the avatar picture.
Is the mistake in your mod or in the other mod ?
Thanks for your help.

SMF 2.1.2
Avatars Display Integration 1.5.3


gevv

Hello,

Update SMF 2.1.2 to 2.1.3 

Codes appear next to usernames who's online page;

data-adi="buffer_remove_this;">

USER-NICK-NAMEdata-adi="buffer_remove_this;"> (IP)

USER-NICK-NAMEdata-adi="buffer_remove_this;"> (IP)

USER-NICK-NAMEdata-adi="buffer_remove_this;"> (IP)
ElkArte is a modern, powerful community building forum software. https://www.elkarte.net/

Shades.

Quote from: gevv on November 21, 2022, 02:57:37 PMCodes appear next to usernames who's online page;

data-adi="buffer_remove_this;">
I am seeing the same thing after updating to SMF 2.1.3

Until this mod is updated for 2.1.3 go to Admin>Forum>Attachments and Avatars>Avatar Settings and uncheck where it says "Display user avatar on the who's online page". I haven't seen any other errors so far. 8)
ShadesWeb.com - Custom Logos - My Themes on SMF | My Themes on ShadesWeb
https://shadesweb.com

BikerHound.com - Sniffing out the road ahead
https://bikerhound.com

Dream as if you'll live forever; Live as if you'll die today. - James Dean

Pipke

mod updated

Changelog
Version 1.5.4 - Nov 26, 2022
- Fixed who's online page buffer bug, due Who.template update
- Added style for avatar: Curved (square shape with rounded corners)
"If something is wrong, fix it if you can. But train yourself not to worry: Worry never fixes anything."

Click here to view my mods for SMF

Hey 👋 Did i helped... you like what i do. You can now buy me a coffee! ☕

Shades.

SMF 2.1.3
Avatars Display Integration 1.5.4

After installing I have all the options selected (see 2nd attachment) except for the top three but when I go to index.php?action=who I get these errors:

Error
Type of error
Undefined_vars
Error message
8: Undefined index: avatar
File
/home/******/public_html/Sources/AvatarsDisplayIntegration.php
Line
664
URL of page causing the error
https://******.com/index.php?action=who

Backtrace information
#0: smf_error_handler()
Called from /home/******/public_html/Sources/AvatarsDisplayIntegration.php on line 664
#1: adi_integrate_theme_context()
Called from /home/******/public_html/Sources/Subs.php on line 5836
#2: call_integration_hook()
Called from /home/******/public_html/Sources/Subs.php on line 4443
#3: setupThemeContext()
Called from /home/******/public_html/Sources/Subs.php on line 4514
#4: template_header()
Called from /home/******/public_html/Sources/Subs.php on line 4157
#5: obExit()
Called from /home/******/public_html/index.php on line 195

Error
Type of error
General
Error message
8: Trying to access array offset on value of type null
File
/home/******/public_html/Sources/AvatarsDisplayIntegration.php
Line
664
URL of page causing the error
https://******.com/index.php?action=who

Backtrace information
#0: smf_error_handler()
Called from /home/******/public_html/Sources/AvatarsDisplayIntegration.php on line 664
#1: adi_integrate_theme_context()
Called from /home/******/public_html/Sources/Subs.php on line 5836
#2: call_integration_hook()
Called from /home/******/public_html/Sources/Subs.php on line 4443
#3: setupThemeContext()
Called from /home/******/public_html/Sources/Subs.php on line 4514
#4: template_header()
Called from /home/******/public_html/Sources/Subs.php on line 4157
#5: obExit()
Called from /home/******/public_html/index.php on line 195

Error
Type of error
Undefined_vars
Error message
8: Undefined index: link_color
File
/home/******/public_html/Sources/AvatarsDisplayIntegration.php
Line
664
URL of page causing the error
https://******.com/index.php?action=who

Backtrace information
#0: smf_error_handler()
Called from /home/******/public_html/Sources/AvatarsDisplayIntegration.php on line 664
#1: adi_integrate_theme_context()
Called from /home/******/public_html/Sources/Subs.php on line 5836
#2: call_integration_hook()
Called from /home/******/public_html/Sources/Subs.php on line 4443
#3: setupThemeContext()
Called from /home/******/public_html/Sources/Subs.php on line 4514
#4: template_header()
Called from /home/******/public_html/Sources/Subs.php on line 4157
#5: obExit()
Called from /home/******/public_html/index.php on line 195

Also, it shows my (Admins) avatar on the whos online page but not guests. (see 1rst attachment)

You cannot view this attachment.

You cannot view this attachment. 
ShadesWeb.com - Custom Logos - My Themes on SMF | My Themes on ShadesWeb
https://shadesweb.com

BikerHound.com - Sniffing out the road ahead
https://bikerhound.com

Dream as if you'll live forever; Live as if you'll die today. - James Dean

Pipke

@Shades. try the file in the attachment and replace it at /Sources folder, let me know if it solves the issues.

"If something is wrong, fix it if you can. But train yourself not to worry: Worry never fixes anything."

Click here to view my mods for SMF

Hey 👋 Did i helped... you like what i do. You can now buy me a coffee! ☕

Shades.

Quote from: Pipke on November 27, 2022, 12:36:25 PM@Shades. try the file in the attachment and replace it at /Sources folder, let me know if it solves the issues.


Yes that fixed it and no errors now. Thank you! 8)
ShadesWeb.com - Custom Logos - My Themes on SMF | My Themes on ShadesWeb
https://shadesweb.com

BikerHound.com - Sniffing out the road ahead
https://bikerhound.com

Dream as if you'll live forever; Live as if you'll die today. - James Dean

Pipke

Quote from: Shades. on November 27, 2022, 04:18:46 PM
Quote from: Pipke on November 27, 2022, 12:36:25 PM@Shades. try the file in the attachment and replace it at /Sources folder, let me know if it solves the issues.


Yes that fixed it and no errors now. Thank you! 8)

thx, i have updated the download package with the new file.
"If something is wrong, fix it if you can. But train yourself not to worry: Worry never fixes anything."

Click here to view my mods for SMF

Hey 👋 Did i helped... you like what i do. You can now buy me a coffee! ☕

Advertisement: