• Welcome to Simple Machines Community Forum. Please login or sign up.
November 29, 2021, 06:03:11 PM

News:

Want to get involved in developing SMF, then why not lend a hand on our github!


email Inactive Users

Started by Suki, April 19, 2014, 02:00:47 PM

Previous topic - Next topic

petewadey

Just ones like this. All Line 909

http://bsac10c11c12.co.uk/smf/index.php?pretty;action=admin&area=eiu;sa=generalApply : in_array() expects parameter 2 to be array, boolean givenApply  /home/lrdvgak/public_html/smf/Themes/default/Admin.template.php
Line: 909

Suki

OK, what do you exactly mean by "backing up" and "page not found"?
Disclaimer: unless otherwise stated, all my posts are personal and does not represent any views or opinions held by Simple Machines.

Making tough decisions, so you don't have to.

petewadey

When the mod is installed, if I go to my email queue, I see emails there that have been waiting to be sent, just a couple, and not related to the mod. When I try to send the emails, I get page not found message. If I uninstall the mod, then go to email queue, the queue is empty. So the emails sent as they should, but wouldn't with the mod installed.
Same thing with scheduled tasks. When I try to run any task with mod installed I get the same page not found message. Uninstall the mod and tasks will run as normal?
Thanks for help

Suki

Can you show me a screenshot of that "page not found" error
Disclaimer: unless otherwise stated, all my posts are personal and does not represent any views or opinions held by Simple Machines.

Making tough decisions, so you don't have to.

petewadey

Not done this before. Hope it works

Suki

I mean an actual image of your screen, you can use the "PrntScr" key to create it and then use some image manipulation program to save the image
Disclaimer: unless otherwise stated, all my posts are personal and does not represent any views or opinions held by Simple Machines.

Making tough decisions, so you don't have to.

petewadey


petewadey


Suki

and are you sure there isn't any error related to that page in your error log?  the only thing I can think of is the mod missing some files and your host been configured to fire a 500 error if there is a PHP error, that also might explain why SMF doesn't catch it.

Follow the mod's manual instructions: https://custom.simplemachines.org/mods/index.php?action=parse;mod=3849;attach=239036;smf_version=2.0.15

And be sure you have all the files this mod adds in their correct locations. Also, if you have access to your error log (your hosting error log, NOT SMF's) take a look at it and see if theres any error related to that page.

Disclaimer: unless otherwise stated, all my posts are personal and does not represent any views or opinions held by Simple Machines.

Making tough decisions, so you don't have to.

petewadey

Thanks for your help. I have to go out now, but will be straight on it tomorrow.

petewadey

I have 2 ./Sources/ScheduledTasks.php files, applications/x-httpd-php and text/x generic. Both have seem to have the same content. Which one should I edit? (I will make a copy before I touch it)
Also, should I uninstall the mod and delete it before doing a manual install, or just replace the existing script?
Thanks for your patience. I am keen to learn

petewadey

I don't know if the attached is of any help, but scroll down and there seems to be more script than there is in the manual install script?

petewadey


Suki

That file looks OK at first glance. Did you had the chance to look at your hosting error log?
Disclaimer: unless otherwise stated, all my posts are personal and does not represent any views or opinions held by Simple Machines.

Making tough decisions, so you don't have to.

petewadey

I asked my host to and they couldn't find anything?

Suki

Did they know what to look for?

Are you able to grab a copy of those logs?

Did you make sure that all files this mod uses are placed in their correct locations?, besides the change on the file you attached, there are several files that need to be placed in their correct locations.
Disclaimer: unless otherwise stated, all my posts are personal and does not represent any views or opinions held by Simple Machines.

Making tough decisions, so you don't have to.

petewadey

I've asked for a copy of the error logs and they replied
"Please let us know how we can reproduce the error exactly step by step, the URLs involved and the access credentials if necessary."
What should they be looking for?
Thanks

Suki

In all honestly,it will be easier if you just go look and see if all the files this mod uses are properly placed in their correct location, you just need to follow the mod's parser. There is a wiki page on how to use it.

If you don't want to do that,then ask for a copy of your error log and send me a link to it over pm.
Disclaimer: unless otherwise stated, all my posts are personal and does not represent any views or opinions held by Simple Machines.

Making tough decisions, so you don't have to.

petewadey

I'm on the case with my host. Will take your advise if they can't help.
Thanks for your patience
Pete

petewadey

Ok, Looks like I'm going to check/ replace files using the mod's parser.
Questions
Should I uninstall and delete mod, then reinstall manually or work with what is already in the files?
Is it ok to use this program to do so https://www.smfhacks.com/smf-package-parser.html
Thanks

Advertisement: