• Welcome to Simple Machines Community Forum. Please login or sign up.

Responsive Curve

Started by SMF Customization Team, April 20, 2015, 06:33:49 AM

Previous topic - Next topic

njtweb

No, I have the original version 1.0.0 that's all. I downloaded that one last week and attempted install but got failures on every single file so I backed out and forgot about it after I advised her I got nothing but failures. Today cleaning up I saw it there and was ready to delete but I'm afraid my site will break if I do it.

lurkalot

Well, yes if the package you want to delete isn't installed you should be able to delete it.

Sir Osis of Liver

Tryuing to get post separator to display in mobile.  Fixed css so it shows on pc, but it's removed in mobile.

Display.template.php



// Show the member's signature?
if (!empty($message['member']['signature']) && empty($options['show_no_signatures']) && $context['signature_enabled'])
echo '
<div class="signature" id="msg_', $message['id'], '_signature">', $message['member']['signature'], '</div>';

echo '
</div>
</div>
<span class="botslice"><span></span></span>
</div>
<hr class="post_separator" />';



index.css



/* Separator of posts. More useful in the print stylesheet. */
#forumposts .post_separator
{
// display: none;
}



"The best laid schemes o' mice an' men / Gang aft a-gley." - Robert Burns

Kindred

CSS uses the same "block comment" syntax as the C-like languages - you start a comment with /* , and end it with */ . However, CSS is missing the "line comment" syntax that those languages have, where everything from // to the end of the line is commented out

in other words...   the // is not actually commenting out that line because css does not allow //
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Gwenwyfar

Since it is invalid syntax it may just be breaking the selector/rule, or it could be breaking other things also.   
"It is impossible to communicate with one that does not wish to communicate"

Sir Osis of Liver

Quote from: Kindred on July 09, 2018, 08:58:50 AM
in other words...   the // is not actually commenting out that line because css does not allow //

Use it all the time, for years, it's never not worked.  Problem is due to caching, apparently some mobile browsers cache css but not template or source code, so all changes are effective immediately except css, which requires refresh.  But I will delete the line anyway, just to be strict.

"The best laid schemes o' mice an' men / Gang aft a-gley." - Robert Burns

Sir Osis of Liver

Installed this mod on forum running 2.0.15 Curve Multi Color, users are having problems on iphones and android phones.  Theme doesn't fit display, they have to scroll horizontally to read content.  Also reporting a glitch with reply editor, it opens way to large, only room for 2-3 characters, but works ok after they pinch it down.
"The best laid schemes o' mice an' men / Gang aft a-gley." - Robert Burns

njtweb

Quote from: Sir Osis of Liver on August 10, 2018, 12:49:10 PM
Installed this mod on forum running 2.0.15 Curve Multi Color, users are having problems on iphones and android phones.  Theme doesn't fit display, they have to scroll horizontally to read content.  Also reporting a glitch with reply editor, it opens way to large, only room for 2-3 characters, but works ok after they pinch it down.

The newly updated responsive curve or the old version?

I had the same problem on mobile, (currently using original responsive curve mod) only when I was posted youtube videos using the O'Hara youtube embed mod. I removed that mod and installed a different one and the problem went away.

Sir Osis of Liver

It's ver 1.0, that's what's currently on mod site.  They're not using any youtube mod.  May be a problem with Curve MC, I've switched everyone to default Curve, waiting for feedback.
"The best laid schemes o' mice an' men / Gang aft a-gley." - Robert Burns

Kindred

Hmmm... can't reproduce any of those reported issues on my site...
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Sir Osis of Liver

Installed it a few weeks ago on another forum running default Curve, nothing like this was reported.  Did you try it on mobile in Curve MC?
"The best laid schemes o' mice an' men / Gang aft a-gley." - Robert Burns

Kindred

Mmm... not sure, it's been a while since I had the mc theme installed, but I did have it and the responsive curve mod installed at one point
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Sir Osis of Liver

Mod doesn't affect Curve MC at all in pc view, but getting complaints from mobile users.  Haven't gotten any feedback yet on whether problems persist in default Curve, they're just ******ing about the color.
"The best laid schemes o' mice an' men / Gang aft a-gley." - Robert Burns

Sir Osis of Liver

Still trying to fix this, both android and ios users are repoprting problems.  Viewing the forum with android silk, what I'm seeing is responsive theme in default Curve, but pc theme in Curve MC.  Responsive is not loading in MC.  Template code looks correct, responsive.css is in theme css.  Any idea what's causing this?


n/m, found it.  Responsive code must be in .css for color variant, i.e., index_green.css, doesn't work just having responsive.css in theme /css.  Waiting for confirmation from phone users, but it loads correctly in silk.

"The best laid schemes o' mice an' men / Gang aft a-gley." - Robert Burns

Sir Osis of Liver

Looking at Responsive Curve in Android Silk, main menu is invisible in default Curve and Curve MC.  It's there, if I poke around where it should be, menu links work, but it's completely invisible.  Is this another stealth feature, or what?
"The best laid schemes o' mice an' men / Gang aft a-gley." - Robert Burns

Antes

This modification is not created for generic usage, its only valid for Curve theme. Any other theme which has issues with this mod should resolve within.

Sir Osis of Liver

I've installed the mod on two forums, one is running default Curve, the other Curve Multi Color.  I'm seeing the same thing on both, also when I switch to default Curve on second forum.  Navbar is invisible, but if I tap on where it should be, I see a quick blue square, and link works.  Don't know if this glitch is specific to Silk, not having any luck getting screenshots from members using android or iphones.

I know the mod is for Curve, unfortunately it's being recommended in other threads for any theme.  One of my regulars wants to try it in a couple of custom themes, maybe I'll give it a shot and see what happens.

"The best laid schemes o' mice an' men / Gang aft a-gley." - Robert Burns

Sir Osis of Liver

Ok, here are three screenshots from FF61 responsive design mode, they are more or less similar to what I'm seeing in android Silk.

BCM forum default Curve -



MLC forum default Curve -



MLC forum Curve MC -



First one has a row of little icons, no labels or tooltips, additional menu items all use same question mark icon.  Pretty useless, but that apparently is the mod menu.

Second and third there are no icons, but if I poke around where they should be, a small blue square lights up when I hit a menu item and link works.  A lot less then useless.  There are mods and some customizations on both forums.
"The best laid schemes o' mice an' men / Gang aft a-gley." - Robert Burns

Gwenwyfar

Quote from: Sir Osis of Liver on August 12, 2018, 11:35:57 PM
I know the mod is for Curve, unfortunately it's being recommended in other threads for any theme.  One of my regulars wants to try it in a couple of custom themes, maybe I'll give it a shot and see what happens.
It is not being recommended for "any theme". It is being recommended to be tried with themes that may work with it, because it works in many more than just curve. Problems with some themes is expected, and only curve will be supported by the mod.


Without a link to your forum to see what is going on, I'd guess your icon's path is broken or they are missing.
"It is impossible to communicate with one that does not wish to communicate"

Sir Osis of Liver

It installed correctly in default Curve, with one manual edit in Memberlist.template.php.  Are the menu icons in /images/AlternativeMenu.icons/?  They're present in both themes.  Not especially useful if you don't know what they are, there are no labels, and all custom menu items (there are several on this forum) are the same.
"The best laid schemes o' mice an' men / Gang aft a-gley." - Robert Burns

Advertisement: