• Welcome to Simple Machines Community Forum. Please login or sign up.
December 04, 2021, 03:50:23 AM

News:

Follow SMF on Twitter.


Convertire da ipb 3.4

Started by Rungut, February 03, 2013, 06:31:15 PM

Previous topic - Next topic

Rungut

Quote from: emanuele on February 05, 2013, 12:01:07 PM
Prova questa:
select forum_id from ibf_topics where forum_id REGEXP '^[^0-9]+$'

E' comparso questo: http://puu.sh/1Y9MW [nofollow]

Rungut

Sto provando di tutto.
Ho provato anche a cancellare tutto e rifare tutto da capo, ma niente... compare sempre quell'errore.

emanuele

Il problema è che quell'errore non ha senso...
Sarebbe possibile vedere i dati? (intendo, se ti fidi e/o puoi a darmi accesso al database)


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Rungut

Quote from: emanuele on February 06, 2013, 12:18:34 PM
Il problema è che quell'errore non ha senso...
Sarebbe possibile vedere i dati? (intendo, se ti fidi e/o puoi a darmi accesso al database)
Nessun problema, però adesso non ho i dati qua (ce li ho nell'altro PC), entro questa settimana faccio un Rar e te li passo.

Grazie ancora.

emanuele



Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Rungut

February 10, 2013, 10:47:39 PM #25 Last Edit: February 11, 2013, 03:22:38 AM by emanuele
Quote from: emanuele on February 07, 2013, 03:10:00 PM
Meglio zip. :P
Ecco a te :)



La password te la mando in PM ;)

Rungut


emanuele

Soooooooooooooooooooooorry!!!
Non ho avuto tempo...ed ora dovrei essere dietro a fare altro... :'(


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

emanuele



Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

emanuele

Scusa per il ritardo, ho avuto dei problemi con un sito... ::)

Nel blocco:
--- Converting posts (this may take some time)...
trovi la query:
SELECT
p.pid AS id_msg, p.topic_id AS id_topic, p.post_date AS poster_time,
CASE WHEN p.author_name = '' THEN 0 ELSE p.author_id END AS id_member, SUBSTRING(t.title, 1, 255) AS subject,
SUBSTRING(p.author_name, 1, 255) AS poster_name,
SUBSTRING(p.ip_address, 1, 255) AS poster_ip, p.use_emo AS smileys_enabled,
IFNULL(p.edit_time, 0) AS modified_time, SUBSTRING(p.edit_name, 1, 255) AS modified_name,
t.forum_id AS id_board, REPLACE(p.post, '<br />', '') AS body,
SUBSTRING(IFNULL(m.email, 'guest@example.com'), 1, 255) AS poster_email, 'xx' AS icon
FROM {$from_prefix}posts AS p
LEFT JOIN {$from_prefix}topics AS t ON (t.tid = p.topic_id)
LEFT JOIN {$from_prefix}members AS m ON (m.member_id = p.author_id);


cambiala in:
SELECT
p.pid AS id_msg, p.topic_id AS id_topic, p.post_date AS poster_time,
CASE WHEN p.author_name = '' THEN 0 ELSE p.author_id END AS id_member, SUBSTRING(t.title, 1, 255) AS subject,
SUBSTRING(p.author_name, 1, 255) AS poster_name,
SUBSTRING(p.ip_address, 1, 255) AS poster_ip, p.use_emo AS smileys_enabled,
IFNULL(p.edit_time, 0) AS modified_time, SUBSTRING(p.edit_name, 1, 255) AS modified_name,
t.forum_id AS id_board, REPLACE(p.post, '<br />', '') AS body,
SUBSTRING(IFNULL(m.email, 'guest@example.com'), 1, 255) AS poster_email, 'xx' AS icon
FROM {$from_prefix}posts AS p
LEFT JOIN {$from_prefix}topics AS t ON (t.tid = p.topic_id)
LEFT JOIN {$from_prefix}members AS m ON (m.member_id = p.author_id)
WHERE t.forum_id IS NOT NULL;

Notare il "WHERE" aggiunto e il punto e virgola spostato dopo la riga del "WHERE" (just per essere sicuri ;))

ETA: al momento la conversione non è ancora finita, ma sta procedendo.
Se dovesse incontrare altri blocchi riposto le soluzioni.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Rungut

Allora aspetto che mi dai la conferma finale, così provo io ^^

emanuele

C'è un altra modifica da fare in effetti.
Il converter sta ancora girando, appena finisce posto direttamente il file che ho usato...magari anche mettendogli un paio di altri fix che non ho mai aggiunto...


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

emanuele

Postato una nuova versione del converter qui:
http://www.simplemachines.org/community/index.php?topic=477019.0
Allegato al primo messaggio.

Il problema era che probabilmente IPB mantiene molte informazioni anche se gli utenti sono stati cancellati e così il converter si ritrovava con utenti inesistenti.

Ho messo a posto anche la conversione degli smiley in messaggi e PM, la conversione degli smiley stessi, e qualche altra cosuccia.
Spero funzioni correttamente! ;D


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Rungut

Utilizzando quei file posso fare la conversione senza modificare niente?

Sei un grande!

emanuele

Spero... O:)
Io l'ho fatta usando quella coppia di file (riscarica anche upgrade.php perché ho cambiato qualcosa anche in quello ;)).


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Rungut

Quote from: emanuele on February 16, 2013, 03:54:45 AM
Spero... O:)
Io l'ho fatta usando quella coppia di file (riscarica anche upgrade.php perché ho cambiato qualcosa anche in quello ;)).

upgrade.php? i file non sono  ipb3_to_smf.sql e convert.php?

emanuele

Sì, scusa...troppo alcol...o troppo poco, non mi ricordo mai come funziona. :P


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Rungut

Scusa, ma sono stato inattivo (causa problemi con internet) e mi sono dimenticato di ringraziarti :)

Sono riuscito a convertire il foro (anche se con qualche errore), adesso ho modificato in locale e sto trasportando tutto sul web.

Ti ringrazio per tutto l'aiuto che mi hai dato :)

Adesso vorrei curare un po l'aspetto e le applicazioni, così da non far mancare niente agli utenti.

1-Sapresti dirmi se esiste una shoutbox per SMF e dove posso trovare delle mod?
2-Come posso mettere un logo largo quando tutto il forum?
3-Si può inserire una sidebar a destra, nella home?

Il layout che vorrei ottenere è questo: http://puu.sh/2fksL [nofollow]

si può?

Di nuovo, grazie mille :)

emanuele

Per la sidebar dipende da cosa vuoi metterci...
Senza ulteriori dettagli, e viste le richieste, io ti consiglierei SimplePortal...
E' un portale (per darti un'idea: http://www.italiansmf.net/ ), ma se non ti interessa disabiliti la home page ed è come non esistesse, però ha sia uno shoutbox ("primitivo" perché mi pare non supporti aggiornamento automatico in stile ajax, ma fa il suo lavoro) e puoi disporre "cose di contorno" a destra e a manca come più ti pare.

Per il logo...dipende dal tema...esempio recente: http://www.italiansmf.net/index.php?topic=422.0


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Rungut

Adesso do un'occhiata grazie!

Ho trasferito tutto sul web senza errori, ho aggiustato il file setting e il forum funziona :D

Il problema è che i temi hanno ancora gli indirizzi "localhost", quindi non funzionano.
Mi compare la scritta "La cartella predefinita per i temi non è corretta, fare clic su questo testo per sistemarla."
Ho provato a cambiare l'url, ma niente.

Se carico nuovamente un tema mi funziona, però mi compare quest'altra scritta quando tento di accedere all'ACP: Non sei autorizzato ad accedere a questa sezione O_O

Vorrei fare funzionare almeno il tema di default, devo modificare qualche file?

PS: Anche cambiando gli URL del tema, la visuale è questa: http://puu.sh/2fmBu [nofollow]


EDIT: Ci sono riuscito xD

Advertisement: