• Welcome to Simple Machines Community Forum. Please login or sign up.
November 29, 2021, 06:35:34 PM

News:

SMF 2.1 RC4 has been released! Try it out and help us test! :) Read more.


Thousands of callback error messages.....

Started by xposure, August 21, 2014, 06:33:30 AM

Previous topic - Next topic

xposure

August 21, 2014, 06:33:30 AM Last Edit: August 21, 2014, 06:46:25 AM by xposure
I am getting thousands of error messages on my Forum log inn version SMF 2.0.8

2: preg_replace_callback(): Requires argument 2, 'entity_fix__callback', to be a valid callback

I have no mods on the Forum.

Any ideas?

Looking

I did not catch what version your SMF is because of the smiliey face is it 2.0.8? Is your server using PHP 5.5?

xposure

Version 2.0.8

I will find out what PHP version my server uses, thanks.

Arantor

That actually sounds to me like an incomplete 2.0.8 install.
No good deed goes unpunished
All helpful urges should be circumvented

xposure

When I updated to 2.0.8 it said the update was successful.

Arantor

Something went wrong because entity_fix__callback should be defined in Subs.php around line 4344.

Makes me wonder what else is broken.
No good deed goes unpunished
All helpful urges should be circumvented

xposure


Arantor

The PHP version is at this point irrelevant. All the code in 2.0.8 is suitable for any modern version of PHP, it's only *required* for PHP 5.5+.

Your problem is nothing to do with the version of PHP you have. It is because your copy of Subs.php is missing things that it should have. I suspect it is missing other things. Have a look in it for a function called entity_fix__callback, and another one called fixchar__callback or word_break__preg_callback. These things should all be in 2.0.8's copy of Subs.php and the fact you are getting errors suggest they are not.
No good deed goes unpunished
All helpful urges should be circumvented

xposure

I have looked in the 'Modify Theme' section of Admin and  I cannot find subs.php??

Arantor

It's not part of the theme, nor is it accessible from any part of the admin panel. You will have to examine it by way of your hosting control panel or perhaps via FTP.
No good deed goes unpunished
All helpful urges should be circumvented

xposure

I attach subs.php, I downloaded it from my server.

I don't know what I am looking for so any help would be appreciated.

Thanks

Arantor

Your Subs.php file is largely consistent with that from 2.0.6 (save for removing the register button). None of the changes from 2.0.7 or 2.0.8 are installed. Neither, I suspect, are other changes from those releases.

Problem is, if you're missing that, you're probably missing other things from 2.0.7 and/or 2.0.8...
No good deed goes unpunished
All helpful urges should be circumvented

xposure

Thanks, what can I do?

Also, here is the full error message to see if it helps:

Whatever page or action I do on the Forum generates this:

2: preg_replace_callback(): Requires argument 2, 'entity_fix__callback', to be a valid callback

Apply Filter: Only show the errors from this file

File: /home/www/f22lightning3online.com/community/Sources/Load.php(183) : runtime-created function
Line: 3

xposure

I did remove the Register button, hope this hasn't caused the problem?

The Forum works perfectly as well.

Arantor

Honestly, I'm tempted to suggest you nuke all your files and replace them with known fresh 2.0.8 files. If you're missing two patches worth of edits in Subs.php, odds are you're missing far more.

http://wiki.simplemachines.org/smf/How_to_upload_a_fresh_set_of_files for more information.

This will remove all edits and mods, but it will ensure you have a completely correct set of files.
No good deed goes unpunished
All helpful urges should be circumvented

xposure

I have done far too much work to start from scratch  :(

I attach my 'Version' info which looks wrong??

xposure

I think I know what I did to cause the problem. When I removed the Register button I edited the subs.php that was on my local machine not realising that it is an older version of the subs.php that was on my Forum as I had upgraded to 2.0.8.

All I need is the subs.php file that comes with version 2.0.8 to overwrite the old subs.php on my Forum.

Can you supply the subs.php from version 2.0.8 please???

Arantor

You can get it yourself from the large upgrade package - just download and unzip it, and there it is.
No good deed goes unpunished
All helpful urges should be circumvented

xposure


RGMears

Thanks for this suggestion Arantor. I was having similar troubles with a current upgrade to 2.0.17. Comparing the original with the modified Subs.php file worked to eliminate a lot of errors I was getting.

Advertisement: