• Welcome to Simple Machines Community Forum. Please login or sign up.
October 24, 2021, 03:02:03 AM

News:

Follow SMF on Twitter.


TinyPortal

Started by lurkalot, February 12, 2005, 04:43:00 AM

Previous topic - Next topic

JeffGoudreau

ok. thanks :) I will talk to my server dude. He is pretty knowledgable and runs a large SMF. Maybe he can upgrade it with 0 probs. If not Im happy with the Dinosaur :p

Anpu

Quote from: Bloc on September 01, 2010, 03:38:25 PM
Hm, prob. didn't work then. Do you ahve the emans to run/import a SQl file? And can you see in the database if any xxx_tp_xxx tables were created?
You are right, there are no tp tables at all.  :-\
Yes, I can import SQL file.

bloc

Ok, I need to sort it out properly, this can be handy for others too. I'll post it here when its ready.

SilverKnight

Quote from: Bloc on September 02, 2010, 03:34:16 AM
Ok, I need to sort it out properly, this can be handy for others too. I'll post it here when its ready.

Good to see you still working on it Bloc.

JeffGoudreau

ok. I have learned alot :) BUT! now I cant figure out where to check off to make my Left side blocks show up on the front page. The only way to make this happen seems to be if I include it on every page which I dont want to do. I have options for placing the block on all of the boards, admin crap and everything but no option to show it just on the front page. so eventually the whole left side of the home page will look blank. I have sponsors logos I can put in there and I know its possible. Can you try to point me to the right area? One day Im gonna be a pro :)

IchBin™

September 02, 2010, 08:03:53 PM #665 Last Edit: September 02, 2010, 08:14:44 PM by IchBin™
So did you upgrade or not? You indicated you were going to do it, but now I don't know which version you are running. Kind of hard to tell you what to do if I don't know what you're using.

If you're still using TP 0.9.8 the blocks should show on your frontpage by default without needing to set anything.

If you're using TP 1.x there is a checkbox you can select for frontpage.

If you're blocks are not showing, you must have an article or something that is set to not display the blocks or something on the frontpage.
IchBin™        TinyPortal

agridoc

Quote from: JeffGoudreau on September 02, 2010, 07:40:27 PMI have options for placing the block on all of the boards, admin crap and everything but no option to show it just on the front page.

In TP 0.9.8 you create Frontpage blocks, they appear only in Frontpage. You select in Frontpage Settings what and how you want to be displayed in Frontpage.

In TP 1.0 you have much more options. More block areas and for any single block you can choose to be displayed only in Frontpage. It also needs more careful planning.
  For Greek aeromodellers and our friends around the world  - Greek Button sets for SMF - Greeklish to Greek mod
Δeν αφιερώνω χρόνο για μηνύματα σε greeklish.

bloc

Quote from: Anpu on September 02, 2010, 03:24:19 AM
Quote from: Bloc on September 01, 2010, 03:38:25 PM
Hm, prob. didn't work then. Do you ahve the emans to run/import a SQl file? And can you see in the database if any xxx_tp_xxx tables were created?
You are right, there are no tp tables at all.  :-\
Yes, I can import SQL file.

This is a SQL file straight out of a fresh TP install on SMF 2.0RC3. It should work on all SMF2 versions though.

Just import it into phpMyadmin, but remember to change all "smf_tp_" to your prefix first: "{yourprefix}tp_" - if you use anything else than "smf_".

MoreBloodWine

SMF 2.0 RC3
TP Latest

Playing around on a test site, anyway, why do I still have a forum tab / button if I have it set to go to the forum index ?

With the old TP if I had goto forum index set the extra "forum" button vanished.

http://www.eojmarket.com/sigtest/index.php
Want a sig like mine for your BTCGuild stats ? Then check this out: Spend-ur-Bits


bloc

It should not show it..so thats a bug for sure.

MoreBloodWine

Quote from: Bloc on September 06, 2010, 03:18:28 AM
It should not show it..so thats a bug for sure.
Sweet, I just contributed soemthing again lol...

1. Bullets are back...
2. This

;-p
Want a sig like mine for your BTCGuild stats ? Then check this out: Spend-ur-Bits


MoreBloodWine

September 06, 2010, 04:03:56 AM #671 Last Edit: September 06, 2010, 11:10:09 AM by MoreBloodWine
What needs to be changed to take away the hyperlinking of the days that goto a new post page for the mini calendar ?

Everything I've tried either breaks the calendar block or just doesnt work...

global $scripturl;

$now = mktime();
$today = date('j',$now);
$year = date("Y",$now);
$month = date("n",$now);
$days = array($today=>array(NULL,NULL,'<a class="smalltext" style="color: steelblue; font-weight: bold; border: solid 1px black; background-color: white; padding: 0px 4px 0px 4px;" href="'.$scripturl.'?action=calendar;sa=post;month='.$month.';year='.$year.';day='.$today.'" target="_self">'.$today.'</a>'));

$day_name_length = 3;
$month_href = $scripturl . '?action=calendar';
$first_day = 7;
$pn = array();

$first_of_month = gmmktime(0,0,0,$month,1,$year);
//remember that mktime will automatically correct if invalid dates are entered
// for instance, mktime(0,0,0,12,32,1997) will be the date for Jan 1, 1998
// this provides a built in "rounding" feature to generate_calendar()

$day_names = array(); //generate all the day names according to the current locale
for($n=0,$t=(3+$first_day)*86400; $n<7; $n++,$t+=86400) //January 4, 1970 was a Sunday
$day_names[$n] = ucfirst(gmstrftime('%A',$t)); //%A means full textual day name

list($month, $year, $month_name, $weekday) = explode(',',gmstrftime('%m,%Y,%B,%w',$first_of_month));
$weekday = ($weekday + 7 - $first_day) % 7; //adjust for $first_day
$title   = htmlentities(ucfirst($month_name)).' '.$year;  //note that some locales don't capitalize month and day names

//Begin calendar. Uses a real <caption>. See http://diveintomark.org/archives/2002/07/03
@list($p, $pl) = each($pn); @list($n, $nl) = each($pn); //previous and next links, if applicable
if($p) $p = '<span class="smalltext">'.($pl ? '<a href="'.htmlspecialchars($pl).'">'.$p.'</a>' : $p).'</span> ';
if($n) $n = ' <span class="smalltext">'.($nl ? '<a href="'.htmlspecialchars($nl).'">'.$n.'</a>' : $n).'</span>';
$calendar = '<table>'."\n".
'<caption >'.$p.($month_href ? '<a href="'.htmlspecialchars($month_href).'">'.$title.'</a>' : $title).$n."</caption>\n<tr>";

if($day_name_length){ #if the day names should be shown ($day_name_length > 0)
//if day_name_length is >3, the full name of the day will be printed
foreach($day_names as $d)
$calendar .= '<th class="smalltext" abbr="'.htmlentities($d).'">'.htmlentities($day_name_length < 4 ? substr($d,0,$day_name_length) : $d).'</th>';
$calendar .= "</tr>\n<tr style=\"text-align:right;\">";
}

if($weekday > 0) $calendar .= '<td class="smalltext" colspan="'.$weekday.'"> </td>'; //initial 'empty' days
for($day=1,$days_in_month=gmdate('t',$first_of_month); $day<=$days_in_month; $day++,$weekday++){
if($weekday == 7){
$weekday   = 0; #start a new week
$calendar .= "</tr>\n<tr style=\"text-align:right;\">";
}
if(isset($days[$day]) and is_array($days[$day])){
@list($link, $classes, $content) = $days[$day];
if(is_null($content))  $content  = $day;
$calendar .= '<td "'.($classes ? ' class="'.htmlspecialchars($classes).'">' : '>').
($link ? '<a href="'.htmlspecialchars($link).'">'.$content.'</a>' : $content).'</td>';
}
else
{
$calendar .= "<td class=\"smalltext\" style=\"padding-right:4px;\"><a";
if(((($weekday+$first_day) % 7)==0)||((($weekday+$first_day) % 7)==6))
{
$calendar .= ' style="color:#FF0000;"';
}
$calendar .= " href=\"".$scripturl."?action=calendar;sa=post;month=".$month.";year=".$year.";day=".$day."\" target=\"_self\">$day</a></td>";
}
}
if($weekday != 7) $calendar .= '<td class="smalltext" colspan="'.(7-$weekday).'"> </td>'; //remaining "empty" days

echo $calendar."</tr>\n</table>\n";
Want a sig like mine for your BTCGuild stats ? Then check this out: Spend-ur-Bits


bloc

Try adding "text-decoration: none;" right after "color: steelblue;"

MoreBloodWine

Want a sig like mine for your BTCGuild stats ? Then check this out: Spend-ur-Bits


MoreBloodWine

Never caught this until now but whats with all the extra padding for the blocks ?

There's an addition 10px on each side as far as I can tell which means the blocks need to be larger than they did wih 098 to get your content to show properly.

See attached pics...

If possible I would like to be able to control this padding or atleast scale it down to what it use to be if not a tad smaller say something like 4px instead of the 6px that was in 098.
Want a sig like mine for your BTCGuild stats ? Then check this out: Spend-ur-Bits


Kindred

firebug is your friend
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

MoreBloodWine

Quote from: Kindred on September 07, 2010, 09:08:38 AM
firebug is your friend
OMG that was so helpful, thank you for your crypticness !!!!!!!!!
Want a sig like mine for your BTCGuild stats ? Then check this out: Spend-ur-Bits


IchBin™

Quote from: MoreBloodWine on September 07, 2010, 09:14:05 AM
Quote from: Kindred on September 07, 2010, 09:08:38 AM
firebug is your friend
OMG that was so helpful, thank you for your crypticness !!!!!!!!!

There's a link in my sig for you. It's a great tool for firefox that will help you see exactly where the padding is coming from by merely highlight an element on the page.

Should also note, that normally I don't think there is that much padding. If you are using the editor to put the code in, make sure it's not adding extra code for you etc.
IchBin™        TinyPortal

MoreBloodWine

The code is the same unedited version which creates the same block in 098. As for FireBug, I have played around with it before and as for now all I see is something about 8px padding around a div. Even getting rid of all the code and putting in nothing but an echoed Testing 1, 2, 3... thee look is still the same. I know this is a beta and things are bound to change, I was just "putting it out there".
Want a sig like mine for your BTCGuild stats ? Then check this out: Spend-ur-Bits


Kindred

which, to me, indicates a CSS issue....   which is why firebug is your friend.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Advertisement: