News:

SMF 2.0.19 has been released! Please update. Read more.

Main Menu

Characters remaining of post

Started by davidhs, July 01, 2013, 09:48:11 AM

Previous topic - Next topic

davidhs

Quote from: shadav on June 11, 2020, 04:40:11 PM
this mod doesn't seem to work anymore, installed it and used the parse and checked all edits were done correctly

but it doesn't show up...only shows up on the quick modify, doesn't show up on full edit or when creating a new post....
even on default curve theme....
shame because it's a nice thing to have
I test this in my test forum (2.0.17, default theme) and online forum (2.0.17, own theme) and works (create, modify and quick edit post).

Do you have something in error log?
Can you see message Max characters: NNN; characters remaining: MMM bellow of textbox?

shadav

nothing in error logs and no nothing is displayed at all, except on the quick modify
checked all 4 themes i have installed, same issue (curve, greeny, mutant curve, nightbreeze)

davidhs

Quote from: shadav on June 12, 2020, 12:49:06 PM
nothing in error logs and no nothing is displayed at all, except on the quick modify
checked all 4 themes i have installed, same issue (curve, greeny, mutant curve, nightbreeze)
Perhaps you have other mod who modify code and my mod does not work.

Can you attach here these files?

Sources/Display.php
Sources/PersonalMessage.php
Sources/Post.php
Themes/default/Display.template.php
Themes/default/GenericControls.template.php

shadav

Quote from: davidhs on June 12, 2020, 04:38:02 PM
Quote from: shadav on June 12, 2020, 12:49:06 PM
nothing in error logs and no nothing is displayed at all, except on the quick modify
checked all 4 themes i have installed, same issue (curve, greeny, mutant curve, nightbreeze)
Perhaps you have other mod who modify code and my mod does not work.

Can you attach here these files?

Sources/Display.php
Sources/PersonalMessage.php
Sources/Post.php
Themes/default/Display.template.php
Themes/default/GenericControls.template.php

thank you, here's the files

davidhs

I am sorry, I do not see any error in your files, but you have (at least) one mod who add code to textarea of post editor: Tabbed smileys

I installed Tabbed smileys (0.3.7 and 0.3.99d) in my test forum but this not work (I did not see tabs in smileys), and my mod works.

Perhaps another mod?

My mod adds the counter of characters in two files:
- Display.template.php - for quick modify and quick reply (both with not smileys). I am sure both cases work in your forum, correct?
- GenericControls.template.php - for editor with smileys (used in create/modify post and pm). Any of these do not work, correct? Attach here an image of one of these.
(in the other files, on Source, my mod only adds access to language files)

The problem can be another mod who add code in editor with smileys. If you can, try to uninstall some mods (mods related with this).

Warning: I tried adapt my mod to SMF 2.1 but it do not work. Perhaps any of your mod adds code related with SMF 2.1...

shadav

here's the pictures
for some reason now today it seems it's not even working on the quick modify as it had been

yeah I had to edit tabbed smilies to get it to work, don't remember what all I did though, sorry

davidhs

Quote from: shadav on June 13, 2020, 03:09:01 PM
here's the pictures
for some reason now today it seems it's not even working on the quick modify as it had been

yeah I had to edit tabbed smilies to get it to work, don't remember what all I did though, sorry
I think works in your forum but:
- This mod does not work in WYSIWYG mode.
- In quick edit, at beginning counter show "..." instead of a number. When you modify text, number is shown.
Quote from: davidhs on July 01, 2013, 09:48:11 AMThis is shown in:

  • Create/modify post (not WYSIWYG mode only).
  • Create/modify PM (not WYSIWYG mode only).
  • Quick reply.
  • Quick modification of post (does not shown the initial remaining number).

shadav

hm, missed that....searched around found the setting Disable WYSIWYG editor and now it is working
sorry about that  :-[ ... thank you for all of your help and my stupidity
tbh i have no idea what wysiwyg is or does  :laugh:

davidhs

Quote from: shadav on June 13, 2020, 04:46:24 PM
hm, missed that....searched around found the setting Disable WYSIWYG editor and now it is working
sorry about that  :-[ ... thank you for all of your help and my stupidity
tbh i have no idea what wysiwyg is or does  :laugh:
You do not worry :D

About WYSIWYG: https://en.wikipedia.org/wiki/WYSIWYG

Advertisement: