News:

SMF 2.1.3 has been released! Take it for a spin! Read more.

Main Menu

nneonneo's Shoutbox

Started by nneonneo, December 26, 2006, 06:58:11 PM

Previous topic - Next topic

brianjw

Quote from: RoarinRow on February 24, 2007, 02:40:19 PM
Quote from: brianjw on February 19, 2007, 03:00:14 PM
The shoutbox is messing up my website. I took it off so I cannot really show you but I will go into detail.
I use tinyportal, i used aku's way of integrating it.
When I do it the way it says it makes my center blocks in tinyportal be indented far away from the left blocks :(
Maybe aku can help me or nneonneo or someone who has tinyportal using this :)

Brianjw

==Edit=========================================================================
I know what I followed instructions were correct because it was working and when I went on my website it just made the entire page indent and im staring at it in shame :-\ NOW i love this shoutbox; but right now i have only the one for tinyportal that doesnt autorefresh. Please help :D

I'd like to know the fix for TP, but to use in a right block instead of center block.
The way to make this possible for Tinyportal is here: http://www.simplemachines.org/community/index.php?topic=137508.msg880188#msg880188

It stopped working with my website. it indented all the centerblocks and the text box extended over the block. It is because of the index.template.php but dont know how to fix it. Nneonneo, please help. I would love to use this, if you need me to post the index.template.php and block code... I will :D

TrueSatan

If you collapse the header area does it stop the shout box from polling the server and thus reduce server load? If not might this be considered a feature request?

Please could you also consider adding a timer as per IPB's shoutbox such that it shuts down after a predetermined period set by the admins?

brianjw

Next Version Tips (1 included)

  • The mod modifies the SSI.php and adds a code SSI_shoutbox and that could be entered on another page including the codes needed like <?php require_once etc

    Brianjw

RoarinRow

Quote from: brianjw on February 25, 2007, 05:58:27 PM
Quote from: RoarinRow on February 24, 2007, 02:40:19 PM
Quote from: brianjw on February 19, 2007, 03:00:14 PM
The shoutbox is messing up my website. I took it off so I cannot really show you but I will go into detail.
I use tinyportal, i used aku's way of integrating it.
When I do it the way it says it makes my center blocks in tinyportal be indented far away from the left blocks :(
Maybe aku can help me or nneonneo or someone who has tinyportal using this :)

Brianjw

==Edit=========================================================================
I know what I followed instructions were correct because it was working and when I went on my website it just made the entire page indent and im staring at it in shame :-\ NOW i love this shoutbox; but right now i have only the one for tinyportal that doesnt autorefresh. Please help :D

I'd like to know the fix for TP, but to use in a right block instead of center block.
The way to make this possible for Tinyportal is here: http://www.simplemachines.org/community/index.php?topic=137508.msg880188#msg880188

It stopped working with my website. it indented all the centerblocks and the text box extended over the block. It is because of the index.template.php but dont know how to fix it. Nneonneo, please help. I would love to use this, if you need me to post the index.template.php and block code... I will :D

Thanks Brian.  I'm using other 3rd party shoutbox now   ;)

SMF 2.0
TP 1.0 RC1.1
Wordpress 3.1.3

c43

#344
Hello

Thanks for the mod but i have a problem

I want to delete the file history.home.txt but i can't do this on ftp. I have chmod the file to 777 but it automatically chmod to 644 and i can't delete and i can't replace the file.

What can i do please, because i want delete history.

Thanks

EDIT : it's possible to delete message by this example of url :

hxxp:your-forum-url/yshout/yshout.php?file=history.home.txt&delete=XXXXXXXXXX%20%7C%20IP [nonactive]

XXXXXXXXXX is the number of the message and IP is the ip of the user. This information is available in the file history.home.txt for each message.

But i have another problem :

It's with the letter "à" its write "?" instead of "à". I don't have the problem with other letters like é, è, ù, î, etc.., so a solution please ?

Zwerko

Quote from: c43 on February 28, 2007, 07:23:24 PM
Hello

Thanks for the mod but i have a problem

I want to delete the file history.home.txt but i can't do this on ftp. I have chmod the file to 777 but it automatically chmod to 644 and i can't delete and i can't replace the file.

What can i do please, because i want delete history.


Go to Admin-Packages->Options->Select "All files are writable." and hit Change File Permissions

Sarke

if you just want to clear the history, just type /clear

My MODs          Please don't PM me for support, post in the appropriate topic.

c43

Quote from: Sarke on March 01, 2007, 09:25:15 AM
if you just want to clear the history, just type /clear
No, the command /clear just clear the message on index but don't clear history. Thanks Zwerko for the solution.

But do you have a solution for letter "à" please ?

nneonneo

I do not know. It must be some internationalization/encoding problem, but it is using UTF-8 by default. Maybe if it is set to another encoding it will work.

@TrueSatan: AFAIK the shoutbox does not have a shutdown feature, but closing the header will stop the polling (assuming the JS code is added, which it is by default to the index.template.php).

@emrys01: The header "bug" is due to the JS code used to poll for the header.
Remove the JS code (between // YSHOUT HERE and // YSHOUT END in the index.template.php), and it should work.
If it still doesn't, you need to simply use <div id="yshout">[loading text]</div> without the additional header check.

@c43: Strange bug, maybe the history file is being written to by the PHP script. Try doing a rename on it, and then deleting the renamed file (this way, a new file should be created by PHP and the old one will be released).

@brianjw: My knowledge of TinyPortal is very limited. Akulion posted a nice tip early on in this thread.

I am working on finalizing 1.06. The major feature of this release is guest posting.
Check out the AJAX Shoutbox (my one and only mod to date :P)
Do you like SMF? Are you using ProBoards, InvisionFree, ActiveBoards or some other web-hosted forum? I can help you convert to SMF (without having to purchase a DB conversion)...contact me [nneonneo {at} gmail *dot* com], and see this topic
spammers here!

brianjw

Quote from: nneonneo on March 01, 2007, 06:25:27 PM
@brianjw: My knowledge of TinyPortal is very limited. Akulion posted a nice tip early on in this thread.
I used that snippet of code and it worked for a long time until one day the entire center blocks centered and when typing it extended as if it was selected in an iframe with no scroll bars. Akulion might be able to help me but I am now using shoutmix due to these problems :-\

kichu

Hey nneonneo , This shoutbox is really good but after some time it is showing the message like CPU of server is Overloaded, becoz of heavy script. I donno why it is showing like this. Solve this. I really need this SHoutbox, without having problems.

Sarke

kichu, I would suggest you change the refresh rate, like so:

Quote from: Sarke on February 15, 2007, 07:05:12 PM
I would suggest changing the update value in /yshout/js/yshout.js from 1500 to something like 5000 or 10000 (ms). 

var refreshTime = 1500;

If you have something like 100 people viewing the shoutbox, by default that is 4000 requests per minute, but if you change the update to 5 seconds (5000 ms), that brings the number of shoutbox requests down to 1200 (600 if you change the update to 10 seconds).

Remember that the value is in milliseconds!  If you put something below 1000 (1 second), for example 5 by mistake (thinking it's 5 seconds), you'll end up with over a million requests a minute from just those 100 viewers.

My MODs          Please don't PM me for support, post in the appropriate topic.

dado d.d.

Quote from: Daggers on February 25, 2007, 01:22:29 PM
Quote from: dado d.d. on February 25, 2007, 06:20:04 AM
Quote from: dado d.d. on February 24, 2007, 02:24:58 PM
hello i'm have made these changes to other template and it says loading shoutbox all the time,help?
anyone?

Make sure the yshout folder has been chmod 755


could you explain!please

c43

Quote from: nneonneo on March 01, 2007, 06:25:27 PM

@c43: Strange bug, maybe the history file is being written to by the PHP script. Try doing a rename on it, and then deleting the renamed file (this way, a new file should be created by PHP and the old one will be released).

I cannot rename, rewrite or delete the file history.home.txt from ftp (with filezilla), but i have find another solution. In my hosting there is an online file manager, so i can edit txt files directly from internet, so i just have to delete all text on this file.

For the letter "à" i have already try different encoding without results. Usually when there is a problem with "à", there also a problem with "é", "è", "ù", but here, there is just a problem with "à", and not for all other, so I don't understand that.

A suggestion also : Can you add an option to allow chat (reading &/or posting) just for some members not for all please?

Quotecould you explain!please
With filezilla software go to your ftp, click right on yshout folder, click on file attribute, and put 755 on Numeric Value

buben06

Quote from: buben06 on February 12, 2007, 11:20:27 AM
I have problem with encoding.

...when I change all instances of utf-8 in yshout.php to windows-1251 (russian) , it fixes datestamp and username (if russian) and shows them correctly, but the input text becomes all #$^@$%^&. (if typed in russian, english works fine either way)

Also, when I use default yshout.php (with utf-8), it's opposite: I can input text to shoutbox and see simbols in english and russian as well, but the datestamp and username is @#%$^#


any suggestions where I can change the input charset type to recognize windows-1251 ?

Note:
I use russian "windows-1251" charset in the forum settings in general and to switch to russian-utf , is not an option at the time. (too much to retype)

thanks,

Any updates on that?!

brianjw

Quote from: buben06 on March 02, 2007, 03:45:24 PM
Quote from: buben06 on February 12, 2007, 11:20:27 AM
I have problem with encoding.

...when I change all instances of utf-8 in yshout.php to windows-1251 (russian) , it fixes datestamp and username (if russian) and shows them correctly, but the input text becomes all #$^@$%^&. (if typed in russian, english works fine either way)

Also, when I use default yshout.php (with utf-8), it's opposite: I can input text to shoutbox and see simbols in english and russian as well, but the datestamp and username is @#%$^#


any suggestions where I can change the input charset type to recognize windows-1251 ?

Note:
I use russian "windows-1251" charset in the forum settings in general and to switch to russian-utf , is not an option at the time. (too much to retype)

thanks,

Any updates on that?!
I think it was said somewhere on this topic that nneonneo was gonna make all the characters work in this shoutbox next version :)

buben06

Quote from: nneonneo on January 30, 2007, 11:03:31 PM
I will see if the character encoding thing is related to SMF's default encoding (I'm guessing it does, but that's just a hunch)
If this is what you have reffered to, it not, please explain, because I've been following this post for over a month and have not yet seen any respond.

Daggers

My shoutbox has stopped refreshing  :(

You can post a message but you have to refresh the whole page for it to be displayed. Nothing has been altered.. it just happened yesterday afternoon.

Anybody got any ideas please

Shy1

Quote from: The [email protected] on January 11, 2007, 01:42:53 AM
Hello
I hope anyone can help me.
I installed the Shoutbox, The installation goes fast and easy, but I've got a little problem with the smilies.

As I type :) or :woot: , then I get no Smilie, in the preferences, I can see that the Link to the smilie is wrong.

It looks so ...... ....../smileys//smile.gif  .. the smile.gif lies in /smileys/default/smile.gif

Is there a solution, for the problem?

@ nneonneo, I like the shoutbox, it's a very nice Mod :)

P.S. sorry for my bad english, i hope you can understand what i mean...  ::)

I am having this exact same problem except that I have had the mod installed for a while and the smilies worked perfectly but all of the sudden the problem described above began to happen.  I have uninstalled the mod and tried to reinstall it but still, the smiles will not show and has "//smiley.gif" rather than "/smiley.gif".

Daggers

Quote from: Ashyra on March 03, 2007, 08:03:54 AM
Quote from: The [email protected] on January 11, 2007, 01:42:53 AM
Hello
I hope anyone can help me.
I installed the Shoutbox, The installation goes fast and easy, but I've got a little problem with the smilies.

As I type :) or :woot: , then I get no Smilie, in the preferences, I can see that the Link to the smilie is wrong.

It looks so ...... ....../smileys//smile.gif  .. the smile.gif lies in /smileys/default/smile.gif

Is there a solution, for the problem?

@ nneonneo, I like the shoutbox, it's a very nice Mod :)

P.S. sorry for my bad english, i hope you can understand what i mean...  ::)

I am having this exact same problem except that I have had the mod installed for a while and the smilies worked perfectly but all of the sudden the problem described above began to happen.  I have uninstalled the mod and tried to reinstall it but still, the smiles will not show and has "//smiley.gif" rather than "/smiley.gif".

The answer to the smileys can be found here...

http://www.simplemachines.org/community/index.php?topic=137508.msg928954#msg928954


Advertisement: