• Welcome to Simple Machines Community Forum. Please login or sign up.
November 29, 2021, 11:16:39 AM

News:

Wondering if this will always be free?  See why free is better.


1.1.9 chinese language pack upgrade problem

Started by wicka, May 24, 2009, 11:25:25 PM

Previous topic - Next topic

wicka

After I upgrade my forum from 1.1.8 to 1.1.9, I also upgrade to language pack: smf_1-1-9_chinese-traditional-utf8. After I install the language pack, there are copyright error shown http://docs.simplemachines.org/index.php?topic=907.0 .

Is that the language pack missing the copyright related translate?

CapriSkye

Quote from: wicka on May 24, 2009, 11:25:25 PM
After I upgrade my forum from 1.1.8 to 1.1.9, I also upgrade to language pack: smf_1-1-9_chinese-traditional-utf8. After I install the language pack, there are copyright error shown http://docs.simplemachines.org/index.php?topic=907.0 .

Is that the language pack missing the copyright related translate?

probably, haven't had time to update the language to 1.1.9.

popking

可以更改以下文件(我用繁體utf8):
/Themes/default/languages/index.chinese-traditional-utf8.php 
Line 413-414
From
413   $forum_copyright = '<a href="http://www.simplemachines.org/" title="Simple Machines Forum" target="_blank">Powered by %s</a> |
414   <a href="http://www.simplemachines.org/about/copyright.php" title="Free Forum Software" target="_blank">SMF &copy; 2006, Simple Machines LLC</a>';
To
413   $forum_copyright = '<a href="http://www.simplemachines.org/" title="Simple Machines Forum" target="_blank">Powered by ' . $forum_version . '</a> |
414   <a href="http://www.simplemachines.org/about/copyright.php" title="Free Forum Software" target="_blank">SMF &copy; 2006-2009, Simple Machines LLC</a>';

wicka

Thanks popking.

I've find out that the same problem is in the 1.1.10 version.
The solution is copy the $forum_copyright variable line back from the index.english.php file to /Themes/default/languages/index.chinese-traditional-utf8.php

Advertisement: