• Welcome to Simple Machines Community Forum. Please login or sign up.
November 29, 2021, 06:53:22 PM

News:

SMF 2.1 RC4 has been released! Try it out and help us test! :) Read more.


Damn...

Started by The -L-, August 22, 2009, 09:32:26 PM

Previous topic - Next topic

Adish - (F.L.A.M.E.R)

Just put up the right database details, and you should be up and working. If you have access to the control panel of the hosting, you can create a username for the database and then link them both together if you have forgotten your older username and password for that database.

The -L-

Only one problem now...how to find out database name???

Adish - (F.L.A.M.E.R)

If you have access to phpmyadmin, you will probably know by just looking into it.

If you have many installed, then export the "messages" table and see if you see something similar for that forum.

While removing the user associated to the database for your forum to add another user and associate it take care that you don't hit the "Delete Database" button. You'll loose everything. Unless you have a backup. :P

Norv

You need to write in it the correct database connection data: your host's server name, your forum's database name, your user, and your password, for the database.
These are the same data you entered when you first installed on this server.
Normally, you should be able to use repair_settings.php to do exactly this thing, set the correct data in Settings.php (repair_settings does it itself), but you need to write it correctly yourself in the page repair_settings shows you. If you don't know the correct data, check the welcome email from your host, or from the owner of the site, or ask your host.
To-do lists are for deferral. The more things you write down the later they're done... until you have 100s of lists of things you don't do.

File a security report | Developers' Blog | Bug Tracker


Also known as Norv on D* | Norv N. on G+ | Norv on Github

The -L-

I deleted my post to not double post...i repaired the forum and found database info and phpmyadmin info....now this is the problem...

Quote8: Undefined offset: 1001
/nfs/c02/h10/mnt/30579/domains/forum-racunara.com/html/forum/Sources/Errors.php
138

...

Norv

When does this happen?
Please eventually post your Errors.php file, for us to take a look at it.
To-do lists are for deferral. The more things you write down the later they're done... until you have 100s of lists of things you don't do.

File a security report | Developers' Blog | Bug Tracker


Also known as Norv on D* | Norv N. on G+ | Norv on Github

The -L-

It happens when i access index.php,sure here it is...

___________________________________________

ugh...i fix that by uploading original SMF 2.0 RC1-2 files back to host but now there is this error witch i cant fix with this method xD

QuoteFatal error: Call to undefined function: () in /nfs/c02/h10/mnt/30579/domains/forum-racunara.com/html/forum/Sources/Load.php on line 144


Norv

This file is (Errors.php)
* Software Version:           SMF 1.1
I thought you had a SMF 2.0 RC 1.2 forum.

Have you by any chance replaced the files with the 1.1.10 package instead of 2.0?
To-do lists are for deferral. The more things you write down the later they're done... until you have 100s of lists of things you don't do.

File a security report | Developers' Blog | Bug Tracker


Also known as Norv on D* | Norv N. on G+ | Norv on Github

Norv

Ah, you edited your message.
Please try to make sure that all the .php files in the original installation package of SMF 2.0 RC1.2 are all replacing your files. It seems that at least once, you have used 1.1.10 files, so I can't tell whether there are others as well.
To-do lists are for deferral. The more things you write down the later they're done... until you have 100s of lists of things you don't do.

File a security report | Developers' Blog | Bug Tracker


Also known as Norv on D* | Norv N. on G+ | Norv on Github

The -L-

Oh damn...yep there is a chance...omg...what now??? Re upload all default SMF files for 2.0 RC 1.2?

I now remembered the database that i changed was our old from byethost (free host) and batck in those days we had 1.1.10 version...si witch files do i reupload?

Norv

The database that you changed?
Did you make a database restore?
Please explain exactly what you made with the database.
To-do lists are for deferral. The more things you write down the later they're done... until you have 100s of lists of things you don't do.

File a security report | Developers' Blog | Bug Tracker


Also known as Norv on D* | Norv N. on G+ | Norv on Github

The -L-

I restored the database via repair_settings.php...

Norv

Modifying a few settings in repair_settings.php does not mean restoring a database. You only changed the connection data to the database.

So, you probably have a 2.0 RC1.2 database, and need a 2.0 RC1.2 forum. Make sure all the .php files in your forum are from the 2.0 RC1.2 installation package. Specially those in the ./Sources folder, but also those in the SMF folder, and themes/default at least.
After you do, please tell, does it still happen?
To-do lists are for deferral. The more things you write down the later they're done... until you have 100s of lists of things you don't do.

File a security report | Developers' Blog | Bug Tracker


Also known as Norv on D* | Norv N. on G+ | Norv on Github

The -L-

Fixed...but if i have more problems ill write it here....(i just uloaded full install pakage to host (Source dir))

JimM

Is this issue solved or do you still require assistance?  If this is solved please mark it solved by clicking the Mark Topic Solved link at the bottom left of the page.
Jim "JimM" Moore
Former Support Specialist

Advertisement: