• Welcome to Simple Machines Community Forum. Please login or sign up.
November 29, 2021, 11:19:29 AM

News:

SMF 2.0.18 has been released! Please update. Read more.


Tidy Child Boards

Started by Arantor, December 09, 2009, 04:00:36 AM

Previous topic - Next topic

Kimmie

December 12, 2009, 07:59:14 PM #60 Last Edit: December 12, 2009, 08:03:31 PM by Kimmie
Quote from: Arantor on December 12, 2009, 04:27:19 PM
None of your themes have their own BoardIndex.template.php or MessageIndex.template.php files (other than default/) ? Then uninstall should remove it correctly, but if you have custom themes, it won't always tidy up correctly, meaning that even if you were to ask it to uninstall, it won't uninstall correctly anyway. :(

a few do, a few dont.

I guess my main confusion is on "doesn't always uninstall on custom themes". Confusion because it doesnt actaully "install" to them either so I dont see why it causes a problem..lol. (but hey, I dont code em, I just use em..lol)

at any rate, I would prefer to try and get this version completely removed but if im stuck with it im stuck with it..lol - other than those images not pulling right I havent found any other issues with it. Go ahead and post the edits I need to make to get those file names to pull right. I doubt I will ever "want" to uninstall this mod once once its all working right because it was one of my fav mods on 1.x so hopefully it will never be an issue :).


EDIT: I just thought of something.....not sure if it will work but I will ask anyways..lol.

I made a backup of my public_html folder before I installed this mod. Its the only mod I have installed since that backup. Could I just reupload that and let it overwrite those files putting them back to the way they were before I installed it and then install the updated one?

Arantor

QuoteI guess my main confusion is on "doesn't always uninstall on custom themes". Confusion because it doesnt actaully "install" to them either so I dont see why it causes a problem..lol. (but hey, I dont code em, I just use em..lol)

So you didn't ask it to install to other themes on install in the package manager?

Yes, ultimately, if you backed up public_html before installation, you will be able to remove the mod's code that way. However, there will still be an entry in the database for the mod, so it may still show as installed, but we'll come to that after uploading the backup (I feel bad that's where it's got to :()
No good deed goes unpunished
All helpful urges should be circumvented

Kimmie

Quote from: Arantor on December 13, 2009, 04:44:59 AM

So you didn't ask it to install to other themes on install in the package manager?

I have been using SMF for over 2 years and I have never had option in the package manager to install a mod to custom themes. I think you just enjoy confusing me  ;)

QuoteYes, ultimately, if you backed up public_html before installation, you will be able to remove the mod's code that way. However, there will still be an entry in the database for the mod, so it may still show as installed, but we'll come to that after uploading the backup (I feel bad that's where it's got to :()

and thats not gonna work because I did install another mod after this one Thought it was before, but I was mistaken. Looks like I will just have to do all the GIF edits manually so whenever you have them ready, throw em at me..lol. (OR...lol... wanna do em yourself?  lol)

Arantor

Quote from: Kimmie on December 13, 2009, 04:01:09 PM
I have been using SMF for over 2 years and I have never had a mod ask me if I wanted to install it onto custom themes. I think you just enjoy confusing me  ;)

In SMF 2, after you press Apply Mod, you get the list of edits. At the bottom of that screen is "Install on Other Themes".

Quoteand thats not gonna work because I did install another mod after this one Thought it was before, but I was mistaken. Looks liek I will just have to do all the GIF edits manually.

There aren't many of them. I think there's 2 in BoardIndex.template.php and 2 in MessageIndex.template.php. The package parser on the mod site will tell you what the 2.0 RC1.2 compatible code is (now the package supports that)
No good deed goes unpunished
All helpful urges should be circumvented

Kimmie

k I am gonna have to do another backup of the public folder before I do this incase something goes wrong. I will assume that the changes are within the same part of the mod code that is already there?

Arantor

Yup. Literally all I did when converting to 2.0 RC1.2 was edit the .png to .gif, there's no other differences. Package parser will show you the correct code for 2.0 RC1.2.
No good deed goes unpunished
All helpful urges should be circumvented

Kimmie

k well I made all the changes, and it looks like everything is working ok. No errors in the log and the images are all pulling correctly now.

Thanks for adding the 2.0 RC1.2 support on the mod. :)

perplexed

I hate Internet Explorer!

I installed this mod a few days ago and it looks really good... in firefox and opera.  I didn't bother to look in IE because I don't use it and didn't expect it to look any different.  However I had to use it today and I have the mod set to two columns, but in IE7, it shows column one and then column two is directly underneath it.  As though it's not wide enough to display them side by side if you know what I mean.  Anyway unless you know how to fix this stupid IE problem, I will have to uninstall it, and I would like to keep it, as it looks so nice in other browsers. :(

edit:  I just switched it to three columns and that displays it in two columns side by side and then one underneath.

I'm using the Curve default theme and the Chocolate curve theme and 2.0 RC2.

Arantor

Unfortunately I don't have IE7 so I wasn't able to test it on that (I only have IE8 whereupon it looks just fine)

Can you show me a screenshot of exactly what you get please?
No good deed goes unpunished
All helpful urges should be circumvented

perplexed

yeah I know what you mean *kicks stupid IE7-using members* It didn't even occur to me to look at it until today, and that was accidental.

ok, in firefox it looks like this



and in IE7 it looks like this


Arantor

Argh, I agree IE can be a pain.

Core problem is that IE does something funky with respect to margins. I'm going to have to see if I can't get hold of an environment where I can test using IE 7.

I'm thinking messing with the margins in the .css file the mod comes with might help, possibly changing from 0 0 0 1 to 0 0 0 -1... or 0 1 0 0 instead (keeping the same units)
No good deed goes unpunished
All helpful urges should be circumvented

FragaCampos

I there. Thanks for the mod, it works just fine on SMF 1.1.11.

I would like to ask the following: is it possible to organize the child-boards in just one column?

Arantor

Not with the mod as it stands. It could be modified to do so but it's not something I'm planning on adding any time soon to be honest.
No good deed goes unpunished
All helpful urges should be circumvented

FragaCampos

It's just that the layout changes with resolution, and with one column some boards would be prettier...
But thanks anyway.

h78509

Am I an idiot because I cannot find where to setup this mod? I've looked everywhere.

Spoogs

Quote from: h78509 on December 16, 2009, 12:07:31 AM
Am I an idiot because I cannot find where to setup this mod? I've looked everywhere.

Admin>Configuration>Features and Options>Layout (scroll down to arrange child boards into columns)

Arantor

Quote from: FragaCampos on December 15, 2009, 08:30:52 PM
It's just that the layout changes with resolution, and with one column some boards would be prettier...

That would also imply configuration per parent board, which I'm definitely not going to be adding any time soon.

Quote from: h78509 on December 16, 2009, 12:07:31 AM
Am I an idiot because I cannot find where to setup this mod? I've looked everywhere.

1.1: Admin > Features and Layout > Layout

2.0: Admin > Features and Options > Layout (about 1/3 the way down the page)
No good deed goes unpunished
All helpful urges should be circumvented

h78509

Quote from: Arantor on December 16, 2009, 03:59:56 AM
Quote from: h78509 on December 16, 2009, 12:07:31 AM
Am I an idiot because I cannot find where to setup this mod? I've looked everywhere.

1.1: Admin > Features and Layout > Layout

2.0: Admin > Features and Options > Layout (about 1/3 the way down the page)

Thanks! Wow, I cannot believe I missed that.

perplexed

Quote from: Arantor on December 14, 2009, 05:12:56 PM
Argh, I agree IE can be a pain.

Core problem is that IE does something funky with respect to margins. I'm going to have to see if I can't get hold of an environment where I can test using IE 7.

I'm thinking messing with the margins in the .css file the mod comes with might help, possibly changing from 0 0 0 1 to 0 0 0 -1... or 0 1 0 0 instead (keeping the same units)

Sorry, I misread this.  Did you mean I should mess with the css and see what happens?

Arantor

Yeah, have a mess with the CSS file it comes with and see what happens. I haven't had chance to try it.
No good deed goes unpunished
All helpful urges should be circumvented

Advertisement: