News:

SMF 2.1.2 has been released! Take it for a spin! Read more.

Main Menu

fare un upgrade da 1.1.19 a 2.0.6

Started by luca16568, October 31, 2013, 05:46:15 AM

Previous topic - Next topic

luca16568

sottoscrizioni pagamento impossibile da visualizzare.......quindi altro problema!(anche con tema di default)
mi sa' che e' stato un'upgrade verso un bagno di sangue!
sto' pensando di perdere 1 settimana di post e rimettere la vecchia versione! :'(
meglio un buon nemico che un cattivo amico..........

emanuele

Ahhh....

Guarda bene *quando* funziona e quando no:
http://motoclubgilera4t.it/forum/index.php
http://www.motoclubgilera4t.it/forum/index.php
Noti niente di diverso? ;)
Scegli se vuoi il www  no ed usa solo quello (e fai un redirect all'altro).


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

luca16568

ma come mai questo problema c'e' con www e sparisce senza?
meglio un buon nemico che un cattivo amico..........

emanuele

Potrebbe essere (la configurazione dei server non è esattamente il mio punto forte) che una delle due versioni sia indirizzata all'altra tramite un symlink e quindi quando php va a "risolvere" il percorso "vero" (siccome da quel che *suppongo* nchat usa un percorso relativo e non assoluto) non trova il file dove si aspetta di trovarlo.
Lo stesso può essere vero per altre cose, ma iniziamo a correggerne una e vediamo.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

luca16568

qui ora mi blocco.....
il problema e' "solo" del forum.....
quindi come dovrei agire?
meglio un buon nemico che un cattivo amico..........

emanuele

Facciamo un secondo un passo indietro.
Admin > configurazione > impostazioni server > database e percorsi
La voce URL del forum, ha il www o no?


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

luca16568

meglio un buon nemico che un cattivo amico..........

luca16568

meglio un buon nemico che un cattivo amico..........

emanuele

#28
Ed il forum "corretto" è quello senza www? (Giusto per essere sicuro. ;))

Se così fosse, prova questo htaccess:
http://stackoverflow.com/questions/234723/generic-htaccess-redirect-www-to-non-www


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

emanuele

1) hai una mistura di file di lingua utf8 e non utf8. Questo è male. Il forum è utf8, quindi i file di lingua non utf8 dovrebbero sparire.
2) sicuro ti servano tutte quelle lingue? Rumeno, polacco, norvegese e finlandese non sono praticamente usate (tutte hanno 1 utente, il che mi fa sospettare che siano errori).
3) mi rispondi alla domanda che ti ho posto nel messaggio sopra?

Dopo potrebbero arrivarne altre.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

emanuele

P.S.
Ovviamente senza conferma io di mio non cambio niente a meno che non implichi un problema di sicurezza. (Giusto per essere sulla stessa linea. ;))


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

luca16568

Quote from: emanuele on November 17, 2013, 01:16:37 PM
1) hai una mistura di file di lingua utf8 e non utf8. Questo è male. Il forum è utf8, quindi i file di lingua non utf8 dovrebbero sparire.
2) sicuro ti servano tutte quelle lingue? Rumeno, polacco, norvegese e finlandese non sono praticamente usate (tutte hanno 1 utente, il che mi fa sospettare che siano errori).
3) mi rispondi alla domanda che ti ho posto nel messaggio sopra?

Dopo potrebbero arrivarne altre.
ho su molti utenti stranieri......non le ho messe cosi', ma per questa cosa....
l'impostazione "dovrebbe" essere in utf8....
dammi 10 minuti, faccio un salvataggio e poi hai "carta bianca"!
meglio un buon nemico che un cattivo amico..........

emanuele

Mi puoi rispondere alla domanda:
Quote from: emanuele on November 13, 2013, 07:42:35 AM
Ed il forum "corretto" è quello senza www? (Giusto per essere sicuro. ;))
per favore?
Vedo che il sito è con il www, ma il forum è senza, quindi vorrei essere sicuro.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

luca16568

il forum in "teoria" dovrebbe essere www.motoclubgilera4t.it/forum.....
cartella del percorso:
/home/xxxxxxx/domains/motoclubgilera4t.it/public_html/forum
meglio un buon nemico che un cattivo amico..........

emanuele

Okay, allora proviamone usa semplice, da:
Admin > configurazione > impostazioni server > database e percorsi
Cambia l'url aggiungendoci il www.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

luca16568

non me li cambia....
(solo indirizzo del forum me lo ha cambiato)
meglio un buon nemico che un cattivo amico..........

emanuele

E' sufficiente.
Ora la chat "funziona" in ogni caso, perché anche quando punti a http://motoclubgilera4t.it/forum/ senza il www vieni re-indirizzato alla versione www e la chat pesca i file correttamente.

Magari, anche altri problemi sono magicamente spariti, prova a verificare. ;)


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

luca16568

meglio un buon nemico che un cattivo amico..........

Advertisement: