News:

SMF 2.1.2 has been released! Take it for a spin! Read more.

Main Menu

Like Posts

Started by vbgamer45, June 29, 2013, 09:29:03 AM

Previous topic - Next topic

Gluz

The issue is that the theme uses a jquery_bits.js for theme animations and stuff, that file use $ as function, and from one or another mod installed that uses jQuery I get errors in the Console Log, telling that $ is not a function, so I edited that file to update with a more suitable syntax to work with the MODs.

Code (Change from this) Select
$(document).ready(function() {

Code (To this) Select
jQuery(document).ready(function($) {

And other file that just have a deprecated syntax at the beggining, and all my problems where solved. But it was weird, as the other jQuery file of the theme have the right syntax(the second one) to make the functions.



Just one thing that didn't work for me, in my iPod Touch if I press the link to the members that Liked one post can't do anything else, the box don't disappear no matter what, the only way is to go back one page, but I'm not sure if my iPod loaded the new files or uses the ones that have in the cache, need to test that again.

gorbi

Install 2.0.5. Link for like posts notification box is non-active.

Siirist

Quote from: Joker™ on May 17, 2015, 12:12:15 AM
Quote
Hi Joker,

Thanks for this GREAT MOD!!!!  ;D

SMF v2.0.9

MODs
1.    Like Posts    2.0.5       
2.    Menu_Icons    1.0    
3.    PM Warning    1.0    
4.    Topic Solved    1.1.1    
5.    Google Translate for SMF 2.0    1.4    
6.    Default_Membergroup    2.0    
7.    Enhanced Dropdown    1.3    
8.    Board-color-and-icons    1.1    
9.    Caps_Lock_Detection_on_Login    1.1.0.2    

Themes that the user is able to select:
    SMF Default Theme - Curve
    Core Theme
    Hope
    Bright Forest (haven't even tried this theme due to failed when installing)
    Ostara
    Sunshine

Link to Test Forum
USERNAME=testmember    (is a regular member)
PASSWORD=letmesee

Check settings from admin panel

Hi again,

I tried the MOD after uninstalling v2.0.4 and then installing v2.0.5.
The results were
while using default theme (Curve) the mod seems to function as intended
while using Hope theme the mod seemed to function as intended
(although I think I broke the "Hope" theme when I manually removed the "Send" and "Print" Buttons from the Display Template.php)
while using Sunshine theme the mod seemed to function as intended

while using Ostara theme the box didn't appear

See attachments for ScreenShots of Admin Panel Settings

Be Well,
Siirist
Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

Siirist

Should I go to the parse and verify each and every action?  O:)
Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

Gluz

If you are sure that you ticked the checkbox to install on that theme, I think that you need to check that, yes.

When I updated in my production site I forgot to check my theme and I think that I broke something, then I realized that I didn't install it in the theme :P then have to uninstall and reinstall to check all themes and works again.

Siirist

#705
Quote from: Gluz on May 18, 2015, 10:40:55 PM
If you are sure that you ticked the checkbox to install on that theme, I think that you need to check that, yes.

Okay, will manually verify the three (3) themes that are not functioning properly (Bright Forest-failed on install, Ostara, and Core)
Also need to find out what damaged the HOPE theme (sceenshots included)

Be Well,
Siirist

EDIT:
Standard install (default template) changes verified

Some changes were in place for Bright Forest
HOWEVER,
<li><a href="', $scripturl, '?action=unreadreplies">', $txt['show_unread_replies'], '</a></li>';
is NOT present in the index.template.php, so I do NOT know where to add
      if(LikePosts::$LikePostsUtils->showLikeNotification()) {
         echo '
               <li><span class="showLikeNotification" onclick="lpObj.likePostsNotification.showLikeNotification()">', $txt['like_show_notifications'], '</span></li>';
      }

Core template - verified

Ostara1 template does NOT have a display.template.php
(HOLY CRAP! How can a template "display" without a display.template.php?)
Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

Gluz

For the theme that doesn't have Display.template.php, it uses the default one, so if the default theme works, that theme should work too.


On the theme Bright Forest, if the link to read Unread Replys is not present in index.template.php, then that means that there is no user zone to add the link to show Like Notifications, is not really a big deal, the thing is that in that theme there is no other way to show Like Notifications. Need to look a place to place that link and then add it there.

And for the Hope theme, I think that the design don't get in mind a big main menu, so when you have so many buttons in the menu the logo get to another line. The fix for that is really simple, in the index.css of the Hope Theme:
Code (Search) Select
#logo a {
Code (Add after) Select
position: absolute;

That fix the logo and the layout should look ok.

Can I register in your Test Forum to view all the themes when logged in? maybe ther I could help you to fix things.

Siirist

Quote from: Gluz on May 19, 2015, 05:38:34 PM
Can I register in your Test Forum to view all the themes when logged in? maybe ther I could help you to fix things.

Absolutely

Will begin work in a bit on the fix for Hope template
Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

Siirist

Quote from: Gluz on May 19, 2015, 05:38:34 PM
For the theme that doesn't have Display.template.php, it uses the default one, so if the default theme works, that theme should work too.


On the theme Bright Forest, if the link to read Unread Replys is not present in index.template.php, then that means that there is no user zone to add the link to show Like Notifications, is not really a big deal, the thing is that in that theme there is no other way to show Like Notifications. Need to look a place to place that link and then add it there.

And for the Hope theme, I think that the design don't get in mind a big main menu, so when you have so many buttons in the menu the logo get to another line. The fix for that is really simple, in the index.css of the Hope Theme:
Code (Search) Select
#logo a {
Code (Add after) Select
position: absolute;

That fix the logo and the layout should look ok.

Can I register in your Test Forum to view all the themes when logged in? maybe there I could help you to fix things.

Yeah, fixed it mostly but still not looking completely right
Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

Paracelsus

The new version works very well Joker, no more problems with Reseller theme, thank you. ;D

A question about the "show likes notification"... is it "interactive"? I mean, is it possible for a user to know whenever it receives a like on one of its posts like you get when you receive new/unread PMs?

Media-Bay

Hi need some help please.

This mod is great and works so well on my site. but for some reason then i look at a post a member has made is see the like icon twice.

I have attached picture.


Livaco

It doesent work, look



When on the prevew on the page of the mod

jakes_t

Hi Joker

Thanks for a very nice mod!

Can you help with getting the Like button to match the look and feel of the curve theme? (rounded corners button and capital letters etc)

Similar to the example below?

Thanks!

Elizabeth II

#713
When you click on someones likes on a post, you get the box.. I changed the main background colour, but how do you change the colour of the small spacer in between names of people who liked, basically the border?

TIA

Elizabeth II

Apologies for double post can't seem to edit my own post after 2nd time... Is there also a way to make that box not transparent? As you can see through it to the nav menu


amritsidhu

Like notification box is too far to the left on my mobile website how can i make it responsive to fit the mobile screen or at least show in center. Thank for nice mod :)

strano

hi...for an upgrade from ...... 1.3.1 version? :D

Are there any problem? it's possible?

MilanRS

Does this support determineActions()?
It seams that I see "Unknown Action" on Who is online when someone is doing some action with Like (Like, Dislike, View likes...).

heiho1974

My Problem ist this:

SQL logic error or missing database
near "SHOW": syntax error
Datei: /mnt/webo/c0/78/54140778/htdocs/forum/Packages/temp/installer/install.php
Zeile: 155

strano

I've some problem with stats: when i want to see the stats about the Users, there is an infinite loading.

Advertisement: