• Welcome to Simple Machines Community Forum. Please login or sign up.
December 02, 2021, 02:23:10 AM

News:

Wondering if this will always be free?  See why free is better.


XHTML Hataları ve Çözümleri

Started by Hoochie Coochie Man, January 21, 2008, 06:40:21 PM

Previous topic - Next topic

arslanturk0687

direkt şu adresten taratıyorum. 54 hata diyor. Bu sadece ana sayfa için. Buradaki hataların kodları indextemplate ve boardindextemp. ait.

şu profil sayfasına ait. 27 hata var ve profiletemplate ile ilgili hata kodu yok gözüküyor. indextemplate ve boardindextemp. ait gözüküyor.

şu displeytemplate.php ye ait olan konu içi 45 hata gözüküyor. displeytemplate.php, indextemplate.php ye ait hata kodları. boardindex.template.php var mı bilemedim.

şu arama sayfasına ait 28 hata gözüküyor. hataların çoğu yine indextemplate ve boardindextemp. ait.

yani indextemplate ve boardindextemp. deki hatalar giderildimmi hemen hemen tüm hataları çözmüş oluyoruz. 4 dosyayıda eke koydum. Nasıl çözüleceğini inanki bilmiyorum.

Antes

<div id="bayrak"><a href="http://www.sohbetforumu.com/index.php" target="_self"></a></div>

Silip tekrar deneyin? (Ayrıca o kodun head elementi değil body elementinin en üst kısmında olması lazım.)

arslanturk0687

dediğini silsem de body'nin en üstüne eklesem de hata oranı
anasayfada ------ 54 den 36 ya
konu içinde ------ 45 den 32 e
profilde ---------- 27 den 11 e
arama sayfasında-28 den 13 e düştü

çok iyi oldu sağ ol.

menüde Themes/default/images/forummunuimages/mb_anasayfa.png)">Anasayfa</div></a> krmızı ile belirttiğim yer hata veriyor.
duyurulardaki n="center"><font=Verdana></size><size=2px><b>Eğitimli insanlar topluma borçlu...
yine duyuruda impleannouncementmodduyurukismicss"><div align="center"><font=Verdana></siz...

gibi birkaç hatalar kaldı sayende. Şu diye belirttiğim linklerden tekrar bakınca nerede değişiklik yapmam gerektiğini belirtmeni rica ederim.

Antes

li > a > div şeklinde olanları span olarak değiştirmen gerekiyor veya div'i komple kaldırıp a elementine gerekli tanımlamaları yapman lazım.

arslanturk0687

menüdeki li leri span yaptım css ayarlarınıda span olarak değiştirdim menü sorunsuz çalışiıyor. xhtml taraması yaptım yine. anasayfada 36 dan 44 e çıktı hata.
menüdeki Themes/default/images/forummunuimages/mb_anasayfa.png)">Anasayfa</div></a> krmızı ile belirttiğim yerdeki hatayı çözsem genel hataların çoğu gidiyor.

Antes

Sitenizde söylediğim yerler hala div olarak gözüküyor, index.template'de.

arslanturk0687

Dediğini anladım da dosyalara bakınca karıştırıyorum. Belirttiğim dosyalardan birinden bir kod yapısı ile örnek verir misin?

Antes

<li><a href="', $scripturl ,'"><div class="frmmenu_buttonimg frmmenu_buttonimg_29" style="width: 107px; background-image: url('. $settings['default_images_url']. '/forummunuimages/mb_anasayfa.png)">Anasayfa</div></a>

buradaki div 'i span olarak değiştirmen gerekiyor. Şu var ki menü neden ayrık olarak kodlanmış function main_menu neden kullanılmamış çok garip.



Antes

Quote from: arslanturk0687 on October 30, 2015, 07:12:30 AM
div dışında başka bir değer yapınca menü göstermiyor.

CSS düzenlemesi yaptınız mı?

arslanturk0687

Yaptm. Css, boardindex temp. ve js dosyasında div olan yerleri span yaptım menü gözükmedi. sadece Css, boardindex temp. yaptım yine gözükmedi. ve yine sadece boardindex temp. yaptım gözükmedi. span yerine a yaptım yine sonuç aynı. yani her türlüsünü denedim.

marinaturizm

çok sagol hocam ellerin dert görmesin

Macabreo

alt etiketi hatası, çoğu webmasterin baş belası haline gelmiş durumda maalesef.

Advertisement: