News:

SMF 2.1.2 has been released! Take it for a spin! Read more.

Main Menu

Like Posts

Started by vbgamer45, June 29, 2013, 09:29:03 AM

Previous topic - Next topic

Siirist


The "shove" was a joke. Any one have any thoughts about this?
Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

CDLehner

It was suggested, I post this here:

I installed the following mod, for a 'Like' button...



and it seems to have taken...





But I don't see a 'Like' button anywhere (I'm used, to seeing it...where the purple box is). Could it have something to do, with the way I already have my Karma set-up?



Thanks

Siirist

Hi CDLehner,

For me the word Like is white in color and sometimes does NOT have the maroon background to make it visible.

An example of this is in my Guest Area here

And this MOD places the "Like" at the bottom of all the text in the post, an example here *Remember that because it is NOT working correctly that the word "Like" is white in color.

My Karma is fully functional and is a separate thing from "Like Post".

Are you wanting to have the Karma Buttons to say "Like" and "Dis-Like"?

Be Well,
Siirist


*EDIT -->  Forgot to mention Thank you for posting in the right place
Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

CDLehner

Quote from: Siirist on January 18, 2016, 09:48:33 PM
Hi CDLehner,

For me the word Like is white in color and sometimes does NOT have the maroon background to make it visible.

An example of this is in my Guest Area here

And this MOD places the "Like" at the bottom of all the text in the post, an example here *Remember that because it is NOT working correctly that the word "Like" is white in color.

My Karma is fully functional and is a separate thing from "Like Post".

Are you wanting to have the Karma Buttons to say "Like" and "Dis-Like"?

Be Well,
Siirist


*EDIT -->  Forgot to mention Thank you for posting in the right place

No...I'm happy to have Like, separate from the Karma. So it sounds like the solution, is to change the 'Like' color; to something that will stand out from your background (that is...if you don't particularly want to change your background)?

NooB alert; how do I do? :)

Thanks

Siirist

Quote from: CDLehner on January 18, 2016, 10:03:33 PM

No...I'm happy to have Like, separate from the Karma. So it sounds like the solution, is to change the 'Like' color; to something that will stand out from your background (that is...if you don't particularly want to change your background)?

NooB alert; how do I do? :)

Thanks

Well, truth said, I do not know how to change the color.

However, I am brave enough to look into and try something AFTER I back-up.
ALWAYS back-up BEFORE making changes.

Give me 24 hours (unless someone else comes and gives us the answer)

Be Well,
Siirist
Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

CDLehner

I got it. There are screen-shots, on the mod page that helped.






Siirist

Hi CD,

Glad it worked for you!   :D

Please in the future, attach images INSTEAD of placing them in the post.

I know that some members use cell phones to access SMF and your post size make the page unreadable.

By using attachments, the post is readable and the person looking at it can check out the attachments one by one.

Be Well,
Siirist
Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

Siirist

* Bump

Quote from: Siirist on January 12, 2016, 12:10:49 PM
Hello,

I installed this mod using the package manager without any problems.

I went into the APC and set it to be available on ALL boards.

I then set permissions so that all members will see the like buttons throughout the forum, in the member profiles, and be able to like all posts in the forum.

I have the following TWO problems.

ONE) On the Menu Bar, there is NO icon.



TWO)
A) In the posts, the like is a white font color Like This, and does NOT have a maroon background.

B) On the boards, SOME of the Like buttons have a maroon background, and some do not.

I parsed for SMF ver 2.0.11 and verified that all modifications were done and found no errors.

I am using the following themes:
Bright Forest
Habbingo
Habboland
Ostara (set as default template)

And the following MODs:
1.    Custom Copyright    1.0.4    
2.    Simple Menu Icons    1.0    
3.    Like Posts    2.0.5    
4.    SMF Gallery Lite    5.6    
5.    PM Warning    1.0    
6.    Topic Solved    1.1.1    
7.    Google Translate for SMF 2.0    1.4    
8.    SMF 2.0.11 Update    1.0    
9.    Optimus Brave    1.8.7    
10.    Default_Membergroup    2.0    
11.    Welcome Back    1.0    
12.    Enhanced Dropdown    1.3    
13.    Board-color-and-icons    1.1

Thank you in advance,
Siirist
Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

Siirist

Sheesh, okay, never mind.

*cuts and eats a piece of humble pie*

I forgot to use the default theme.  Boy do I feel sheepish.

So yeah, the MOD functions as intended when using the default theme.

Be Well,
Siirist
Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

Gluz

That means your theme overides the CSS of the Like Button, so, you need to change some things in the CSS file of your other theme.

Atrus

Hi Joker,

   I have your "Like Posts    2.0.5" installed on my forum, (2.0.11).  I am looking for a mod that allows like/unlike of individual posts within a topic. I do see the "Like" button at the top if the topic in the index of a board, but nothing shows up in any of the individual posts. Since I am not looking to "like" the entire topic, I have " Show like button on board index - Global settings to show like button board index" unchecked. I have set permissions for membergroups, and boards, and all looks good.

I am using a custom theme that I have modified for appearance sake to my liking, and wonder if there are any manual mods that I may have to apply ti it? Since guests can only "look but not post," I have everything unchecked for guests. I doubt visiting the forum will help, but here is the url; www.myconstitution.info

Could you please offer any suggestions on what else I could check to activate the "Like Posts" at the individual post level?

Thanks for the mod. If I can make it work, it's EXACTLY what I  want...




Siirist

Quote from: Atrus on February 04, 2016, 04:01:02 PM
Hi Joker,

   I have your "Like Posts    2.0.5" installed on my forum, (2.0.11).  I am looking for a mod that allows like/unlike of individual posts within a topic. I do see the "Like" button at the top if the topic in the index of a board, but nothing shows up in any of the individual posts. Since I am not looking to "like" the entire topic, I have " Show like button on board index - Global settings to show like button board index" unchecked. I have set permissions for membergroups, and boards, and all looks good.

I am using a custom theme that I have modified for appearance sake to my liking, and wonder if there are any manual mods that I may have to apply ti it? Since guests can only "look but not post," I have everything unchecked for guests. I doubt visiting the forum will help, but here is the url; www.myconstitution.info

Could you please offer any suggestions on what else I could check to activate the "Like Posts" at the individual post level?

Thanks for the mod. If I can make it work, it's EXACTLY what I  want...

I have heard that Joker has been absent for some time now.

They are active at the individual post level.

I am running the same MOD on 2.0.10 with SMF Default, Ostara, Bright Forest (BF), Sunshine, and Hope themes. The only one it did not function on SkyFall theme.

See attachments.

Regards,
Siirist
Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

Atrus

Quote from: Atrus on February 04, 2016, 04:01:02 PM
Hi Joker,

   I have your "Like Posts    2.0.5" installed on my forum, (2.0.11).  I am looking for a mod that allows like/unlike of individual posts within a topic. I do see the "Like" button at the top if the topic in the index of a board, but nothing shows up in any of the individual posts. Since I am not looking to "like" the entire topic, I have " Show like button on board index - Global settings to show like button board index" unchecked. I have set permissions for membergroups, and boards, and all looks good.

I am using a custom theme that I have modified for appearance sake to my liking, and wonder if there are any manual mods that I may have to apply ti it? Since guests can only "look but not post," I have everything unchecked for guests. I doubt visiting the forum will help, but here is the url; www.myconstitution.info

Could you please offer any suggestions on what else I could check to activate the "Like Posts" at the individual post level?

Thanks for the mod. If I can make it work, it's EXACTLY what I  want...

Ok, I just did some more checking and it does work as advertised on the default theme. It does not work on my modified theme, even though the installation said it was ok through the package manager. Stats work fine, but in my theme no likes show up under user's avatar, and no like button in individual posts that I did not make. Everything seems to work fine in default theme.

So now I do a "stare and compare" on files in my theme. 

Thanks for the mod!!!


Siirist

Quote from: Atrus on February 04, 2016, 05:18:25 PM

Ok, I just did some more checking and it does work as advertised on the default theme. It does not work on my modified theme, even though the installation said it was ok through the package manager. Stats work fine, but in my theme no likes show up under user's avatar, and no like button in individual posts that I did not make. Everything seems to work fine in default theme.

So now I do a "stare and compare" on files in my theme. 

Thanks for the mod!!!

Well, I would go to the MOD and parse it for 2.0.11, then check your files and ensure that the changes were successfully made.
Some others would uninstall and reinstall, but I think that won't help because you have verified that the MOD does in fact function with the default theme.

Just my thoughts,
Siirist
Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

Atrus

Quote from: Siirist on February 04, 2016, 05:26:07 PM
Quote from: Atrus on February 04, 2016, 05:18:25 PM

Ok, I just did some more checking and it does work as advertised on the default theme. It does not work on my modified theme, even though the installation said it was ok through the package manager. Stats work fine, but in my theme no likes show up under user's avatar, and no like button in individual posts that I did not make. Everything seems to work fine in default theme.

So now I do a "stare and compare" on files in my theme. 

Thanks for the mod!!!

Well, I would go to the MOD and parse it for 2.0.11, then check your files and ensure that the changes were successfully made.
Some others would uninstall and reinstall, but I think that won't help because you have verified that the MOD does in fact function with the default theme.

Just my thoughts,
Siirist

That's precisely what I have in mind.  Thanks for the suggestion.


Siirist

You're Welcome,
Siirist
Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

Atrus



I had to manually edit a few of the template files in my theme, and it is now working! I even changed the color and text, and rounded the corners of the button, to fit the theme.

All working great now. Thanks again!

Siirist

You're Welcome,
Siirist
Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

Dylert

Thanks a lot for a really great mod! :)

I have a question: Is it possible to change the info in the profile field of the post from "Total likes" to "Likes given"? How do I do that?

Thanks in advance! :)

PLAYBOY

Does this mod sort out the msgs and topics based on how many likes it has? so It`ll show the best answer for the question on top?
and the topics with most likes are listed on top?


Also is there a Turkish translation? if not I may be able to help out on this

Advertisement: