• Welcome to Simple Machines Community Forum. Please login or sign up.
October 22, 2021, 08:00:35 PM

News:

SMF 2.1 RC4 has been released! Try it out and help us test! :) Read more.


Better Messages Menu (SMF 2.0.x Only)

Started by dougiefresh, November 26, 2017, 10:22:13 AM

Previous topic - Next topic

dougiefresh

Uploaded v1.5 - February 26th, 2018
o Fixed issue causing long pause each page load.
o Added Spanish Latin translation, courtsey of Rock Lee.

dougiefresh

Uploaded v1.6 - April 7th, 2018
o Fixed Spanish Latin translation XML file to properly skip operations.




@chyyyone: Thanks for reporting this bug (source).  It's been fixed for this version!

Steve

Sweet! Not sure why I hadn't installed this before now!
Please do not PM me for support.

dougiefresh

Uploaded v1.7 - October 10th, 2018
o No functionality change.
o Updated documentation to point to new website.

GigaWatt

Has anybody had issues with this mod? Like everyone registered reading their messages when the mod is installed? And then, they seem to go off about their business when the mod is uninstalled :P :D. I guess it's just the power this mod has :D.
"This is really a generic concept about human thinking - when faced with large tasks we're naturally inclined to try to break them down into a bunch of smaller tasks that together make up the whole."

"A 500 error loosely translates to the webserver saying, "WTF?"..."

dougiefresh

@GigaWatt:  I don't understand what you are reporting.  Can you please explain what you mean?  Thanks.....

GigaWatt

Well, when the mod is installed, when I (I haven't tested this with a regular/test user) click on the online users link (the one that tells you what everyone currently browsing the forum is doing :)), every single registered user is reading their messages :P :D... which, of course, can't be true :D... not that I've got like 100, 200 users online at that time, but even if that number is 5, it seems very unlikely that they'll all be reading their messages at the same time... and then suddenly stop doing that when the mod is uninstalled :D.

This happens every time I click the online users link... they can't all be reading their messages at the same time, every single one of them, right, LOL :D.
"This is really a generic concept about human thinking - when faced with large tasks we're naturally inclined to try to break them down into a bunch of smaller tasks that together make up the whole."

"A 500 error loosely translates to the webserver saying, "WTF?"..."

dougiefresh

Yeah.....  They can't all be reading them at the same time.  You're right.  It has everything to do with how the mod functions.  Let me see if I can fix the issue....

dougiefresh

@GigaWatt:  Can you insert the following code in the writeLog function in Sources/Subs.php, just after global variable declarations?  It should be around line 2591 (in the unmodified version of the file)....

// Are we doing something for Better Message Menu mod?
if (!empty($_SESSION['old_url']) && strpos($_SESSION['old_url'], 'action=pm;sa=bettermessages_ucp') !== false)
return;


Let me know if this solves this particular problem.  Thanks!

GigaWatt

Sorry for replying a bit late :).

So let me get this straight, you're suggesting to add this code to Subs.php before I install the mod, then install it, and see if the same thing happens again, right?
"This is really a generic concept about human thinking - when faced with large tasks we're naturally inclined to try to break them down into a bunch of smaller tasks that together make up the whole."

"A 500 error loosely translates to the webserver saying, "WTF?"..."

GigaWatt

Nope... I did what I described in my previous post and it still shows me as viewing my messages :-\, when I'm in fact viewing who's online :-\.

"This is really a generic concept about human thinking - when faced with large tasks we're naturally inclined to try to break them down into a bunch of smaller tasks that together make up the whole."

"A 500 error loosely translates to the webserver saying, "WTF?"..."

Justyne

I am confused. Not sure the screenshot you added to this matches up with what you're saying.
Ever tried. Ever failed. No matter. Try Again. Fail again. Fail better.

GigaWatt

Yeah, my bad... it takes a few seconds for the changes to reflect and I did the screenshot right away. Here's a new one ;).




Hmm... now that's interesting... it shifts between what I'm really doing and viewing my messages just by hitting F5 a few times :D. If "Viewing their messages" shows up, I have to hit F5 two times for "Viewing Who's Online" to show up, but I only have to hit F5 once after "Viewing Who's Online" shows up for it to change back to "Viewing their messages"... weird LOL :D.





I think I added the code in the right place in Subs.php ???.

// Put this user in the online log.
function writeLog($force = false)
{
global $user_info, $user_settings, $context, $modSettings, $settings, $topic, $board, $smcFunc, $sourcedir;

// Are we doing something for Better Message Menu mod?
if (!empty($_SESSION['old_url']) && strpos($_SESSION['old_url'], 'action=pm;sa=bettermessages_ucp') !== false)
return;

// If we are showing who is viewing a topic, let's see if we are, and force an update if so - to make it accurate.
if (!empty($settings['display_who_viewing']) && ($topic || $board))
{
// Take the opposite approach!
$force = true;
// Don't update for every page - this isn't wholly accurate but who cares.
if ($topic)
{
if (isset($_SESSION['last_topic_id']) && $_SESSION['last_topic_id'] == $topic)
$force = false;
$_SESSION['last_topic_id'] = $topic;
}
}
"This is really a generic concept about human thinking - when faced with large tasks we're naturally inclined to try to break them down into a bunch of smaller tasks that together make up the whole."

"A 500 error loosely translates to the webserver saying, "WTF?"..."

shadav

there's a typo in the install
language_spanish_latin.xml
<file name="$languagedir/Profile.spanish_latin-utf8" error="skip">
should be
<file name="$languagedir/Profile.spanish_latin-utf8.php" error="skip">

shadav

trying to install this (2.0.17) and there's no errors (other than the issue mentioned above that I fixed)
but it doesn't work....
went through the parse and double checked that it installed correctly....went to my profile and look and layout and it is set to enabled....

but still nada....

GigaWatt

Hit Ctrl + F5, see if that "fixes" it ;).
"This is really a generic concept about human thinking - when faced with large tasks we're naturally inclined to try to break them down into a bunch of smaller tasks that together make up the whole."

"A 500 error loosely translates to the webserver saying, "WTF?"..."

shadav

 ;D yeah tried that and cleared cache then refreshed....
still no go....

GigaWatt

Hm... strange. Next thing to check - see if all of the edits the mod did are actually written in the modded files. That's what I would do ;).
"This is really a generic concept about human thinking - when faced with large tasks we're naturally inclined to try to break them down into a bunch of smaller tasks that together make up the whole."

"A 500 error loosely translates to the webserver saying, "WTF?"..."

Advertisement: