News:

Wondering if this will always be free?  See why free is better.

Main Menu

Agregar botones al menu en 2.0RC3, RC4

Started by mirahalo, February 16, 2009, 11:02:18 AM

Previous topic - Next topic

mirahalo

hola, no veo ningún problema relacionado con el código, puede ser una cuestión del lenguaje, prueba con esto:


'home' => array(
'title' => 'Portal',
'href' => $scripturl,
'show' => true,
'sub_buttons' => array(
),
),
//-> start add PortaMx
'forum' => array(
'title' => 'Foro',
'href' => $scripturl . '?action=forum',
'show' => $context['PortaMx']['settings']['frontpage'] != 'none',
'sub_buttons' => array(
),



en donde he cambiado el "inicio"  por "Portal"  y también el "forum"  por "Foro"  directamente y así no depender de ningún archivo de idioma.


si aún así, el botón no aparece, tendrás que adjuntar todo tu archivo subs.php y tambien tu archivo index.tuidioma.php  o en su defecto, el archivo en donde portamx pone sus strings de texto, podria ser el modifications.php o un archivo propio de portamx, por lo que ví, parece ser que portamx tiene sus propios archivos de texto.

varen sea

Ok 130860,  no es suficiente, voy a ver si veo algo de lo que me comentas, en cuanto al index.tuidioma.php lo compruebo ahora mismo, también en los archivos del PortaMx aquí ni se me a ocurrido mirar,  voy a ver,
para adjuntar hay un problema y es que no puedo adjuntar todo el subs.php por ejemplo, es por la cantidad de caracteres que dispone el foro, no me deja ya que esta limitado,
si sigo sin dar con la solución ya respondo en este hilo,
gracias 130860,


mirahalo

prueba el subirlo a un servidor de descargas tipo megaupload o similares, y es muy importante que revises los archivos de idioma de portamx   y que adjuntes tu archivo subs.php pues puede haber conflictos de código  si has instalado otros portales antes.

varen sea

#23
Ok dame tiempo ahora no puedo subir a ningún server, he estado mirando el index.tuidioma.php  y tampoco consigo nada , en cuanto pueda subo los archivos aunque no sabría cuales son los que modifican las funciones dentro de la carpeta de PortaMx, también existe dentro de la carpeta Sources otra carpeta del PortaMx...
esta tampoco la he mirado a fondo pero lo dicho en cuanto realice todas las comprobaciones y pueda lo subo, Ah! y si esta completamente limpio el portal ya que estaba indeciso entre el simpleportal y este ultimo, ayer realice la consulta y tal vez la impaciencia me haga precipitarme, y lo he instalado hoy,  en fin aunque tengo en local los dos no me decidía
bueno ya tranquilamente y con paciencia te dejo los archivos, gracias por tu dedicación 130860... O:)
Salu2

Edit: bueno aquí esta, ya me dirás si es suficiente, Salu2 
http://rapidshare.com/files/225127173/Bot_n_Inicio_por_Portal.rar.html

mirahalo

#24
uff, no me habia dado cuenta de que ya habias puesto tu archivo :P ... bueno, deja lo reviso y te aviso...

* 130860 edita ;)

prueba con este archivo adjunto, lo probé en un foro local y funcionó a la perfección, supongo que en el tuyo será igual, revisé el archivo y te faltaban pedazos de código del portamx.

cualquier cosa me avisas ;)

saludos !!!


mirahalo

Quote from: waren on May 10, 2009, 06:49:13 PM
gracias 130860  sin problemas,
Salu2

me alegro de que te haya funcionado ;)

si tienen alguna otrs pregunta, no duden en consultar !!!

pendrakon

hay algna manera de asignarle target al boton, para que se abra en ventana nueva?
thx

mirahalo

hola, bueno eso no se puede hacer desde aqui, sin embargo si es posible hacerlo, para hacerlo tiewnes que ir a tu archivo index.template.php y buscar algo como esto:

// Show the menu up top. Something like [home] [help] [profile] [logout]...

y un poco mas abajo encontraras el diseño para cada botón:


foreach ($context['menu_buttons'] as $act => $button)
echo '<li><a ', $button['active_button'] ? ' class="current"' : '' , ' href="', $button['href'], '"><b>', $button['title'], '</b></a></li>';


este ejem es del theme reference, puede variar en otros themes, ahi simplemente le agregas el target blank




foreach ($context['menu_buttons'] as $act => $button)
echo '<li><a ', $button['active_button'] ? ' class="current"' : '' , ' href="', $button['href'], ' 'target="blank"'"><b>', $button['title'], '</b></a></li>';




desafortunadamente, esto hara que todos los botones tengan ese target, no creo que se pueda hacer para un solo boton anque tratare de investigarlo.

saludos !!!

pendrakon

bueno, muchas gracias, lo otro seria meter el boton a la mala en el index jaja

Crazyes

130860

Donde dices en el manual ahora abre tu index.tuidioma.php donde puedo encotnrarlo?
siendo tuidioma = español = spanish.

Saludos

mirahalo

los archivos que utiliza este manual se encuentran en:

Themes/default/languages/index.tudioma.php  para el index.tuidioma.php

y

Sources/Subs.php para Subs.php


saludos!

Alphonze

#32
Aproximadamente cuanto tiempo toma el visualizar los cambios realizados?

Edito.
Uso: SMF 2.0 RC1-1
Theme: Prof
Simple Portal 2.2.2

Adjunto mis archivos modificados.
Subs.php

'controlp' => array(
'title' => $txt["Panel de Control"],
'href' => 'http://cp.epsilons-dream.com',
'show' => true,
'sub_buttons' => array(
),
),


Index.spanish_es-utf-8.php
$txt['home'] = 'Inicio';

$txt['controlp'] = 'Panel de Control';


Edito nuevamente.
Se ha resuelto el problema anterior, sin embargo después de instalar el portal, el botón inicio me llevaba a al portal precisamente, entonces decidí crear un botón mas con el nombre "Foro".
Seguí el mismo procedimiento que el anterior, pero en este si, no veo cambios, y ya espere un tiempo considerable, por aquellos que dicen que toma su tiempo.

Adjuntos el extracto de Subs.php
'common' => array(
'title' => $txt['common'],
'href' => $scripturl . '?action=forum',
'show' => true,
'sub_buttons' => array(
),
),


Aca el de mi index.spanish...........

$txt['controlp'] = 'Panel de Control';

$txt['common'] = 'Foros';

ZerK


Alphonze

Pues no aparece el titulo del botón, pero el espacio esta creado correctamente.

hxxp:img197.imageshack.us/img197/6550/dibujouxt.png [nonactive]

mirahalo

bueno, puedes utilizar esta manera, aqui ya no se necesitan agregar lineas a tus archivos de texto:

'common' => array(
'title' => 'foros',
'href' => 'misitio.com/index.php?action=forum',
'show' => true,
'sub_buttons' => array(
),
),


y directamente te mostrara la palabra foros y la direccion misitio.com/index.php?action=forum,   tambien, si utilizas simpleportal, el portal te agrega automaticamente los dos botones, uno para el foro y otro para el portal:


'home' => array(
'title' => $txt['home'],
'href' => $modSettings['sp_portal_mode'] == 3 ? $modSettings['sp_standalone_url'] : $scripturl,
'show' => true,
'sub_buttons' => array(
),
),
'forum' => array(
'title' => empty($txt['sp-forum']) ? 'Forum' : $txt['sp-forum'],
'href' => $scripturl . ($modSettings['sp_portal_mode'] == 1 ? '?action=forum' : ''),
'show' => in_array($modSettings['sp_portal_mode'], array(1, 3)),
'sub_buttons' => array(
),
),


y dependiendo de el modo en que uses el portal, el boton aparecera o no aparecera, utiliza el modo "pagina frontal".

saludos!

amartin

hola como estan estuve tratando de poner otro boton en mi foro pero no caigo como hacerlo probe de varias formas pero ni modo si alguien me tira un cable se lo agradezco mucho saludos!!! ;D

mirahalo

seguiste las instrucciones del tutorial ?


cual es el enlace que quieres agregar?

adjunta tu archivo Sources/Subs.php para ayudarte.

Akir-Anime

Quote from: waren on April 03, 2009, 01:36:44 PM
hola 130860, estoy siguiendo este manual y me encuentro con un pequeño problema, antes de nada aclarar que he seguido el manual como lo explicas.....
el problema es que el botón no se ve....


bueno ya me diréis si falta algo y gracias.....
Salu2



me ocurre lo mismo que le paso a warren en ese momento....

podrian ayudarme a ver porque pasa eso...

mirahalo

@Akir-Anime   asegurate de que hayas puseto correctamente los strings de texto:

en tu archivo Themes/default/languages/index.tuidioma.php

$txt['boton'] = 'boton';   en donde  cambias ell boton por la palabra que quieras que aparezca en el boton.

tambien, borra el cache de tu navegador y tambien el de tu foro, lop uedes hacer desde admin/mantenimiento.

saludos!

Advertisement: