• Welcome to Simple Machines Community Forum. Please login or sign up.
October 24, 2021, 02:59:23 AM

News:

Join the Facebook Fan Page.


SimplePortal

Started by SimplePortal Team, March 10, 2008, 11:16:07 PM

Previous topic - Next topic

[SiNaN]

Italian Lanugage is added as a package. I would be glad if you check it.
Former SMF Core Developer | My Mods | SimplePortal

maxdg

Seems to be ok and working.

Since I have integrated SMF in Joomla I modified the last istruction from:

<file name="$languagedir/index.italian.php">
<operation>
<search position="end" />
<add><![CDATA[$txt['sp-forum'] = 'Forum';]]></add>
</operation>
</file>


to

<file name="$languagedir/index.italian.php">
<operation>
<search position="end" />
<add><![CDATA[$txt['sp-forum'] = 'Indice';]]></add>
</operation>
</file>


..because I just have a "Forum" link on the website menu to the "Home" page of the forum..

So I preferred to change "Forum" link in "Indice" (Index) for better understanding.

It's only a choice.. maybe I will modify that "Home" link in something like "SPortal" .... still not sure..

[SiNaN]

Is the "Forum" correct for the Italian language?
Former SMF Core Developer | My Mods | SimplePortal

maxdg

March 12, 2008, 11:56:51 AM #23 Last Edit: March 12, 2008, 12:02:15 PM by maxdg
Quote from: [SiNaN] on March 12, 2008, 10:13:12 AM
Is the "Forum" correct for the Italian language?

More than others.. because it's a latin word: (pl. "fora" and not "forums")
Anyway, I have keep some words as the original english (like "post", "board" and so) because in internet we (as many) use the same words..

Overall.. I preferred the short word when possible and in the "online users" block there isn't  the word "online" in "online users", "online guests"... for a better layout..

;)

ivo2296

I would like to give a try but my forum is in my domain root installed - Will that be a problem?

maxdg

Quote from: ivo2296 on March 12, 2008, 02:36:17 PM
I would like to give a try but my forum is in my domain root installed - Will that be a problem?

I think it's the best way you can use it.

My 2 cents

ivo2296

Quote from: maxdg on March 12, 2008, 02:52:09 PM
Quote from: ivo2296 on March 12, 2008, 02:36:17 PM
I would like to give a try but my forum is in my domain root installed - Will that be a problem?

I think it's the best way you can use it.

My 2 cents

hehe oki-doki :)

what about the uninstaller - is it work good? - my forum is 3 years old and i don't want to demolish everything. My opinion is talking now... :) 

maxdg

Best is ALWAYS backing up your site and database... and you go fearless... ;)

(I didn't uninstall it yet... )

maxdg

Just a little question to SiNaN:

How can I make the text flowing form right to left without blank space, in the Announce block?

Thanks

A pic to show what I mean:

brianjw

I have to say it's very nice and very simple. I'd like to see the mod further coded and continued for custom blocks and even other ideas.

[SiNaN]

Quote from: ivo2296 on March 12, 2008, 05:34:45 PM
what about the uninstaller - is it work good? - my forum is 3 years old and i don't want to demolish everything. My opinion is talking now... :) 

If you didn't get any error during the install, uninstalling should be just a piece of cake.

Quote from: maxdg on March 12, 2008, 09:24:16 PM
Just a little question to SiNaN:

How can I make the text flowing form right to left without blank space, in the Announce block?

You can use the html tag <marquee> in the texbox that you write the announcement.

Quote from: brianjw on March 12, 2008, 10:16:22 PM
I have to say it's very nice and very simple. I'd like to see the mod further coded and continued for custom blocks and even other ideas.

I hope too. This is just start. Thanks.
Former SMF Core Developer | My Mods | SimplePortal

maxdg

Quote from: [SiNaN] on March 13, 2008, 11:04:50 AM
You can use the html tag <marquee> in the texbox that you write the announcement.

Sorry, I wasn't clear enough..

The only thing I want is to have the "NEWS" text area filled at 100%, where there's the posts preview..

Thanks!

[SiNaN]

Quote from: maxdg on March 12, 2008, 09:24:16 PM
How can I make the text flowing form right to left without blank space, in the Announce block?

SPortal.template.php

Find:

<tr class="windowbg" align="center">

Replace:

<tr class="windowbg">

Quote from: maxdg on March 13, 2008, 12:09:21 PM
The only thing I want is to have the "NEWS" text area filled at 100%, where there's the posts preview..

It should be I think. But if not, can you try this:

SPortal.template.php

Find:
<div>
<a href="', $news['href'], '">', $news['icon'], '</a> <b>', $news['subject'], '</b>
<div class="smaller">', $news['time'], ' ', $txt[525], ' ', $news['poster']['link'], '</div>

<div class="post" style="padding: 2ex 0;">', $news['body'], '</div>


Replace:

<div width="100%">
<a href="', $news['href'], '">', $news['icon'], '</a> <b>', $news['subject'], '</b>
<div class="smaller">', $news['time'], ' ', $txt[525], ' ', $news['poster']['link'], '</div>

<div class="post" style="padding: 2ex 0;" width="100%">', $news['body'], '</div>
Former SMF Core Developer | My Mods | SimplePortal

maxdg

Quote from: [SiNaN] on March 13, 2008, 12:20:04 PM
It should be I think. But if not, can you try this:

It doesn't..

I tried your code and still no success..

As you can see in the posted pic I use a different template than default.
Perhaps it may be a CSS problem?

I have a "style.css" file in my template folder but there isn't any "smaller" class.
Only a "post" class like this:

.post, .personalmessage
{
width: 100%;
overflow: auto;
line-height: 1.3em;
}

...and it's 100%.. :-/


brianjw


[SiNaN]

March 14, 2008, 02:38:59 AM #36 Last Edit: March 14, 2008, 02:44:57 AM by [SiNaN]
maxdg, I tested in the default and in some other themes. There is not such an error. But another member reported such an error with a likely theme. I will check with the theme you use also.

Quote from: NIBOGO on March 13, 2008, 07:45:53 PM
i cant install this mod in my forum

i make a manual edit and didnt work

I guess you've made a mistake during the edit. Please check them again.

//Edit: Same theme, no error. :S http://bizmuhacirler.com/test/index.php
Former SMF Core Developer | My Mods | SimplePortal

[SiNaN]

I've found the error. It appears only when avatars are disabled in the news.

SPortal.template.php

Find:

<td colspan="2">
<hr style="margin: 2ex 0;" width="100%" />


Replace:

<td', $modSettings['nshowavatar'] ? ' colspan="2"' : '', '>
<hr style="margin: 2ex 0;" width="100%" />
Former SMF Core Developer | My Mods | SimplePortal

jusplay77

First off, I must say this is a great portal!  I previously had gencportal installed but had too many errors.  This one is a great start and has potential as well.  Very well done.

--

For further development, it would be nice to choose which boxes go on which side (LEFT or RIGHT). 

-

Also, exclusion of certain boards from the "Top Boards" List would be nice.  (As I have Several Archives Forums where I move old topics... And I do not want any Archive Boards showing up in The Top Boards section).  So perhaps a block that says:

[Board ID's that you do not want counted in Top Boards]: [ 2,5,15,23 ]  (Separate by comma)

-

Lastly, Custom Boxes would be nice to add as well (Such as SMF Shop Recently Purchased Items, SMF Pets Leadersboard, SMF Arcade Latest High Scores, SMF Downloads Latest Download Additions, etc).. The possibilities are endless..

maxdg

QuoteI've found the error. It appears only when avatars are disabled in the news.

Great, good job!

I disabled avatars because they overlaying the text.. but only if measures aren't standard.
The working theme you link to me has little avatars..

Advertisement: