News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord

Main Menu

Mibbit Ajax IRC Chat

Started by KCToker, June 18, 2008, 11:04:54 PM

Previous topic - Next topic

Bugo

Error log (default settings):

Undefined index: ircChannels
Undefined index: ircServer
Undefined index: ircHeight
Undefined index: ircWidth


And add please $charset parameter, by example:
echo"
<iframe width=$width height=$height scrolling='no' frameborder='0'
src='http://embed.mibbit.com/?server=" . $server . "&channel=" . $channels . "&nick=" . $userchatname . "&noServerTab=false&charset=" . $charset . "'>
</iframe></div>";

KCToker

Updated version for SMF 1.1.11 is now out! I also did a bit of messing with the version numbers which should help to ease confusion about which one should be used.

Quote from: Bugo on August 30, 2010, 11:21:10 AM
Error log (default settings):

Undefined index: ircChannels
Undefined index: ircServer
Undefined index: ircHeight
Undefined index: ircWidth


And add please $charset parameter, by example:
echo"
<iframe width=$width height=$height scrolling='no' frameborder='0'
src='http://embed.mibbit.com/?server=" . $server . "&channel=" . $channels . "&nick=" . $userchatname . "&noServerTab=false&charset=" . $charset . "'>
</iframe></div>";


Which version of SMF were you using when you got those errors?

Also for charsets, I haven't really dealt with them much, but looking at Mibbit's wiki for supported charsets, it shouldn't be too hard to add of drop-down option in the config page. My only concern would be with an admin's selection of a non-default charset and creating problems for end-users using a different charset.

Again I haven't dealt with charsets much but I'll look into it.

Bugo

Quote from: KCToker on August 31, 2010, 09:14:08 AM
Which version of SMF were you using when you got those errors?
Rhetorical (or stupid) question? SMF 2.0 RC3.

KCToker

Quote from: Bugo on August 31, 2010, 09:47:34 AM
Quote from: KCToker on August 31, 2010, 09:14:08 AM
Which version of SMF were you using when you got those errors?
Rhetorical (or stupid) question? SMF 2.0 RC3.

I thought that was it, but I wanted to make sure.

The only thing its sending to the error log is the notice that no values have been entered when it does the check to see if values have been entered XD. If the check comes back negative (meaning no values were entered in the config page) then it sets the values at defaults hard-coded into the script (600x450 widget size, irc.mibbit.com [nofollow] server, #mibbit channel).

flutter

I don't think I get this.  I went to ibit and set up an account.  I chose my nickname and tried to use it on my site.  I was told that my nickname was already in use and it wouldn't connect me on my site.

I thought I'd be creating our own chat room which we could use on the site and as I'm the first on my site to connect to it I have to wonder why my username could already be taken.

Bobn

How do I get rid of the ad's at the top of the chat?

Bobn


rakicko


Senkusha

Any chance for an 2.0 RC4 update to fix the subs.php code addtion?
--Senkusha ("Kokoro")
Anime Gaming Galaxy
Classic Anime-style Role Playing Games and Discussion.
(SMF v. 2.1.2, PHP v. 8.0)

Sylar!

Hi.

i am using latest one on 2.0 RC5.its working normally atm.But i need 1 more thing.On chat login screen there is just nickname field.I wanna use nick and password field (it can work if nick registered).Also you can check my chat on here -> http://hex.us.gg/index.php?action=chat [nofollow]

Regards.

mianosm

Quote from: Senkusha on January 19, 2011, 09:56:10 PM
Any chance for an 2.0 RC4 update to fix the subs.php code addtion?

I noted that I needed to manually make this change/fix.

Feature Requests:
      - Select pixel/percentage choice for the iframe.
      - Enable the ability to add a user selected theme to better integrate into the SMF.
            (I'm using:  src='http://embed.mibbit.com/?server= [nofollow]" . $server . "&channel=" . $channels . "&settings=1529ea977baeb4471a913b48465ca96e" . "&nick=" . $userchatname . "&noServerTab=false'>)
      - Linktree does not appear to be correctly updating (I haven't checked into this fully, but I know it isn't working correctly across themes).

Thanks a ton if you are able to check back here at all KCToker, great mod, hope to see more updates! = )

Rumblepack

#71
Hi,

i have a little problem with the mod for the mibbit irc, im using the smf 2.0 rc5 but the mibbit irc is for the 1.x or 2.0 rc3, i dowloaded the    Mibbit_Ajax_IRC_2.0.zip.
the mod is installed on the webserver and i can change the height and widht and irc server/chan but the mod dosnt work on the forum itself. to me i dont know about any phpcoding or something  :-\ can anybody help me?

greets

Bobn

Installed on RC 5 but there is no chat button?

Rumblepack

yap thats my prob too, the addon is installled but smf rc5 cant open the addon. I hope KCToker makes a update for rc5.


mianosm

If you guys parse the modification you can add the button (notice the subs.php talk just above your posts guys).

Wintaru

#75
I'm not having much luck getting this working on 1.1.13, which is what my host has available to use. 

Would you recommend upgrading SMF to RC3, or somehow shoe-horning this into my 1.1.13 install?  The issue is there is no chat button nor is there a configuration section for it once installed.  I'm not a complete noob to PHP, but this is a bit beyond my skills.

Edited to add that viewing the page source after this mod is installed, I see that the link is in the menu, but there is no label in between the anchor tags so it looks like this:

<td valign="top" class="maintab_back">

<a href="http://lootwhorindramafest.com/index.php">Home</a>
</td>
<td valign="top" class="maintab_back">
<a href="http://lootwhorindramafest.com/index.php?action=chat"></a>
</td>
<td valign="top" class="maintab_back">
<a href="http://lootwhorindramafest.com/index.php?action=help">Help</a>
</td>


Edit Again:

Found where it was set, in the index.template.php and the index.english.php, but I can't see why it's not working.

This value in index.english.php: "$txt['chat'] = 'Chat';"

Corresponds to this chunk in index.template.php:


// Show the [chat] button.
echo ($current_action=='chat' || $context['browser']['is_ie4']) ? '<td class="maintab_active_' . $first . '">&nbsp;</td>' : '' , '
<td valign="top" class="maintab_' , $current_action == 'chat' ? 'active_back' : 'back' , '">
<a href="', $scripturl, '?action=chat">' , $txt['chat'] , '</a>
</td>' , $current_action == 'chat' ? '<td class="maintab_active_' . $last . '">&nbsp;</td>' : '';



Not sure what the issue is :(

Moric

can u u guys give tell me how to run this in SMF 2.0 RC5

Gryzor


Ruddy Kitty

...*blows dust off of thread*

I'm pretty sure I won't be getting an answer to this since it has been so long, however...

I've finally come to add a chat to my site (mibbit irc chat) and received these problems upon installation (see attachment).

How do I fix this? Also, can I continue the installation without my forum exploding?

Please help, thanks!

Shambles

Quote from: Ruddy Kitty on March 15, 2012, 07:20:37 AM
I'm pretty sure I won't be getting an answer to this since it has been so long, however...
Wrong  :P


Quote from: Ruddy Kitty on March 15, 2012, 07:20:37 AM
I've finally come to add a chat to my site (mibbit irc chat) and received these problems upon installation (see attachment).

How do I fix this? Also, can I continue the installation without my forum exploding?
Click the little pencil-on-paper icon to the left, to display a popup of the string in subs.php that's being searched for. Chances are you have a mod installed that changed the line being searched for. I wouldn't proceed with the installation (but I personally would change the mod to fit the line being searched - others might change the line in subs.php to fit the mod)

Advertisement: