News:

SMF 2.0.19 has been released! Please update. Read more.

Main Menu

SMF Quiz

Started by Diego Andrés, February 18, 2009, 01:08:19 PM

Previous topic - Next topic

Dave J

Quote from: Shades. on March 28, 2012, 09:02:17 PM
Worked like a charm! Thanks! ;)

Only problem I'm having is the search feature...searching for certain quizzes, even though they're there, the search feature produces a page with nothing found. Is there any fix for that or did I miss it somewhere. I've read this support thread back to page 19 but I might have overlooked it!??

Glad it's working for you OK.

I have tried this on all three forums I have set up and it works on all of them, including my test sites one of which is a fresh install of SMF 2.0.2...see screen shot.

What should happen is when you type into the search box it should populate an area below it, as seen in the image, of all the possible matches to your entry. Then all you do is click on one of them and the quiz should open ready to play.

If thats not happeneing it's possible you need to run the 'Database' maintenance 'Optimize all tables' and maybe go through and clear the site cache etc too.

If that doesn't work then I have no idea why it wont. 
If you want quizzes to add to the new SMF2.1 quiz mod go here . There are also walkthroughs in the forum to explain how to install them and other tips.

GlitchPC

Question...

Anyone know the correct code to fix this issue?  (See attached image)

It appears the left title bar is chopped...while the right is rounded.  I'd like the left to appear rounded, as well.

Remember...I am NOT a coder.  Take my hand, gently, please...

TheListener

Quote from: GlitchPC on March 29, 2012, 01:05:22 PM
Question...

Anyone know the correct code to fix this issue?  (See attached image)

It appears the left title bar is chopped...while the right is rounded.  I'd like the left to appear rounded, as well.

Remember...I am NOT a coder.  Take my hand, gently, please...

Do you use Simple Portal? I see you do.

Try adding portal.css to your theme.

Dave J

Quote from: GlitchPC on March 29, 2012, 01:05:22 PM
Question...

Anyone know the correct code to fix this issue?  (See attached image)

It appears the left title bar is chopped...while the right is rounded.  I'd like the left to appear rounded, as well.

Remember...I am NOT a coder.  Take my hand, gently, please...

Can you check and see if the 'quiz_css' folder is in the themes css directory!! It needs to be in each themes css directory not just the default one.

If it's not then transfer the whole folder in to the css directory.

If that doesn't work then I don't know, sorry Glitch
If you want quizzes to add to the new SMF2.1 quiz mod go here . There are also walkthroughs in the forum to explain how to install them and other tips.

TheListener

Has anyone seen this error before?

Apply Filter: Only show the error messages of this URL
xxxxxxxxxxxxxindex.php?action=admin;area=quiz;sa=adminCenter
Apply Filter: Only show the errors with the same message
8: Trying to get property of non-object
Apply Filter: Only show the errors from this file
File: /xxxxxxxxxx/public_html/Sources/SMFQuizAdmin.php
Line: 2408

GlitchPC

I'm using SimplePortal 2.3.5.  There's no need for the portal.css to be uploaded.  The issue appears the same in both themes...so uploading the quiz css folder didn't work, either.

I appreciate the effort, though...I know it's a coding issue...just don't know where...

Shades.

Quote from: davejo on March 29, 2012, 03:00:15 AM
Quote from: Shades. on March 28, 2012, 09:02:17 PM
Worked like a charm! Thanks! ;)

Only problem I'm having is the search feature...searching for certain quizzes, even though they're there, the search feature produces a page with nothing found. Is there any fix for that or did I miss it somewhere. I've read this support thread back to page 19 but I might have overlooked it!??

Glad it's working for you OK.

I have tried this on all three forums I have set up and it works on all of them, including my test sites one of which is a fresh install of SMF 2.0.2...see screen shot.

What should happen is when you type into the search box it should populate an area below it, as seen in the image, of all the possible matches to your entry. Then all you do is click on one of them and the quiz should open ready to play.

If thats not happeneing it's possible you need to run the 'Database' maintenance 'Optimize all tables' and maybe go through and clear the site cache etc too.

If that doesn't work then I have no idea why it wont.

The search partially works for me. (See attachments below)

The first attachement show when I type "Countries" in the search field the results are shown under the field as I type it...that's works fine. But in the second attachment, it show what appears after hitting enter.

Oh and by the way, I wasn't getting the search result under the search box (see 1rst attachment) until I followed your suggestion for doing the database maintenance so thank you for that! But why don't the appear after pressing enter or search?
ShadesWeb.com - Custom Logos - My Themes on SMF | My Themes on ShadesWeb
https://shadesweb.com

BikerHound.com - Sniffing out the road ahead
https://bikerhound.com

Dream as if you'll live forever; Live as if you'll die today. - James Dean

Ozzie

QuoteThe first attachment show when I type "Countries" in the search field the results are shown under the field as I type it...that's works fine. But in the second attachment, it show what appears after hitting enter.


yer that is correct it as always been that way the search only works correctly on the quiz home page

2000+ games available to download

emanuele

Quote from: GlitchPC on March 29, 2012, 01:05:22 PM
Question...

Anyone know the correct code to fix this issue?  (See attached image)

It appears the left title bar is chopped...while the right is rounded.  I'd like the left to appear rounded, as well.

Remember...I am NOT a coder.  Take my hand, gently, please...

The generic idea is that each "h3" title should be surrounded by a <div class="title_bar"></div>...

For example in SMFQuiz.template.php, search for:

<h3 class="titlebg" style="min-height:30px; padding:0">
<span class="left"></span>
' , $txt['SMFQuiz_Common']['QuizHome'] , '
</h3>

it should be replaced by:
<div class="title_bar">
<h3 class="titlebg" style="min-height:30px; padding:0">
<span class="left"></span>
' , $txt['SMFQuiz_Common']['QuizHome'] , '
</h3>
</div>


Problem is that there are 8 to fix only in the main page...

Well, while I'm at it I can say I asked (few weeks ago) the permission to the original author to continue his work, he agreed and now I'm working on the mod.
First a big thank you to davejo for the copy he provided!! And for his support, I hope he will continue! :D

I started from his work to remove the errors, then I fixed (and I'm still fixing) few issues I knew, and few other I found (plus those that you found like the one reported by GlitchPC, of course if there are others feel free to bump them, I went very quickly through the topic...).
I'm now working on an import function (for a start from local files) for new quizzes. As soon as this will be read I'll update the mod on the mod site!


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Shades.

Quote from: Ozzie on March 29, 2012, 05:54:42 PM
QuoteThe first attachment show when I type "Countries" in the search field the results are shown under the field as I type it...that's works fine. But in the second attachment, it show what appears after hitting enter.


yer that is correct it as always been that way the search only works correctly on the quiz home page
Ok, I understand that but how do we fix the actual results page? Shouldn't the result page display some search results instead of nothing after pressing enter or search? ???
ShadesWeb.com - Custom Logos - My Themes on SMF | My Themes on ShadesWeb
https://shadesweb.com

BikerHound.com - Sniffing out the road ahead
https://bikerhound.com

Dream as if you'll live forever; Live as if you'll die today. - James Dean

Ozzie

thats never worked either you just click on 1 from the list below the search box  if you click enter you get what you got (nothing)....dont know why but it as never worked and i have used it for years now and it as always been the same.....sorry i cannot give you better news  :laugh:

2000+ games available to download

Shades.

Ok thanks! Maybe someone can fix that later on! I appreciate the help! :)
ShadesWeb.com - Custom Logos - My Themes on SMF | My Themes on ShadesWeb
https://shadesweb.com

BikerHound.com - Sniffing out the road ahead
https://bikerhound.com

Dream as if you'll live forever; Live as if you'll die today. - James Dean

Dave J

Quote from: emanuele on March 29, 2012, 06:26:08 PM

Well, while I'm at it I can say I asked (few weeks ago) the permission to the original author to continue his work, he agreed and now I'm working on the mod.

I'm glad you told everyone as it was getting increasingly difficult for me to keep the secret ;)

With the errors that were being raised I just wanted to say to everyone...live with what you've got till Emanuele has fixed it.

Anyway folks as Emanuele has said he is working on the mod to update and improve things. He is also going to work on a similar function to the original quiz mod that you could share quizzes made by others.

So hopefully in the not too distant future this mod will rise again from the ashes and be as good if not better than the original.
If you want quizzes to add to the new SMF2.1 quiz mod go here . There are also walkthroughs in the forum to explain how to install them and other tips.

FrizzleFried

This is,  indeed,  good news.  I'm quite frustrated as it stands... I have no idea why it would work in a stock installation but not in my custom installation... even though no errors are reported.

:(

emanuele

FrizzleFried what exactly is not working for you?

I found this post:
Quote from: FrizzleFried on March 15, 2012, 09:53:20 AM
I keep getting this error...

http://www.xxxxxxxxxx.com/index.php?action=SMFQuiz;sa=categories;id_quiz=483
8: Undefined index:
File: /home/ahaforum/public_html/testingsite/Sources/Subs.php
Line: 3949
And the following where you explained you removed the logout button and getting an "undefined index" error.
Are you getting it only in the quiz page?


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

FrizzleFried

Long story... please ignore the LOGOUT unidentified index questions of past.  Basically,  I couldn't get it going on my modified theme... it would install correctly... no errors at all.  I could see the quizzes... but when I select a quiz... it would open the quiz window and... do nothing.

SO... i set up a test site and installed it on a bare version of 2.0.2.  It installed correctly and it WORKED.  So I figured  what the hell and bridged my forum to the test forum to run only the quiz.  THAT is where I was having the problems... basically all the mods I did to my main site weren't on the other site so when people did things OTHER than the quiz on the other site the errors flew... so I attempted to remove EVERYTHING other than the quiz from the other site... so the users couldn't click to go anywhere other than the quiz and HOME (which took you back to the main site).

Lets say I gave up.   I am back to only my main site and quiz installed... but it's doing the very same thing it did originally.  It works as intended other than when you click to play a quiz,  the quiz window opens and ... nothing.

But at least I don't have 2,500 errors per day filling up my logs.

:)

I'd love to get them going again as they were pretty popular here in the 3 weeks I had them going (albeit jury-rigged).


emanuele

So it seems a problem with a custom theme. And that's already something.

Did you modify Curve or did you use another theme?
Or did you create a new theme based on curve, or which other variation did you use? :)

In the meantime I'll test with non-default themes to see if there are problems.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

FrizzleFried

Quote from: emanuele on March 30, 2012, 02:50:04 PM
So it seems a problem with a custom theme. And that's already something.

Did you modify Curve or did you use another theme?
Or did you create a new theme based on curve, or which other variation did you use? :)

In the meantime I'll test with non-default themes to see if there are problems.

It's the default curve theme... with a BUNCH of mods added...

emanuele

Then can you send me the data of an account? (don't need (and don't want) admin, just a user that can play a quiz)


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

FrizzleFried

As I reported to Emanuele directly... it seems I managed to 'fix" the Quiz SOMEHOW.  When I took it off line it was NOT working.  That was last week.  Since then I have added a couple mods and fixed a couple bugs... I also added the newer Hooks program.  Not sure what did it... but QUIZ works.

MOSTLY it seems.

I am getting these errors in my log:

Apply Filter: Only show the error messages of this URL
http://www.aha-forums.com/index.php?action=admin;area=quiz;b502cea71=0e200771b21ac0c4acdee824fdcee597
2: Invalid argument supplied for foreach()
File: /home/ahaforum/public_html/Themes/default/SMFQuizAdmin.template.php
Line: 1740

http://www.aha-forums.com/index.php?action=admin;area=quiz;b502cea71=0e200771b21ac0c4acdee824fdcee597
8: Trying to get property of non-object
File: /home/ahaforum/public_html/Sources/SMFQuizAdmin.php
Line: 2411

http://www.aha-forums.com/index.php?action=admin;area=quiz;b502cea71=0e200771b21ac0c4acdee824fdcee597
8: Trying to get property of non-object
File: /home/ahaforum/public_html/Sources/SMFQuizAdmin.php
Line: 2408


Ideas?

Advertisement: