• Welcome to Simple Machines Community Forum. Please login or sign up.

[UNSOLVABLE?] Red post-moderation "(!)" remains despite member account deletion

Started by css_script_writer, September 15, 2010, 08:38:00 PM

Previous topic - Next topic

css_script_writer

Sorry to do this (I really need help here!). It's been another 24 hours (almost to the minute). Surely, there must be a developer or tech-savvy user who has some semblance of a solution to this. As I indicated the other day, I've already done all of the obvious things. In fact, I've systematically gone down the list and performed/checked every way I could possibly find to try and resolve this issue.

Any idea as to what might be causing this and what can be done to fix it?...please?...

- CSS
Anxiety Zone Forums & Chat Rooms
http://www.anxietyzone.com/index.php

xenovanis

You'll have to enter the correct session_id for this to work. Hover over that or any other topic awaiting approval and it should show the session stuff.



/index.php?action=moderate;area=postmod;sa=approve;topic=topic_id_here;msg=message_id_here;session_stuff_here
"Insanity: doing the same thing over and over again and expecting different results."

css_script_writer

Thank you so much for responding!. When I hover the cursor over the red "(!)" it says "Unapproved Posts (Topics:0 Posts: 2)" but when I actually click on the red "(!)", it takes me to a page that says "There are currently no posts awaiting approval" and shows 0 topics and 0 replies so there really is nothing there to delete apparently. I'm assuming this is some sort of remnant or artifact left over in the cache and yet I've cleared the file cache, browser cache  and done all sorts of other things to make it go away. I even tried the following modification with your URL...

YOUR CODE:
/index.php?action=moderate;area=postmod;sa=approve;topic=topic_id_here;msg=message_id_here;session_stuff_here

MY MODIFICATION:
http://www.anxietyzone.com/index.php?action=moderate;area=postmod;sa=approve;brd=57;db66faa54367=d15370b7a5d1a45fd3d5720ab9354177

Not sure what to do next...

- CSS

Quote from: xenovanis on September 20, 2010, 07:37:34 AM
You'll have to enter the correct session_id for this to work. Hover over that or any other topic awaiting approval and it should show the session stuff.



/index.php?action=moderate;area=postmod;sa=approve;topic=topic_id_here;msg=message_id_here;session_stuff_here

Anxiety Zone Forums & Chat Rooms
http://www.anxietyzone.com/index.php

MrVista

You are not alone with a problem like this.

After upgrading our forum all old posts are like this and I can't get it working either.
Sadly not much help in my thread...

http://www.simplemachines.org/community/index.php?topic=387804.0;topicseen

xenovanis

So, on my testforum I created a testaccount. I set the warninglevel for the testaccount to postmoderation. I made two posts with the testaccount and then deleted it, without deleting the posts.

As an admin, I still was able to approve one post and delete another one which wasn't approved, and the exclamation mark disappeared.

So I created a new testaccount and put it on postmoderation. I let the account post 2 topics and deleted the account, including their posts and topics. The posts were gone and so was the notice (!) for moderators.

Funny things going on then ;)

Could you provide me with an admin account css_script_writer? Please read this first:
http://www.simplemachines.org/community/index.php?topic=228940.0

Just drop me a PM. I'll either take a look tonight or tomorrow.
"Insanity: doing the same thing over and over again and expecting different results."

css_script_writer

Hi

Well, I'm really not at liberty to provide that information - even as much as I genuinely appreciate the effort you obviously went to in testing and attempting to reproduce this apparent glitch. I hope that won't cause any hard feelings or prevent further discussion of this matter with the possibility of a positive outcome if someone can figure out what is causing this to occur.

Perhaps, it will be resolved when a patch is released or when 2.0 Final comes out. This is one of only a number of bugs but of course that is to be expected with any unfinished software.

- CSS

Quote from: xenovanis on September 20, 2010, 03:02:11 PM
So, on my testforum I created a testaccount. I set the warninglevel for the testaccount to postmoderation. I made two posts with the testaccount and then deleted it, without deleting the posts.

As an admin, I still was able to approve one post and delete another one which wasn't approved, and the exclamation mark disappeared.

So I created a new testaccount and put it on postmoderation. I let the account post 2 topics and deleted the account, including their posts and topics. The posts were gone and so was the notice (!) for moderators.

Funny things going on then ;)

Could you provide me with an admin account css_script_writer? Please read this first:
http://www.simplemachines.org/community/index.php?topic=228940.0

Just drop me a PM. I'll either take a look tonight or tomorrow.
Anxiety Zone Forums & Chat Rooms
http://www.anxietyzone.com/index.php

xenovanis

No hard feelings  ;) I'm just reaching a point where I have to see things for myself though.

Could you run this query in phpMyAdmin?

SELECT * FROM `smf_messages` WHERE `approved` = '0'


phpMyAdmin will return a list of unapproved messages. Please see if you can find the messages that are haunting you are there.
"Insanity: doing the same thing over and over again and expecting different results."

css_script_writer

Thanks, I tried the query and it returned an "empty result" which means that these "ghost" topics/posts awaiting approval do not exist in the database. So where are they coming from?. This is really odd.

- CSS
Anxiety Zone Forums & Chat Rooms
http://www.anxietyzone.com/index.php

Oya

Quote from: css_script_writer on September 29, 2010, 10:41:07 AM
Thanks, I tried the query and it returned an "empty result" which means that these "ghost" topics/posts awaiting approval do not exist in the database. So where are they coming from?. This is really odd.

- CSS

please now run
SELECT * FROM `smf_topics` WHERE `unapproved_posts` > 0

css_script_writer

Thanks, just tried it and here is the result...

MySQL returned an empty result set (i.e. zero rows). ( Query took 0.0296 sec )

I also experimented with...

SELECT * FROM `smf_topics` WHERE `unapproved_topics` > 0
SELECT * FROM `smf_topics` WHERE `unapproved_replies` > 0

Really puzzling now...

- CSS
Anxiety Zone Forums & Chat Rooms
http://www.anxietyzone.com/index.php

Oya

Quote
SELECT * FROM `smf_topics` WHERE `unapproved_topics` > 0
SELECT * FROM `smf_topics` WHERE `unapproved_replies` > 0

these two columns do not exist so im not sure what querying would have told u...

the *only* other place this value can now remain is in the file cache on the server

go to cache/ and remove every file except for any .htaccess file and index.php

Joker™

Just a suggestion , try this

Administration Center » Forum Maintenance » Database » Optimize all tables
Github Profile
Android apps
Medium

How to enable Post Moderation

"For the wise man looks into space and he knows there is no limited dimensions." - Laozi

All support seeking PM's get microwaved

css_script_writer

Thanks for all of the help and info. What's really odd is that when I FTP into cache/, I only see those two files (ie; .htaccess and index.php). There is nothing else there. Could it be cached elsewhere?.

Quote from: Oya on September 29, 2010, 12:59:57 PM
Quote
SELECT * FROM `smf_topics` WHERE `unapproved_topics` > 0
SELECT * FROM `smf_topics` WHERE `unapproved_replies` > 0

these two columns do not exist so im not sure what querying would have told u...

the *only* other place this value can now remain is in the file cache on the server

go to cache/ and remove every file except for any .htaccess file and index.php
Anxiety Zone Forums & Chat Rooms
http://www.anxietyzone.com/index.php

Joker™

Quote from: css_script_writer on September 30, 2010, 08:54:07 AM
Thanks for all of the help and info. What's really odd is that when I FTP into cache/, I only see those two files (ie; .htaccess and index.php). There is nothing else there. Could it be cached elsewhere?.
Afaik , answer is no. Have you tried this
Quote from: Joker™ on September 29, 2010, 01:23:58 PM
Just a suggestion , try this

Administration Center » Forum Maintenance » Database » Optimize all tables
Github Profile
Android apps
Medium

How to enable Post Moderation

"For the wise man looks into space and he knows there is no limited dimensions." - Laozi

All support seeking PM's get microwaved

xenovanis

Running out of options, but please try these queries:


UPDATE smf_messages SET `approved` = '1';


and

UPDATE smf_topics SET `approved` = '1'  AND `unapproved_posts` = '0';


BACKUP UP YOUR DATABASE FIRST!
"Insanity: doing the same thing over and over again and expecting different results."

Advertisement: