News:

SMF 2.1.2 has been released! Take it for a spin! Read more.

Main Menu

Grado di difficoltà aggiornamento board

Started by webbiko, March 18, 2013, 03:13:45 PM

Previous topic - Next topic

webbiko

Ciao! I veterani ed esperti vari mi potrebbero dire quali difficoltà si vanno ad incontrare quando bisogna aggiornare SMF? E' abbastanza fattibile come nel caso di MyBB o c'è da farsi venire una crisi isterica come nel caso di PHPbb? Insomma con SMF c'est plus facile o bisogna prendere una specializzazione in ingegneria informatica?  ;D

emanuele

Beh, se tutto va bene è abbastanza facile.
Poi dipende da cosa intendi per aggiornare.

Passare ad esempio da 2.0.2 a 2.0.3? In questo caso basta che vai nel pannello di admin e clicchi su "installa".
Passare ad esempio da 1.1.x a 2.0.y? In questo caso è un po' più complicato dato che mod e temi non sono più compatibili e quindi dovrai re-installare tutti gli "accessori" da capo.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

webbiko

Ho installato l'ultima versione, cioé la 2.0.4 quindi da quello che ho capito quando si tratterà di installare la 2.0.5 me la caverò con un click ...  :D
Probabilmente il coefficiente di difficoltà cambierà quando si dovrà passare dalla 2.0.9 alla 2.1.x ...? Dico così a caso perché non so se sia prevista o meno una versione "rivoluzionaria" di SMF.

emanuele

I "large upgrade" sono da usare solo in caso di "major" o "minor" upgrade.
In 2.0.4:
  • 2 => major
  • 0 => minor
  • 4 => micro
    Quindi ogni cambio sulla terza cifra si fa da pannello di admin.
    Ogni cambio di prima o seconda cifra va fatto via ftp.

    Ovviamente versioni "successive" sono in programma (vedi firma), il "quando" è un altro discorso (dato che doveva essere più o meno 8 mesi fa... ::)).


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

webbiko

Nel caso di aggiornamenti che riguardano la prima e seconda cifra oltre ad un adeguato trasferimento di dati via ftp sono previsti anche drammatici interventi sul codice, modello PHPbb?  ::)  :o

emanuele



Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

webbiko

senza voler dire nulla di particolare contro PHPbb, accennavo al fatto che tempo fa ho avuto l'esperienza di aggiornarne una versione ed è stata un'impresa allucinante. Modifiche su modifiche, errori a ripetizione, incompatibilità di varia natura, ecc. ecc. Spero che tutto questo non abbia niente a che vedere con smf.

emanuele

E chi lo sa...
Tutto è possibile.
Come ho detto l'aggiornamenti micro è via package manager ed è l'equivalente di installare un mod, se non ci sono conflitti si installa e via.
Fare un upgrade (quindi 2.0 => 2.1, 2.1 => 3.0, ecc.) richiede una sorta di azzeramento: tutti i mod vengono rimossi, il tema sarà probabilmente non più compatibile e se hai fatto modifiche da qualche parte andranno rifatte. Purtroppo è la natura di questi software, non si scappa (almeno per ora, in futuro dovrebbe essere più facile).


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

Advertisement: