News:

SMF 2.1.1 has been released! Take it for a spin! Read more.

Main Menu

Say Thanks

Started by kelvincool, August 30, 2014, 05:16:29 PM

Previous topic - Next topic

kelvincool

Link to the mod

Say Thanks provides the ability for users to thank posts.

Requirements

This mod requires PHP 7.4.10 or above.

Postgresql users: this mod requires v9+ for the stats page

Additional Notes and known limitations

  • Posts that require users to thank will not show content on reply page or the posts by user page even if the user has thanked the post already
  • Alerts are not enabled by default unless users choose to enable it individually, you can enable it for everyone in Features and Options -> Notifications

Translation Credits
Croatian - ameo
Italian - Ninja ZX-10RR
German - larry007
Russian - Sergey
Persian - roza
Norwegian - Svendsen
Spanish - d3vcho
Turkish - gevv

Thank you icons created by rsetiawan - Flaticon
Icon courtesy of Yusuke Kamiyamane (http://www.iconfinder.com/icondetails/27245/24/fine_good_hand_ok_thumb_thumbs_up_up_icon)
Tick and cross icon courtesy of Pixel Mixer (https://www.iconfinder.com/iconsets/basicset)
Loading icon courtesy of Preloaders.net

Support
Support for this modification can be found in the support topic.



This work is licensed under a Creative Commons Attribution 3.0 Unported License

akbora

This mod is good well how can we get back thanks after give say thanks. This is important
SMF 2.0.13
Default Theme
Utf8 Turkish
---------------

kelvincool

When you say thanks to someone it's not something that you take back so I didn't include such an option, also I wanted to keep the mod simple for maintainability. If there's enough demand for it then I'll add it in.

Gallardo994

Installing the mod has no problems, all tests pass, but when it finishes the installation, there is no effect at all. Trying to uninstall the mod causes a long list of errors for every file. Checking changed files, the mod has changed nothing at all.

Steve

Odd. It works perfectly for me.
Please do not PM me for support.

kelvincool

#5
That's pretty strange. Some questions that will help debug:

Which version of smf are you using?
Are you running with PHP 5.3+?
Are you using the default theme?
Did it create the two tables messages_thanks and messages_thanks_stats?
What errors are you getting?

Ninja ZX-10RR

Doesn't work 100% to me, the icon is missing, it didn't copy it at all in the destination folder and when I tried to put my own image and renaming it to "thank.png" it didn't show anyway :/
Quote from: BeastMode topic=525177.msg3720020#msg3720020
It's so powerful that on this post and even in the two PMs you sent me,you still answered my question very quickly and you're apologizing for the delay. You're the #1 support I've probably ever encountered man, so much respect for that. Thank you, and get better soon.

I'll keep this in my siggy for a while just to remind me that someone appreciated what I did while others didn't.

♥ Jess ♥

STOP EDITING MY PROFILE

kelvincool

OK answer the same questions I posted above and I'll see if I can recreate.

Ninja ZX-10RR

2.0.8
Yes
Yes
Doesn't matter but yes
None

EDIT: P.s. the installation was successful.
Quote from: BeastMode topic=525177.msg3720020#msg3720020
It's so powerful that on this post and even in the two PMs you sent me,you still answered my question very quickly and you're apologizing for the delay. You're the #1 support I've probably ever encountered man, so much respect for that. Thank you, and get better soon.

I'll keep this in my siggy for a while just to remind me that someone appreciated what I did while others didn't.

♥ Jess ♥

STOP EDITING MY PROFILE

kelvincool

I guess those questions didn't really help as much as I thought they would. You're basically running the same set up as me when I develop this.

Follow up questions:

Are your themes folder permissions set correctly? Specifically the folder /Themes/default/images/theme/

That's the only reason I can think of for it not to copy the icon correctly. Have you had any issues with other mods copying icons into the theme folder? The php logs at the time of the installation might give some idea on what the error might be.

Ninja ZX-10RR

No dude you didn't get it and i might have explained myself badly... I tried to put an image manually but it didn't show up either that way! :O logs showed nothing :(
Quote from: BeastMode topic=525177.msg3720020#msg3720020
It's so powerful that on this post and even in the two PMs you sent me,you still answered my question very quickly and you're apologizing for the delay. You're the #1 support I've probably ever encountered man, so much respect for that. Thank you, and get better soon.

I'll keep this in my siggy for a while just to remind me that someone appreciated what I did while others didn't.

♥ Jess ♥

STOP EDITING MY PROFILE

kelvincool

So if you put this into your browser (with your own website domain of course):

http://youwebsite.com/Themes/default/images/theme/thank.png

Do you get anything back? How about:

http://youwebsite.com/Themes/default/images/theme/thank.png.png
or
http://youwebsite.com/Themes/default/images/theme/quote.png

I would say check the permissions on that image you uploaded and check the permissions on the theme folder too. That's of course if you are running with linux and not windows. Would be interested to know if you have any issues with other mods trying to write to that folder.

swaggaderby

@Kelvin please is der a way the mod can be set to set a list of the highest people thanked?

kelvincool

@swaggaderby you mean as part of the forum stats, eg on the same page as Top 10 posters, Top 10 boards, etc...?

If people want that as a feature I can certainly put that into the next version.

swaggaderby

As top10 just like this pic attached

Ninja ZX-10RR

Well I just tried it again and... It didn't work when I tried to install it but when I uploaded an image renamed to "thank.png" it worked... I probably made a mistake with the upload last time, still it doesn't copy the image by default. It says it does but in fact he doesn't do that... Ah the permissions are 775 so way higher than necessary there.
Thanks for the help anyway :) sorry if I haven't been completely accurate the first time.
Quote from: BeastMode topic=525177.msg3720020#msg3720020
It's so powerful that on this post and even in the two PMs you sent me,you still answered my question very quickly and you're apologizing for the delay. You're the #1 support I've probably ever encountered man, so much respect for that. Thank you, and get better soon.

I'll keep this in my siggy for a while just to remind me that someone appreciated what I did while others didn't.

♥ Jess ♥

STOP EDITING MY PROFILE

ameo

As a good boy I am, I've translated this lil script from English to Croatian.


So you can include it if you like, or whoever likes it on my language, can use it.
It's attached. Also you can find it on pastie: say thanks -   Cheers!  :)
antechinus:
QuoteIf you are dying for a solution it may be wise to seek medical attention.
Get some Awesome Smileys for your forum

|±(ಠ_ಠ
)±|

Apllicmz

iam done portugues files any news send MP
Thank you



Steve

Why not just attach it so anyone who wants it can grab it right away without having to wait? :)
Please do not PM me for support.

Ninja ZX-10RR

Quote from: Steve on October 07, 2014, 04:29:32 PM
Why not just attach it so anyone who wants it can grab it right away without having to wait? :)
+1
Quote from: BeastMode topic=525177.msg3720020#msg3720020
It's so powerful that on this post and even in the two PMs you sent me,you still answered my question very quickly and you're apologizing for the delay. You're the #1 support I've probably ever encountered man, so much respect for that. Thank you, and get better soon.

I'll keep this in my siggy for a while just to remind me that someone appreciated what I did while others didn't.

♥ Jess ♥

STOP EDITING MY PROFILE

Advertisement: