• Welcome to Simple Machines Community Forum. Please login or sign up.
October 16, 2021, 09:18:30 AM

News:

Join the Facebook Fan Page.


Custom Top Menu

Started by smp420, May 15, 2010, 12:57:45 PM

Previous topic - Next topic

tfs

Quote from: smp420 on December 25, 2010, 11:39:58 AM
Updated for RC4 thanks to Yoshi2889 for letting me use his site! And Merry Christmas to everyone!!

Seems to have installed just fine on my RC4 site, and it properly remembered the settings from the RC3 install.  Thanks!

And Merry Christmas to you!
A good tree cannot bring forth evil fruit, neither can an evil tree bring forth good fruit.

chinaren

The Opus Path - The Next Generation of the Written Word

tennis4you

This is an awesome mod!  I am having issues installing though due to index.template.php

1.    Execute Modification    ./Sources/ManageSettings.php    Test successful
      1.    Add After    ./Sources/ManageSettings.php    Test successful
      2.    Add Before    ./Sources/ManageSettings.php    Test successful
2.    Execute Modification    ./Sources/Admin.php    Test successful
      1.    Add Before    ./Sources/Admin.php    Test successful
3.    Execute Modification    ./Themes/default/languages/Modifications.english.php    Test successful
      1.    Add Before    ./Themes/default/languages/Modifications.english.php    Test successful
4.    Execute Modification    ./Themes/default/languages/Modifications.english-utf8.php    Test failed
      1.    Add Before    ./Themes/default/languages/Modifications.english-utf8.php    Test failed
5.    Execute Modification    ./Themes/default/index.template.php    Test failed
      1.    Replace    ./Themes/default/index.template.php    Test failed
6.    Execute Modification    ./Themes/default/languages/Modifications.russian.php    Skipping file
7.    Execute Modification    ./Themes/default/languages/Modifications.russian-utf8.php    Skipping file

Can anyone help?

Thanks!

NanoSector

Quote from: tennis4you on January 08, 2011, 07:22:41 PM
This is an awesome mod!  I am having issues installing though due to index.template.php

1.    Execute Modification    ./Sources/ManageSettings.php    Test successful
      1.    Add After    ./Sources/ManageSettings.php    Test successful
      2.    Add Before    ./Sources/ManageSettings.php    Test successful
2.    Execute Modification    ./Sources/Admin.php    Test successful
      1.    Add Before    ./Sources/Admin.php    Test successful
3.    Execute Modification    ./Themes/default/languages/Modifications.english.php    Test successful
      1.    Add Before    ./Themes/default/languages/Modifications.english.php    Test successful
4.    Execute Modification    ./Themes/default/languages/Modifications.english-utf8.php    Test failed
      1.    Add Before    ./Themes/default/languages/Modifications.english-utf8.php    Test failed
5.    Execute Modification    ./Themes/default/index.template.php    Test failed
      1.    Replace    ./Themes/default/index.template.php    Test failed
6.    Execute Modification    ./Themes/default/languages/Modifications.russian.php    Skipping file
7.    Execute Modification    ./Themes/default/languages/Modifications.russian-utf8.php    Skipping file

Can anyone help?

Thanks!
Not only index.template.php is erroring: modifications.english-utf8.php is also erroring.
My Mods / Mod Builder - A tool to easily create mods / Blog
"I've heard from a reliable source that the Answer is 42. But, still no word on what the question is."

Spoogs

Quote from: Simple Series team on January 09, 2011, 12:16:50 PM
Not only index.template.php is erroring: modifications.english-utf8.php is also erroring.
Because they are using english as the default language and not english-utf8 so that error can be ignored.


Quote from: tennis4you on January 08, 2011, 07:22:41 PM
This is an awesome mod!  I am having issues installing though due to index.template.php

1.    Execute Modification    ./Sources/ManageSettings.php    Test successful
      1.    Add After    ./Sources/ManageSettings.php    Test successful
      2.    Add Before    ./Sources/ManageSettings.php    Test successful
2.    Execute Modification    ./Sources/Admin.php    Test successful
      1.    Add Before    ./Sources/Admin.php    Test successful
3.    Execute Modification    ./Themes/default/languages/Modifications.english.php    Test successful
      1.    Add Before    ./Themes/default/languages/Modifications.english.php    Test successful
4.    Execute Modification    ./Themes/default/languages/Modifications.english-utf8.php    Test failed
      1.    Add Before    ./Themes/default/languages/Modifications.english-utf8.php    Test failed
5.    Execute Modification    ./Themes/default/index.template.php    Test failed
      1.    Replace    ./Themes/default/index.template.php    Test failed
6.    Execute Modification    ./Themes/default/languages/Modifications.russian.php    Skipping file
7.    Execute Modification    ./Themes/default/languages/Modifications.russian-utf8.php    Skipping file

Can anyone help?

Thanks!
What mods do you have installed and attach your index.template.php

tennis4you

Thanks for the quick reply.  Here are the mods I have installed:

Add Favicon.ico Support    1.101    [ Uninstall ] [ List Files ] [ Delete ]
Effectively Remove SMF Logo    1.2    [ Uninstall ] [ List Files ] [ Delete ]
Stop Forum Spam    0.6    [ Uninstall ] [ List Files ] [ Delete ]
Last Users In 24 Hours    1.0    [ Uninstall ] [ List Files ] [ Delete ]
Stop Spammer    2.3.8    [ Uninstall ] [ List Files ] [ Delete ]
WYSIWYG Quick Reply    2.1    [ Uninstall ] [ List Files ] [ Delete ]
httpBL    2.5.1    [ Uninstall ] [ List Files ] [ Delete ]
Curve_centered_menu    1.2    [ Uninstall ] [ List Files ] [ Delete ]
YouTube BBCode    2.6    [ Uninstall ] [ List Files ] [ Delete ]
Remove Index From Title    1.0    [ Uninstall ] [ List Files ] [ Delete ]


Spoogs

Effectively Remove SMF Logo <--- thats the issue, remove this mod and you should install fine. This mod removes the chunk of code this mod is also looking to replace

tennis4you


tennis4you

Whoa, maybe not...  I tried uninstalling that mod and this is what I got:

   1.    Execute Modification    ./Themes/default/index.template.php    Test failed
      1.    Replace    ./Themes/default/index.template.php    Test failed
*    2.    Execute Modification    ./Themes/default/css/index.css    Test failed
      1.    Replace    ./Themes/default/css/index.css    Test failed
   3.    Extract File    ./Themes/default/images/smflogo.png

Spoogs

here ya go... as always make sure you backup first

tennis4you

Awesome, thank you!  Before I do anything, I better ask so I understand.

Can I just overwrite my copy of index.template.php with the file you attached and then run the mod normally?

Thanks!

Spoogs

yes... if anything goes wrong you already have a copy attached to this thread if you havent saved a copy to your pc ;)

tennis4you

I uploaded your version of the index.template.php, opened the forum and tried to run the mod again.  Here is my error report:

1.    Execute Modification    ./Sources/ManageSettings.php    Test successful
      1.    Add After    ./Sources/ManageSettings.php    Test successful
      2.    Add Before    ./Sources/ManageSettings.php    Test successful
2.    Execute Modification    ./Sources/Admin.php    Test successful
      1.    Add Before    ./Sources/Admin.php    Test successful
3.    Execute Modification    ./Themes/default/languages/Modifications.english.php    Test successful
      1.    Add Before    ./Themes/default/languages/Modifications.english.php    Test successful
4.    Execute Modification    ./Themes/default/languages/Modifications.english-utf8.php    Test failed
      1.    Add Before    ./Themes/default/languages/Modifications.english-utf8.php    Test failed
5.    Execute Modification    ./Themes/default/index.template.php    Test failed
      1.    Replace    ./Themes/default/index.template.php    Test failed
6.    Execute Modification    ./Themes/default/languages/Modifications.russian.php    Skipping file
7.    Execute Modification    ./Themes/default/languages/Modifications.russian-utf8.php    Skipping file

I am not sure if the SMF logo was suppose to re-appear when I uploaded your revised file or not, the logo did not re-appear for me.  Not sure if that matters or not.  Everything looks the same when I uploaded your revised file, as a matter of fact, I have not bothered to upload my previous one yet.  :)

Any thoughts?

Thanks!

impreza

Portal Totemat - artykuły i filmy - treści w postaci artykułów i filmów.

Spoogs

Quote from: tennis4you on January 09, 2011, 02:51:38 PM
I uploaded your version of the index.template.php, opened the forum and tried to run the mod again.  Here is my error report:

1.    Execute Modification    ./Sources/ManageSettings.php    Test successful
      1.    Add After    ./Sources/ManageSettings.php    Test successful
      2.    Add Before    ./Sources/ManageSettings.php    Test successful
2.    Execute Modification    ./Sources/Admin.php    Test successful
      1.    Add Before    ./Sources/Admin.php    Test successful
3.    Execute Modification    ./Themes/default/languages/Modifications.english.php    Test successful
      1.    Add Before    ./Themes/default/languages/Modifications.english.php    Test successful
4.    Execute Modification    ./Themes/default/languages/Modifications.english-utf8.php    Test failed
      1.    Add Before    ./Themes/default/languages/Modifications.english-utf8.php    Test failed
5.    Execute Modification    ./Themes/default/index.template.php    Test failed
      1.    Replace    ./Themes/default/index.template.php    Test failed
6.    Execute Modification    ./Themes/default/languages/Modifications.russian.php    Skipping file
7.    Execute Modification    ./Themes/default/languages/Modifications.russian-utf8.php    Skipping file

I am not sure if the SMF logo was suppose to re-appear when I uploaded your revised file or not, the logo did not re-appear for me.  Not sure if that matters or not.  Everything looks the same when I uploaded your revised file, as a matter of fact, I have not bothered to upload my previous one yet.  :)

Any thoughts?

Thanks!
Ignore the error and complete the installation.... I already added the code needed for the mod to work.
The logo wont reappear, i didnt do anything with regard to the other mod

tennis4you

Yup, that worked perfect, thanks!

Is there a way to center the menu?

Thank you!!!

NanoSector

Center the custom top menu? Not yet.

Of course there IS a way, but not a way that we have tested...
My Mods / Mod Builder - A tool to easily create mods / Blog
"I've heard from a reliable source that the Answer is 42. But, still no word on what the question is."

Faustus

Fresh install of 2.0 RC4.

reports an error with the theme file when I try to install.

Only mods I have installed so far are.

SimplePortal
Facebook Sharer Mod 1.0
InLine Attachments
Custom_Top_menu

PfalzNacht

What have i to do that the menu buttons are"active"?


Now they look like normal links, but i want it with the blue background.

PfalzNacht

Can anyone please help me?


What have i to change to hover all Links/Buttons?

Advertisement: