• Welcome to Simple Machines Community Forum. Please login or sign up.
October 21, 2021, 04:43:18 PM

News:

SMF 2.1 RC4 has been released! Try it out and help us test! :) Read more.


My host or I can't tell what's going on with my site ;'(

Started by agent47, February 24, 2011, 01:54:10 PM

Previous topic - Next topic

agent47

My site has been down for over 3 hours now and I can't tell what's wrong and so can't the host. Apparently there servers are working fine infact the site is working under the sub-domain which is http://movie.superheroalliance.net is working perfectly fine. According to them, they're saying it's an issue with the index.php but I don't think so coz the site code files were totally untouched today and the site worked perfectly before 3 hours. Can someone please be kind enough to help me out here. I feel so lost. I could really use some help.

Here's my site: http://www.superheroalliance.net/

I've attached my index.php so that you'll can see what may be wrong.
Please, I'm literally dying for some help here.

PortaMx is probably the best SMF portal!

Arantor

index.php looks fine, so it's probably another file that's broken in some way. Check that all the files in Sources/ haven't been touched.

In all honesty though, the error being reported looks like a server configuration error, not an index.php one...
No good deed goes unpunished
All helpful urges should be circumvented

agent47

Could it be a server configuration error even while wordpress site running in it's is sub domain seems to be working allright? Do you think I should re-download SMF RC3 and overwrite all files contained in the sources dir? Would that mess up any of the installed mods?

PortaMx is probably the best SMF portal!

Arantor

Subdomains are configured separately...

If you redownload RC3 and upload the files, it will remove all mods.

Let me put it this way: if you didn't touch it in the last 3 hours, and none of the files have been modified, the only other factor is the host configuration...
No good deed goes unpunished
All helpful urges should be circumvented

agent47

Could you state what the possible server configuration issues might be so that I could tell the stinking guys at my hosting so that they can look into. Honestly these guys aren't doing ****** but just keep dragging the support ticket with rubbish. If I could tell them what's wrong, maybe they could look into it.

PortaMx is probably the best SMF portal!

Arantor

I have no idea what's wrong, I just get 'unknown error' come back, which is different to the usual error in the event of bad code or similar.
No good deed goes unpunished
All helpful urges should be circumvented

busterone

I cannot even see the subdomain site- http://movie.superheroalliance.net/  I get a server not found error using FF.

When I click you site in question - http://www.superheroalliance.net/ , I get a loaded blank white page. 

I realize this may not help much, but it looks like server error to me as well.

agent47

Mybad!
Sub-domain: http://moviedb.superheroalliance.net

Well I told they guys at my hosting that and this is what they said:
"We have not changed any server configuration in the last few hours or in few weeks.

Please contact us with any additional questions.

Regards,
Eric K.
Help Desk Staff

Business Enterprise Hosting Media
www.hosting24.com"

These are really unhelpful. Now it has come to a stage where they've refused to help me and it all depends on the SMF support forums now :'(
I would have let it go if I wasn't serious about the site but with this one, I'm very dedicated to it. Spend almost two months just designing it. Would be a shame to just let it sink.

PortaMx is probably the best SMF portal!

busterone

Either log in to your webspace via ftp, or use your host's control panel file manager and search every directory and file for any file that shows a last modified date within the last day or so. If so, the issue could be from there. If you have not modified anything yourself, and the host hasn't, it is a possibility of a hack.  Look in your settings.php file for any code that should not be there, especially any base64 encoded stuff.

agent47

So I checked and it seems none of the important files have been modified ever since. Could one of you guys please personally assist me. I could give you any of you guys access to FTP to check out. I could really use a hand guys. I don't want to lose all my members :'(

PortaMx is probably the best SMF portal!

Illori


busterone

I am not on the team here myself. I help where I can, but Arantor is way more qualified than I am, if he has the time. If not, another support team member may be able to log in and look around.  :)

agent47

The last error on the error log is on the 22nd of Feb. So we got nothing there.
I really hope someone steps forward to assist me with this issue. Man! I'm so desperate right about now.

PortaMx is probably the best SMF portal!

Adish - (F.L.A.M.E.R)

Have a look for .htaccess in your root directory. Paste the content within it.

I see you have mentioned that you haven't touched the files in the past 3 hours, but have you installed any modifications recently? Like via the package manager?

agent47

htcaccess file seems to be empty.
And yes, recently I did install a few mods such as E-Arcade.

PortaMx is probably the best SMF portal!

Adish - (F.L.A.M.E.R)

Have a try doing this: http://www.simplemachines.org/community/index.php?topic=400356.0

(Make a full backup of your website before you try it though. It will bring you back to this stage if you mess up anything further.)

agent47

OH MY GOD. You know what's so weird about that thread. The example mod used in that thread is "PM to new members" and that's exactly my last installed mod. :O I wonder if it's that mod that caused. Anyway trying it out now.....

PortaMx is probably the best SMF portal!

agent47

Unfortunately that didn't work either. :'( So I guess it wasn't the mod.

Also I kept repeatedly pressing the enter key to refresh the site and it brought up this error: "Sorry, SMF was unable to connect to the database. This may be caused by the server being busy. Please try again later."

PortaMx is probably the best SMF portal!

agent47

Just wanted to let this awesome team know that my site happened to start working again. And I think I just figured what was wrong. Just before the site went down I asked Cpanel to take a FULL backup of my site and apparently that backup wasn't successful and it was what was jamming the site.... So I just went into the backup section of CPanel and found out only now that the morning's backup wasn't successful so I asked CPanel to do a re-backup and as soon as I received the notification email that the 2nd backup was complete, my site immediately began to be accessible. A very very weird issue and who would have known what was causing it. I was on the brink of removing SMF and re-installing the entire site from scratch. Man! god is so powerful. I just want to thank the SMF team for being so responsive. Amazing team. Just explains why SMF is such a successful forum CMS. Hats off to the awesome. May god bless you Arantor, F.L.A.M.E.R & busterone. You guys are pretty awesome!!!!

PortaMx is probably the best SMF portal!

busterone


Advertisement: