• Welcome to Simple Machines Community Forum. Please login or sign up.

[SOLVED] Modifying topic title creates 404 error for Admin user

Started by prince_bear, January 08, 2013, 10:38:02 PM

Previous topic - Next topic

prince_bear

SMF Version 2.0.3

Today, an admin on my board went to modify a topic title, and got a 404 error after pressing submit. The interesting thing is that no errors were logged in the SMF error log. We have discovered this on a couple more threads as well but its by no means obviously consistent. Titles for new topics created on the same board(s) can be modified without issue.

Here is an example thread, http://www.christianfamilyplanning.net/index.php?topic=9331.0

Please PM me for a Username and Password if you want to see firsthand.

mashby

Always be a little kinder than necessary.
- James M. Barrie

mashby

I made a topic under Men and was able to edit the Subject without issue. I cannot edit the other topics (nor do I feel the need to) as I think I'd be doing more harm than good. I'll make a new topic (that should be deleted later) and see if I can replicate a 404.
Always be a little kinder than necessary.
- James M. Barrie

mashby

Made a new topic in the same category as the link you provided. Edited it (and the title) a couple of times. No 404s yet. Wondering if this is just an isolated issue.
Always be a little kinder than necessary.
- James M. Barrie

prince_bear

I am certainly hoping its isolated, but that's also what makes it frustrating. Is there any reason that topics before a certain creation date would have issues but more recent ones wouldn't?

mashby

One wouldn't think so, no. Admins can edit anything at any time (unless I'm missing something in settings). I know there's this option in Post Settings:
Maximum time after posting to allow edit
Your site is set to 0 which means it can be edited at any time by those allowed to. Can you try to edit the same topic which was generating a 404? I don't really want to edit real content on your site, only stuff I've made. :)
Always be a little kinder than necessary.
- James M. Barrie

Arantor

Is it possible that the error was really some other kind of error but just saying it was generating a 404 where it couldn't find the error page?

I'm thinking primarily of tripping mod_security, getting a 406 and not having a handler for it, so generating what seems like a 404.
No good deed goes unpunished
All helpful urges should be circumvented

prince_bear

Arantor you might be right about Mod_Security, we just discovered that posts with more with 4 BBCode links even with text in between them seem to trip the error. The posts that the admin was previously trying to edit all had tickers in them which all have embedded links in them.

This is going to be fun one to try and explain to the host.  :o

Arantor

It's really quite simple, ask them about disabling mod_security ;)
No good deed goes unpunished
All helpful urges should be circumvented

Advertisement: