• Welcome to Simple Machines Community Forum. Please login or sign up.
October 24, 2021, 01:01:08 PM

News:

Want to get involved in developing SMF, then why not lend a hand on our github!


SSI Topic and Replies

Started by tyty1234, April 06, 2007, 07:35:13 AM

Previous topic - Next topic

zaum

Hello, this mod works great on my site.  Thanks very much for it.

I just have one feature request:
Can you add support for negative start offset?  I would like an easy way to grab the LAST reply in a topic.

For example:
ssi_topic($topic, 1, -1) - grab the last reply
ssi_topic($topic, 2, -2) - grab the last 2 replies
etc...

Thanks!

Darkness_

is it possible to only get the first post without the replies?
and is it possible to get a limited amount of characters for that post

Neverhurry

Please, can somebody help to improve this mod by adding the posiblity to show the first attachment picture of the first post? that will be more useful, because the one glance of picture worth thousand words. I tried all night but I failed. I tried to use codes (attachment function) form the SSI.php file, but somehow I made mistake and it shows error. Any help will be highly appreciated!
I am using SMF 2.0.1, curve themes.

tyty1234

Hey guys,

I want to apologize for not updating the mod periodically and addressing your errors. I've been real busy and it's been so long since I coded for SMF, but with the release of SMF 2.0, the mod will need to be updated. Before I do that however, if you guys would go here to report some bugs or errors that you found in the mod so that I can fix those bugs and errors and the next version of this mod can be bug-free and is working smoothly. I promise that I will do my best to update and fix the mod in a timely manner as I have a little free time on my hands.

Thanks,
tyty1234
My Activity: Inactive
My Links: tyty1234's SMF Site | SMF Package Parser | SMF Helper | My Mods [5]
Subscribe to my SMF blog for updates
PMs for support will not be accepted, unless requested otherwise.

tyty1234

Version 2.0 has been released! It supports SMF 2.0, but no longer supports SMF 1.1.x forums. Please refer to the OP for what's new in this version. This mod, along with the other mods that I wrote are also available on my site.
My Activity: Inactive
My Links: tyty1234's SMF Site | SMF Package Parser | SMF Helper | My Mods [5]
Subscribe to my SMF blog for updates
PMs for support will not be accepted, unless requested otherwise.

katsbits

September 23, 2011, 02:29:04 AM #105 Last Edit: September 24, 2011, 01:32:23 PM by katsbits
If you have this installed on 2.0, it might break when installing the recent 2.0.1 fix/update. Tried using this today and got an 'incompatible files' error message so it looks like some nuts and bolts stuff has changed behind the scenes.

tyty1234

September 23, 2011, 03:03:21 AM #106 Last Edit: September 23, 2011, 03:19:50 AM by tyty1234
I was reading some of the blog posts and announcements saying that it's now feature locked....however I'm not sure what that means, which means I have to find out. Either that or the way that mods are installed have changed...not sure.

EDIT: Nope, it's just that it's not compatible with SMF 2.0.1 according to the instructions I put in the package_info.xml file. I'll have to go in and adjust this. It should work though. for now, you should be able to use the emulate feature.
My Activity: Inactive
My Links: tyty1234's SMF Site | SMF Package Parser | SMF Helper | My Mods [5]
Subscribe to my SMF blog for updates
PMs for support will not be accepted, unless requested otherwise.

katsbits

September 25, 2011, 04:03:12 PM #107 Last Edit: September 25, 2011, 04:12:42 PM by katsbits
Just confirming that 'emulation' works ok and I've managed to get this sorted out. Thanks for the mod.

[EDIT] is there a way to add a "Post Reply/Write Comment" link (top or bottom of the inclusion) or the "quick reply" box to this mod or is that out of the general scope/purpose?

tyty1234

It's possible, but one of the queries would have to be altered within the function.
My Activity: Inactive
My Links: tyty1234's SMF Site | SMF Package Parser | SMF Helper | My Mods [5]
Subscribe to my SMF blog for updates
PMs for support will not be accepted, unless requested otherwise.

diontoradan

yes i think the quick reply form is a good idea...

Looking forward for the updates...

i777Ares

need ome help with this. I am trying to get this code to work in a simple portal php block
echo '<div id="content-explorer">

<ul class="yui-nav">
<li class="selected"><a href="#">News</a></li>
<li><a href="#">Video's</a></li>
<li><a href="#">Events</a></li>
<li><a href="#">Other</a></li>
</ul>

<div class="yui-content">
<div> ;
<?php ssi_boardNews(8);?>

echo '</div>
<div>;
<?php ssi_boardNews(4);?>
echo '</div>
<div>;
<?php ssi_boardNews(3);?>
echo '</div>
<div>;
<?php ssi_boardNews(10);?>
echo '</div>
<div>
</div>;

ty for ur help
Want some images made for your smf site?
paid help or free see here http://x-tremedesigns.net

Alpay

Quote from: Özgür on April 13, 2010, 03:26:22 PM
I need to calling avatars on topic replys. I try add this in final while.
loadMemberContext($row['id_member']);
  $avatarx =  $memberContext[$row['id_member']]['avatar']['image'];

And call this in foreach
',$avatarx,'
But avatars not showing up. I really need help on this. Seems not impossible to me. But i guess, i would be skip something.
Can you help me?

Yep.. Help us ?

mark7144

Please can someone explain where the value for 'preview' is set? This code is just showing me the first character of the topic.

$topic_data['first_post']['preview']

chinmay235

Hi Anyone help me i have successfully installed ssi_topic();

It is showing good.

It is showing ASC order but i want to show it reverse order(DESC).

More details -

http://www.simplemachines.org/community/index.php?topic=512121.msg3618295#msg3618295

dakey

Sorry for bumping this topic, but this mod still works great with the latest version of SMF (2.0.10)

I'm able to display a certain topic with replies. The documentation of this mod describes that attachments can be displayed in the first post (which is working), but I can't find a solution to display also the attachments in the replies?

Can someone help me with this?

Biology Forums

Thank you for offering this excellent code, been using it with AJAX calls everywhere

Advertisement: