News:

SMF 2.1.2 has been released! Take it for a spin! Read more.

Main Menu

Site Integration Mod

Started by live627, April 29, 2008, 07:45:20 PM

Previous topic - Next topic

Chit-Chat ChatterBox Boss

Someone gave me a solution to this problem on SMF Helper.

Find:
   //   Add the included actions/files for the Site Integration Mod.
   foreach($context['siteintegration_actions'] as $action => $data)

Replace with:
   if (!empty($context['siteintegration_actions']))
   {

   //   Add the included actions/files for the Site Integration Mod.
   foreach($context['siteintegration_actions'] as $action => $data)


Find:
         //   Add the permisions for this action.
         $allowedActions[$action] = array('SiteIntegration:'.$action);
      }
   }

Replace with:
         //   Add the permisions for this action.
         $allowedActions[$action] = array('SiteIntegration:'.$action);
      }
   }
   }
Chit-Chat ChatterBox

Our site is open to everyone. It is a resource for anyone and everyone to talk about anything and everything you could possibly think of. It's a great place to come and talk, ask questions, or just simply hang out. We offer many great features. All we ask is that you follow by the site rules. Hope to see you around!
www.chitchatchatterbox.com
Remember in the "Referral" box to put "Caleb" while registering.

Sordell Media

Does anyone know if this works under 2.0 RC1.2? I'm looking to start work on a new project shortly that will require a fair amount of integration with SMF, and think this mod would be an excellent aide in getting setup, but the mods site still lists it as only supporting beta 4.

ScottDB

Hi all, This sounds like a great mod. What I would like to know is if this can be used or modified so that I can have my SMF login and signup integrated into my LFM login and signup. Would have to keep the LFM signup and Login in tact since it is a php based affiliate software that I have in the subfolders of my forum.
Thank you,
Scott

If at first you don't succeed. post and post again.

espressoguy

After installing this mod (over 1.1.6) I don't have a  "Features and Options" section-> "Site Integration" tab

    ...I just have "Basic Features", "Layout and Options", and "Karma" tabs.

    So how do I use this mod?

onlybrian

This is a very helpful mod, would appreciate latest update. Thanks

ChaosEnergy

will there be an 2. rc2 compatible version
Chaos Empire ®

[unplugged]

#286
I have installed this on a site running RC2 using the parser and everything works fine. Just followed the steps one by one just as they are listed. The only one that I had to change slightly was adding the help $txt strings. The line that the parser was searching for wasn't there, so I added the block to the end of the file (just before the ?>). There are one or two other very minor theme issues such as spacing, but nothing that broke the forum. Works like a charm.

EDIT: Make that two sites running RC2, the latter having several other mods and a custom theme. It's really an easy manual edit. Also, make sure to clear your site's cache so that the language strings show properly.
« Next Edit: Tomorrow at 08:34:45 PM by SunKing »   <---- « someone stole my sig... :o »



Siirist

Quote from: SunKing on February 01, 2010, 02:11:21 AM
I have installed this on a site running RC2 using the parser and everything works fine. Just followed the steps one by one just as they are listed. The only one that I had to change slightly was adding the help $txt strings. The line that the parser was searching for wasn't there, so I added the block to the end of the file (just before the ?>). There are one or two other very minor theme issues such as spacing, but nothing that broke the forum. Works like a charm.

EDIT: Make that two sites running RC2, the latter having several other mods and a custom theme. It's really an easy manual edit. Also, make sure to clear your site's cache so that the language strings show properly.

Hi,

We have the thought of (liking the theme we are using on SMF ver 2.0 RC3)
as a possible background on our website
(sounds like that is what this mod is going to do).  ;D



These don't work  :(

Demo Sites:
SMF 1.1.5: http://www.verbtest.com/smfdemo/index.php
SMF 2 Beta: http://www.verbtest.com/smf2demo/index.php



So, SunKing, could we see yours? or is there another example somewhere that is live?  ???



As we said above, we are running SMF ver 2.0 RC3, but we saw that the parser will give the codes to do the whole thing "by hand", or do you think that we can just use the package manager?  ::)



Thanks in advance.  O:)

Be Well,
Cloud  8)
Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

[unplugged]

http://www.empireofthesun.net/forum/index.php?action=demo


I have a file called demo.php with the code in it that you see shown when going to ?action=demo in the link above.
« Next Edit: Tomorrow at 08:34:45 PM by SunKing »   <---- « someone stole my sig... :o »



Siirist

SunKing,

All I can say about this is


WOW!!!!


It seems like an entire program!!  :o
Is it written in Java Script? Because I know quite a bit of html (ok, that is old), am learning xhtml (I think), and trying CSS (which is nice when there is a single change to many pages).   ::)

That said, and seeing all there is, I wonder if the mod is "above me".  Can't even begin to imagine how to "work" it.  :-\


It seems that it goes FAR BEYOND a portal I've seen.
Again, WOW!!!  ;D


So, is it that the "top" of the page is unchanging but when going to another page the bottom changes?  ???

Should I fake it till I make it?  ???

Awaiting you words of wisdom.  ;)

Be Well,
Cloud 8)
Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

[unplugged]

Basically, this mod is what puts everything between the Forum >> Some page >> Another page navigation and the copyright in the footer. It can handle many file types and essentially just executes whatever scripts may be inside those files.

A quick example:

I create a file named cloud.html. In that file I have <span style="color:red;">WOW!!!!</span>. I add cloud.html to a folder that I have listed in the admin for this mod. I set the permissions for the membergroups I want to be able to use it. Now, when one of those groups navigates to ?action=cloud (through a link, menu button, or whatever), it will display    WOW!!!!   in the forum for them. Now, the possibilities are endless. You could set up any type of script in many programming languages. html, xhtml, php, even txt. You simply drop the file into the assigned folder and set the permissions. Instant ?action=filename.
« Next Edit: Tomorrow at 08:34:45 PM by SunKing »   <---- « someone stole my sig... :o »



Siirist

SunKing,

Thank you for your quick reply.  ;D

So, here's what I / we are wanting.

There is a theme titled Bright Forest that was created by Aäron.

We are still working on what we want as a "logo" or "look" at A Sanctuary / Your Sanctuary.

We are considering using Bright Forest as a background for our "home page" at our "website" A Sanctuary.
This will be with permission from and credit to Aäron.  O:)

We have already posted a request in the support topic of Bright Forest that we want to change the "title" words of Bright Forest.

We would like to add to the background
Your Sanctuary for the forum
and
A Sanctuary for the "website"  ::)

Can this mod do that?  ???

Cloud 8)
Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

coaster3000

This one edit / file edit thing cant be performed on smf V 2.0 RC3


Execute Modification  ./Themes/default/languages/Help.english.php  Test failed
1. Add After ./Themes/default/languages/Help.english.php Test failed


I believe it cant find the text its adding it after. Basically RC3 must have something different then search code for install. Can you update this mod to have this fixed thanks  ;D

Siirist

Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

Siirist

Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

Siirist

Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

Siirist

Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

Siirist

Needed information:
- What's your SMF version?, What MODs are installed? What Theme(s) are you using? Have you backed up your database?

--> At least 50% of the questions asked are answered in the Online Manual <--
Mods for ver 1.x will NOT run on ver 2.x

RCC_SaMiaM

This topic seems to be dead but I am hoping someone knows why this is happening - I installed it on 2.0 and it works fine except for one thing.  When you access the root of the domain, www.whatever.com or www.whatever.com/index.php it gets stuck in a redirection loop.  So this must be something to do with the part of the mod where you can change your home.

RCC_SaMiaM

I know this isn't fixing the issue, but this fixes the problem if you aren't trying to make a different page your home page for the forum. 

Find in index.php (main index page in root)
$load_home = true;

and replace it with
require_once($sourcedir . '/BoardIndex.php');
return 'BoardIndex';


I suspect it has something to do where it is checking if $load_home is false, there must be something incorrect about the conditions.  I might look into this later, but this is a quick fix.

Advertisement: