News:

SMF 2.0.19 has been released! Please update. Read more.

Main Menu

Bookmarks

Started by Matthew K., July 16, 2007, 01:07:24 PM

Previous topic - Next topic

Illori

Quote from: Illori on February 25, 2011, 08:42:41 AM
please read this:

Quote from: Illori on December 23, 2010, 05:55:17 AM
Quote from: DarioBros on October 12, 2010, 06:31:49 AM
Quote from: marcberm on July 25, 2010, 10:03:07 PM
So for some reason, when I attempt to install this package automatically through the SMF interface, instead of proceeding to the screen where the file tests are displayed, I get just a blank white screen (refresh doesn't do anything). 

The same thing happens to me.

I resolved this issue modifying the file "package-info.xml" contained in the archive.

In this file, I replaced every istance of
<database type="file">
with
<code>

and
</database>
was replaced by
</code>

wwwserfer

Quote from: Illori on June 24, 2011, 10:35:34 AM
Quote from: Illori on February 25, 2011, 08:42:41 AM
please read this:

Quote from: Illori on December 23, 2010, 05:55:17 AM
Quote from: DarioBros on October 12, 2010, 06:31:49 AM
Quote from: marcberm on July 25, 2010, 10:03:07 PM
So for some reason, when I attempt to install this package automatically through the SMF interface, instead of proceeding to the screen where the file tests are displayed, I get just a blank white screen (refresh doesn't do anything). 

The same thing happens to me.

I resolved this issue modifying the file "package-info.xml" contained in the archive.

In this file, I replaced every istance of
<database type="file">
with
<code>

and
</database>
was replaced by
</code>

Thanks!!

frx

Quote from: Inti31 on June 22, 2011, 01:00:37 AM
@lazylivin
it still runs fine on 2.0 Gold...
I've implemented that mod in my testforum, everything okay...

How did you do it ?
Whe i do a package parse for 2.0 it says it isn't compatible with my version (2.0 Gold)...

Thanks

Jessica.

emulate it to the version(s) it's compatible with, that is what I did

bottom of Browse Packages (Advanced)
Testing Zone - SMF 2.0.7, default Curve
School & Chat - phpBB3, over 170 mods installed, official live forum

I use the latest version of Chrome

phpBB: Forum = a section; Board = whole site
SMF: Forum = whole site; Board = a section

Inti31

#644
Quote from: frx on June 24, 2011, 11:12:50 AM
Quote from: Inti31 on June 22, 2011, 01:00:37 AM
it still runs fine on 2.0 Gold...
I've implemented that mod in my testforum, everything okay...

How did you do it ?
Where I do a package parse for 2.0 it says it isn't compatible with my version (2.0 Gold)...

Thanks

it's simple...
I just did that for nearly each mod I installed (50 mods now in 2.0 Gold)... - I upgraded also now my main board (epica-forum.de) with all mods - took only minutes to get everything working...



1: download the modification
2: open it with 7Zip (I use a portable version) - this works with every zip file or also tar.gz or gz - don't close 7Zip...
3: extract package-info.xml and translation.xml - use to open the files this app: notepad++ (my recommendation, I also have a portable version of that)
4: modify the install header in file package-info.xml and add , 2.0 at the end of that line
ex: <install for="2.0 Beta 3, 2.0 Beta 3 Public, 2.0 Beta 3.1, 2.0 Beta 3.1 Public, 2.0 Beta 4, 2.0 Beta 4 Public, 2.0 RC1, 2.0 RC2, 2.0 RC3, 2.0">
5 close and save it - then open translation.xml file - if you use another language than English:
6: find a language string or maybe rename an exisiting one like I did:
e.g: <file name="$languagedir/Modifications.german-utf8.php">
do your translation

save that file also - now drag both files back to the open 7zip file - save it - done
Now upload the modified 7zip file and start the installation without using the compatible mode

The file package-info.xml is the "setup" file - standard in smf for every mod...
see which steps and files are included  - mybe delete language-files you don't need.

Greets inti31
my forum
my testforum


my mods - which I only made them work for 2.0 Gold:
Topics Filter v3.2 SMF 2.0 Gold
MemberNumber

Kindred

in 2.0, there is no need to do that.

Click the "advanced" link at the bottom of the package list screen and change the "version" listing there to something that matches the mod's predefined versions.
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Inti31

#646
Quote from: Kindred on June 28, 2011, 11:07:19 AM
in 2.0, there is no need to do that.
I know that - bu I'd like to know what will happen during the installation process so I nearly read everything first before  I install a mod - and because mostly each package does not include my favorite language (German) and I don't like having a Portuguese, Turkish, French or Spanish file on my webserver - that's how it goes.
Its so easy to add a skip parameter to lines are proceeded by the installer (or to remove these lines/files are not needed).

Also - I have a testboard - not every mod works with 2.0 Gold....

This is just a hint for people feels like me... - if it is working fine then there is no need to use the advanced link... - too much clicks :)

I've got huge respect for modworkers - I wish I could do in the same matter like all the experts who share all the useful mods with the community... @all - thx for that...

Well, reading what will happen is part of learning how SMF works and how things come together...

Inti31 - a German SMF fan :)
my forum
my testforum


my mods - which I only made them work for 2.0 Gold:
Topics Filter v3.2 SMF 2.0 Gold
MemberNumber

cloksin

#647
I've modified the package-info.xml file to work on 2.0 for those people that either can't do the change themselves of can't figure out how to make the emulator work.

USE AT YOUR OWN RISK!!!!!!
SMF 2.0.1
SimplePortal 2.3.3

Illori

sorry you are not allowed to distribute the mod made by someone else without their permission. your attachment has been removed.

Major Wood

I tried installing this on a 2.0 gold installation and the majority of the tests fail. This happens regardless of what version I set the emulation to.

Illori

this mod has not yet been fully updated to 2.0 so you may need to do some tweaking to get it installed.

live627

If that's the case, then why did I install it on multiple 2.0 installs without err?

Illori

no idea, i know i had to do some tweaking to get it to install on my 2.0 forum.

Biology Forums

To the author:

Could you help me add a number next to the My Bookmark in the menu that denotes how many bookmarks you have? Kind of like when you have mail, it has the number in brackets Messages (2)... But rather have something like My BookMarks (4)...

Could you help, I'm using 1.1.14

frx

I can't see this botton:
http://custom.simplemachines.org/mods/index.php?action=download;mod=864;id=138967;image

In the Top Menu, the button appears, but the add button doesn't. :(
I've emulated it into smf 2.0 RC3, to work in a SMF 2.0 Gold.

Illori

parse the mod and manually add the code

frx

Quote from: Illori on July 29, 2011, 08:23:41 AM
parse the mod and manually add the code

It only said it wasn't possible to add the code in the subs.php (i added it manually).

The rest of codes were all ok.
But i'll check it later, to see if it has been added or not. Thanks.

frx


Aaron

I have uploaded a new version of this mod to the mod site. :)

This version should install on SMF 2.0 and above without the use of version emulation and should do a better job at adding the 'Add Bookmark' button to the (topic) display template.

Illori

you have again set the edits for Display.template.php as optional, without these edits no one can add a thread to the bookmarks. this issue was seen above a few posts. please change this.

you also made the edits to modifications.english.php optional this would cause many undefined errors as a result if the edits are not made.

Advertisement: