News:

Want to get involved in developing SMF, then why not lend a hand on our github!

Main Menu

MySQL Version Issue During Upgrade

Started by von Corax, May 28, 2022, 01:43:56 PM

Previous topic - Next topic

von Corax

I'm trying to upgrade my forum from 1.1.21 to 2.0.19 preparatory to a hosting change. I uploaded the upgraded software and tried to run upgrade.php, only to be met with the message Your MySQL version does not meet the minimum requirements of SMF. According to phpinfo (my sysadmin would plotz if I posted a link) my MySQL server is version 5.5.62. What version do I need?

My dev box has mysqlnd installed, while my prod box does not. is this the problem?

Doug Heffernan

Quote from: von Corax on May 28, 2022, 01:43:56 PMI'm trying to upgrade my forum from 1.1.21 to 2.0.19 preparatory to a hosting change. I uploaded the upgraded software and tried to run upgrade.php, only to be met with the message Your MySQL version does not meet the minimum requirements of SMF. According to phpinfo (my sysadmin would plotz if I posted a link) my MySQL server is version 5.5.62. What version do I need?

My dev box has mysqlnd installed, while my prod box does not. is this the problem?

Have a look at this post.

https://www.simplemachines.org/community/index.php?topic=572758.msg4052315#msg4052315

While you are upgrading, why not upgrade to 2.1.2. which is the latest/newest version?

What about the php version, what it is set to? Most likely you must upgrade it as well for the upgrade to work.

von Corax

Quote from: Doug Heffernan on May 28, 2022, 01:52:37 PM
Quote from: von Corax on May 28, 2022, 01:43:56 PMI'm trying to upgrade my forum from 1.1.21 to 2.0.19 preparatory to a hosting change. I uploaded the upgraded software and tried to run upgrade.php, only to be met with the message Your MySQL version does not meet the minimum requirements of SMF. According to phpinfo (my sysadmin would plotz if I posted a link) my MySQL server is version 5.5.62. What version do I need?

My dev box has mysqlnd installed, while my prod box does not. is this the problem?

Have a look at this post.

https://www.simplemachines.org/community/index.php?topic=572758.msg4052315#msg4052315

While you are upgrading, why not upgrade to 2.1.2. which is the latest/newest version?

What about the php version, what it is set to? Most likely you must upgrade it as well for the upgrade to work.

Thanks; I'll have a look at that link.

I'm upgrading from 1.1.21, which requires PHP <5.5.9, while 2.1 requires PHP >7, and I don't want to try upgrading both at once. Also, I'm planning to change hosts, and I haven't even tried to find a host that offers PHP <7. Hence, the two-phase upgrade.

Doug Heffernan

Quote from: von Corax on May 28, 2022, 04:10:49 PMThanks; I'll have a look at that link.

I'm upgrading from 1.1.21, which requires PHP <5.5.9, while 2.1 requires PHP >7, and I don't want to try upgrading both at once. Also, I'm planning to change hosts, and I haven't even tried to find a host that offers PHP <7. Hence, the two-phase upgrade.

Good luck with the upgrade and finding a new host. Let us know how it will go.

Sir Osis of Liver

Crocweb supports php 5.3 - 8.1.  Very good host.
"The best laid schemes o' mice an' men / Gang aft a-gley." - Robert Burns

von Corax

Quote from: Doug Heffernan on May 28, 2022, 05:04:17 PM
Quote from: von Corax on May 28, 2022, 04:10:49 PMThanks; I'll have a look at that link.

I'm upgrading from 1.1.21, which requires PHP <5.5.9, while 2.1 requires PHP >7, and I don't want to try upgrading both at once. Also, I'm planning to change hosts, and I haven't even tried to find a host that offers PHP <7. Hence, the two-phase upgrade.

Good luck with the upgrade and finding a new host. Let us know how it will go.

It worked, but now I'm having another problem. I'll close this thread and open a new one.


Advertisement: