News:

SMF 2.1.3 has been released! Take it for a spin! Read more.

Main Menu

SMF 1.1.2 Released

Started by Grudge, February 10, 2007, 07:36:03 AM

Previous topic - Next topic

Daniel D.


gangsta

Is there any chance that you will release "code changes" similar of that to PHPBB? I have to manually edit my files and templates in order to get the modifications and custom template mods since my host (I am sure many people have this problem too) does not allow mods to be installed automatically via the package manager.

destalk

Can anyone list exactly which SMF files are updated with this patch?

Thanks.

Gary

Quote from: ankur0412 on February 14, 2007, 12:19:51 AM
Quote from: SleePy on February 14, 2007, 12:16:18 AM
try:
;version_emulate=1.1.1

at the end of the package manger url.


What will it do?

That will make the package manager think you're running 1.1.1 rather than 1.1.2

-AwwLilMaggie
Gary M. Gadsdon
Do NOT PM me unless I say so
War of the Simpsons
Bongo Comics Fan Forum
Youtube Let's Plays

^ YT is changing monetisation policy, help reach 1000 sub threshold.

Kilian Hendrickx

i have an error when i try to instal:
1. Voer aanpassing uit smf_1-1-2.mod Modificatieverwerkingsfout
2. Voer aanpassing uit smf_1-1-2_can_fail.xml Modificatieverwerkingsfout
3. Voer aanpassing uit - Modificatieverwerkingsfout
is it normal? if i press continu, it don't upgrade  :(

moraidh

Quote from: moraidh on February 13, 2007, 07:14:57 PM
I have never gotten package manager to work and have about 6 mods installed manually.

I am a bit nervous about what to do here.  I upload all the unzipped files and run ..../upgrade.php I guess?

The smileys and avatars are already there - do I really need to upload those again?  Or if I don't upload them will the upgrade.php return an error because they are not there?

Will it overwrite all those files I have modded with the upgrade ones, or does it somehow know to leave my manually edited additional mod code bits alone?  I don't want to upgrade and find I have lost all my mods!

Do i just upload the Ugrade folder unzipped, or have to place the files within it into their proper folders first (source files to the source folder etc)

If it will overwrite my modded files, is it feasible to manually edit the files locally to include the 1.1.2 code and upload those, or not?  It does seem with several MB of files that might be too much.

Should I edit them, adding the mod code, then just upload them - does that mean I don't have to run upgrade.php?

Sorry for the dumb Q, but I'm new to this and have never upgraded a forum before!

Surely someone can help me?!

Do I upload the zipped files, or unzip first?  Upload to which folder? To mysite.com/forum???  Do I unzip the files and put them in their respective folders (Source, Themes..) first?

The FAQ doc goes into no detail about this!

青山 素子

Please, DON'T USE THIS THREAD FOR SUPPORT ISSUES, USE THE SUPPORT BOARD


Quote from: gangsta on February 14, 2007, 04:49:28 AM
Is there any chance that you will release "code changes" similar of that to PHPBB? I have to manually edit my files and templates in order to get the modifications and custom template mods since my host (I am sure many people have this problem too) does not allow mods to be installed automatically via the package manager.

Download the package file and look at the mod files in an editor. You can see all the changes that need to be done with it.
Motoko-chan
Director, Simple Machines

Note: Unless otherwise stated, my posts are not representative of any official position or opinion of Simple Machines.


HecKel

Hi!

I have one question, I am using RC3, yet..., what upgrade should I download? large or small update?

Tnks ;)

HecKel
Quote from: Eliana Tamerin on August 23, 2008, 04:10:10 PM
SMF 7 is where it gets good. That has time travel. You can go back and post before the guy who flamed you. :P

babjusi

Quote from: HecKel on February 14, 2007, 11:51:59 AM
Hi!

I have one question, I am using RC3, yet..., what upgrade should I download? large or small update?

Tnks ;)

HecKel

I think the large one

青山 素子

Quote from: babjusi on February 14, 2007, 11:53:22 AM
I think the large one

Correct. The small update is for only if you are running the next lowest version (in this case, if you were using 1.1.1).
Motoko-chan
Director, Simple Machines

Note: Unless otherwise stated, my posts are not representative of any official position or opinion of Simple Machines.


bank robber

Quote from: somze on February 12, 2007, 09:23:53 AM
Thank you! The update installed flawless  :)
No problems at al. Got 31 mods installed and TinyPortal 0.9.7.1

But i don't understand one thing.. Why is it when i go to the package manager and use the option "The minimum files are writable." it's sets the settings.php and the settings_bak.php to chmod 777? Isn't this a security risk, or do i got it all wrong? I manually set them to 644, and the forum works great after doing this..

But thanks again for the update, i really enjoy using SMF  :D

It's not a security risk. If you look at the file, it's rename as Settings_bak.php and NOT Settings.bak (this is a security risk). Since, it's a php file, the php processor takes over and serves out a blank page.

jdwaso

I have used SMF, and decided to host a forum from my friend using SMF as its great. But am I the only person who cant install ANY packages from that third party thing accessed via the control panel being told.. "The package you are trying to download or install is either corrupt or not compatible with this version of SMF."

Is this cos this release is "too new"?

HecKel

#132
Hi!

I can't upgrade my forum :(

I am Portuguese, as well my forum language..., I removed all the extra themes remove all the language folders..., then I copy the new smf_1-1-2_portuguese-utf8 to my domain, all themes are now with the latest languages files..., but I still have this message:

QuoteThe upgrader found some old or outdated language files.

Please make certain you uploaded the new versions of all the files included in the package, even the theme and language files for the default theme.

Click here to try again.

Any ideia? Where I can find more language files?

HecKel

EDIT: I upload also the smf_1-1-2_portuguese and my problem mantains...
Quote from: Eliana Tamerin on August 23, 2008, 04:10:10 PM
SMF 7 is where it gets good. That has time travel. You can go back and post before the guy who flamed you. :P

HecKel

I tried to fake the upgade and skip step 0, now I have my forum without strings (I have the correct languages files) and this message:

QuoteSorry, the copyright must be in the template.
Please notify this forum's administrator that this site is missing the copyright message for SMF so they can rectify the situation. Display of copyright is a legal requirement. For more information on this please visit the Simple Machines website.
Not sure why this message is appearing? Take a look at some common causes.

I only install from lage upgrade..., is this normal?

HecKel
Quote from: Eliana Tamerin on August 23, 2008, 04:10:10 PM
SMF 7 is where it gets good. That has time travel. You can go back and post before the guy who flamed you. :P

Slamlander

I had a problem with the Install on my board. Tests came up fine by the patch didn't 'take'. What do I do now?

BTW, it worked fine on my other Forum.It [nofollow]'s just the one on http://home.caselle-vpn.net/SMF/index.php [nofollow] that didn't work. It's also the one where I have the Wiki SMF_Auth mod.
[nofollow]

Jewelzz

I installed the latest patch (1.1.2) on my localhost first (as I always do just in case) ... I no longer have Tiny Portal, itwiped it out.  I figured ok, no big deal, just reinstall TP since this is only a local copy.  I get the following error:

"The package you are trying to download or install is either corrupt or not compatible with this version of SMF."

Anyone else have this issue?  Can any one help me work this out?

TIA

!Hachi!

manual install it or change code and make it sure its 1.1.2 instead of 1.1.1 its packageinfo file or install.xml have a lookk.i think it will works.
Happy Ramadan

trenchteam

I got a ton of mods but this update thru the package manager was clean and safe! Thanks SMF! ;D

GaryS

Hi Gang,

I have a problem with my install, error logs show:

2: fopen(/home/httpd/vhosts/dashack.co.uk/httpdocs/gocmc/Themes/default/languages/index.german.php): failed to open stream: Operation not permitted
File: /var/www/vhosts/dashack.co.uk/httpdocs/gocmc/Sources/Subs-Package.php
Line: 1902

2: fopen(): open_basedir restriction in effect. File(/home/httpd/vhosts/dashack.co.uk/httpdocs/gocmc/Themes/default/languages/index.german.php) is not within the allowed path(s): (/var/www/vhosts/dashack.co.uk/httpdocs:/tmp)
File: /var/www/vhosts/dashack.co.uk/httpdocs/gocmc/Sources/Subs-Package.php
Line: 1902

Can anyone tell me what's going on, 'cos I have to admit I don't have a clue! I don't think I have the CAPTCHA mod because it isn't listed... Any help gratefully recieved, thanks.


What happens is the the PM runs everything fine, the tests are all fine and it tells me insta installed but nothing happens, still 1.1.1.

nokonium

I have a test board where I work on Tiny Portal. It is 1.1.1 and the only mods installed were TP 0.97 and Advanced Visual Verification. When the patch came out I installed it via the feed into the Package Manager and on test it failed where expected, so I uninstalled the AVV and it updated without any errors. When I wanted to test a TP 0.98 alpha, I uninstalled TP 0.97 (for 1.1.1) and re-applied the patch. On trying to install TP 0.98 I got the package is corrupted etc. although the package_info file includes install and uninstall info for 1.1.2. To install it I had to uninstall the patch, install TP 0.98 and re-apply the patch.

As 1.1.1 board I have no problems installing mods or themes, as 1.1.2 I am having problems, is this a server problem or a result of one of the security loopholes patched in 1.1.2?


As a postscript, I do not think that the Visual Verification improvements in 1.1.2 are good enough, I still want to use the AVV Mod.



Advertisement: