News:

SMF 2.0.19 has been released! Please update. Read more.

Main Menu

Hide Tag Special

Started by enik, April 11, 2005, 03:41:07 PM

Previous topic - Next topic

madman71

im blind as a bat!

thanks DIN1031 :)

naxiand

hi to all

i tried to install it but after i take this error
Fatal error: Cannot redeclare template_edit_hidetagspecial_settings() (previously declared in /volume1/web/smf/Sources/Load.php(1726) : eval()'d code:1487) in /volume1/web/smf/Sources/Load.php(1726) : eval()'d code on line 1902

how do i take it out or fix it i dont have access to admin tag all other functions work

Regards

Jaa(c)

Hi,
have one simple question.
I've installed this hide tag 1.7.0 into SMF 1.1.4 . It works ok, the only problem is, that there's no unhide button for hidden contents  (so ordinary users can't see the hidden content). How can I enable the button?

Hope you understand my problem, thanks for help...

ディン1031

#763
Quote from: naxiand on March 15, 2008, 10:45:04 AM
hi to all

i tried to install it but after i take this error
Fatal error: Cannot redeclare template_edit_hidetagspecial_settings() (previously declared in /volume1/web/smf/Sources/Load.php(1726) : eval()'d code:1487) in /volume1/web/smf/Sources/Load.php(1726) : eval()'d code on line 1902

how do i take it out or fix it i dont have access to admin tag all other functions work

Regards
Remove the Doupble insert in the $themedir/Admin.template.php somehow the function template_edit_hidetagspecial_settings() it inserted twice. Remove the second insert, and it should work after that.

Quote from: Jaa(c) on March 15, 2008, 02:47:13 PM<br />Hi,<br />have one simple question.<br />I've installed this hide tag 1.7.0 into SMF 1.1.4 . It works ok, the only problem is, that there's no unhide button for hidden contents  (so ordinary users can't see the hidden content). How can I enable the button?<br /><br />Hope you understand my problem, thanks for help...<br /><br />
There will be no button for this, the mod unhide content after you post a repley to the topic. If you like a button to unhide content parts, than use try a Spoiler Tag Mod.

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

Jaa(c)

Thanks, I'm blind....  :)

ディン1031

For SMF 2.0 Beta 3 user i add to the Mod Site a compatible Version.
It's the Hide Tag Version 2.2.0, i did a complete overwork of the source code, but the options for the mod are the same (so it should compatible to a upgraded forum).

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

demonoid

Hi! I was trying to install yor mod. Well there started problem. Here is what it says when I try to install:
1.  Execute Modification  ./Sources/ManagePosts.php  Test successful
2. Execute Modification ./Sources/Display.php Test successful
3. Execute Modification ./Sources/Post.php Test successful
4. Execute Modification ./Sources/Search.php Test successful
5. Execute Modification ./Sources/Subs.php Test failed
6. Execute Modification ./Themes/default/Admin.template.php Test successful
7. Execute Modification ./Sources/Post.php Test successful
8. Execute Modification ./Themes/default/languages/Admin.english.php Test successful
9. Execute Modification ./Themes/default/languages/Help.english.php Test successful
10. Execute Modification ./Themes/default/languages/index.english.php Test successful


Now, I was wondering, can I install like that and made manual changes to subs.php file? And if that is possible, please can you tell me what to change because I am new at this. Thanks for helping! Cheers!

ディン1031

Quote from: demonoid on March 22, 2008, 08:33:51 AM
Hi! I was trying to install yor mod. Well there started problem. Here is what it says when I try to install:
1.  Execute Modification  ./Sources/ManagePosts.php  Test successful
2. Execute Modification ./Sources/Display.php Test successful
3. Execute Modification ./Sources/Post.php Test successful
4. Execute Modification ./Sources/Search.php Test successful
5. Execute Modification ./Sources/Subs.php Test failed
6. Execute Modification ./Themes/default/Admin.template.php Test successful
7. Execute Modification ./Sources/Post.php Test successful
8. Execute Modification ./Themes/default/languages/Admin.english.php Test successful
9. Execute Modification ./Themes/default/languages/Help.english.php Test successful
10. Execute Modification ./Themes/default/languages/index.english.php Test successful


Now, I was wondering, can I install like that and made manual changes to subs.php file? And if that is possible, please can you tell me what to change because I am new at this. Thanks for helping! Cheers!
First which version did you install and for which smf version ;). Normal it should work like you said, installing it and do the Subs.php changes manual ;). (But use the correct Version for the forum you use.)

The Changes for the Version 1.7.0 are here -> http://jmusic.ddo.jp/DIN1031/modparser/index.php?action=installMod&smfVersion=1.1.4&name=HideTagSpecial170

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

demonoid

Sorry, I totally forgot to write that. I tried to install mod: Hide Tag version 1.7.0.

I have SMF 1.1.4.

Thanks for help!

demonoid

I installed it and it works GREAT! Thanks for this great mod ,,, Cheers!

Jaa(c)

Hi,
I've made Czech translation for this great mod.. DIN1031, it should be in your PM, I haven't noticed  your sig earlyer..

Kdo umí česky, může stahovat tady hxxp:blog.princ.name/ostatni/hide-tag-special-plugin-pro-smf-cestina/ [nonactive] :-)

ディン1031

Quote from: Jaa(c) on April 13, 2008, 03:45:42 PM
Hi,
I've made Czech translation for this great mod.. DIN1031, it should be in your PM, I haven't noticed  your sig earlyer..

Kdo umí česky, může stahovat tady http://blog.princ.name/ostatni/hide-tag-special-plugin-pro-smf-cestina/ :-)
Sorry i was not at home, so i could not answer it, i will insert you translation as soon as possible ;).

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

icon

where's your bbc button?
its not attached to your post...

ディン1031

Quote from: icon on April 14, 2008, 11:47:07 AM
where's your bbc button?
its not attached to your post...
http://www.simplemachines.org/community/index.php?topic=32954.0 <- there it is attached oO. I see it at the end of the post.

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

albanian18

does it work with 1.1.4 version? i tried to install it,it has been installed without errors but it doesnt work,can u help me please?

ディン1031

Quote from: albanian18 on April 17, 2008, 07:02:43 PM
does it work with 1.1.4 version? i tried to install it,it has been installed without errors but it doesnt work,can u help me please?
Yes it work in 1.1.4 oO.
Which Version did you install.

Test it with "[hide]test[/hide] here is some hidden" and go to the thread as guest to see that it work ;).

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

Tuplad

I've got a problem...

My forum is Dutch and if I go to controls of the Hide mod, I get no text. Can I somehow make it work ? I don't mind if the controls are English or Russian.

Tuplad

Oh another thing, could a button be added when I'm creating a new topic ? Would be VERY handy to have a button.

ディン1031

Quote from: Tuplad on April 19, 2008, 01:27:41 PM
I've got a problem...

My forum is Dutch and if I go to controls of the Hide mod, I get no text. Can I somehow make it work ? I don't mind if the controls are English or Russian.
Look into the Settings there are Options for alter text for hidden and unhidden content. It could also be Langaugerelated if you use it correct ;).
Admin -> Posts and Topics -> Hide Tag Special

For your next Question: the button is attached to the first post of this thread.

Bye
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

Tuplad

Quote from: ディン1031 on April 21, 2008, 12:45:32 AM
Quote from: Tuplad on April 19, 2008, 01:27:41 PM
I've got a problem...

My forum is Dutch and if I go to controls of the Hide mod, I get no text. Can I somehow make it work ? I don't mind if the controls are English or Russian.
Look into the Settings there are Options for alter text for hidden and unhidden content. It could also be Langaugerelated if you use it correct ;).
Admin -> Posts and Topics -> Hide Tag Special

For your next Question: the button is attached to the first post of this thread.

Bye
DIN1031
Oh, I've got the button. thanks!

But what I meant is, when I get to the control panel, I don't see no text but just characters like ":", ",", ".", etc. So no actual text because the mod isnt translated to Dutch. Can I just somehow copy the English translation and rename it to Dutch so the forum will recognize it as Dutch ?

Advertisement: