• Welcome to Simple Machines Community Forum. Please login or sign up.
October 24, 2021, 12:17:56 AM

News:

Join the Facebook Fan Page.


SEO sitemap and XML sitemap

Started by mkress, May 09, 2012, 09:15:24 PM

Previous topic - Next topic

bearstreet

http://www.livingist.com/index.php?action=kitsitemap;xml
your sitemap is located here
you used mod rewrite rules
so that your sitemap address changes to
http://www.livingist.com/sitemap.xml
but it is not showing xml sitemap at that address http://www.livingist.com/sitemap.xml
Dont do drugs, coz if you get caught u will go to prison, and drugs are real expensive in prison
:P

Ask me Maths Questions

noxe


Nityananda Maity

Hi @mkress, I have some suggestions:
1) option to add any board url manually (when adding, check for duplicates).
2) add any 'action's to add its all url (I currently installed SA Knowledge Base mod but can't able to add it's urls)

Thanks mkress for this great mod.

humbleworld

Perfect MOD. All topics and posts are arranged by this MOD. Thank you so much, Kress. Sample Here.

mrintech

Quote from: mrintech on August 22, 2012, 05:41:55 AM
Hi mkress,

I have recently started using your MOD and it's very useful. Thanks a lot :)

I need your help with following:

I am using Pretty URLs Mod and my normal sitemap ( http://examdunia.com/index.php?action=kitsitemap ) have links which Pretty URLs set for my Boards and Topics. But, the XML Sitemap ( http://examdunia.com/index.php?action=kitsitemap;xml ) have default SMF URLs, instead of Pretty URLs!!!

Is it possible to have Pretty URLs in the XML Sitemap as well, for all boards?

I have removed Pretty URLs MOD and everything is working superb

GWT has also accepted the XML sitemap without any problem :)

XML Sitemap: http://examdunia.com/index.php?action=kitsitemap;xml
HTML Sitemap: http://examdunia.com/index.php?action=kitsitemap

:)

novill

Is there a possibility that this mod is showing up the SA Knowledge Base in the sitemap.xml. This mod works perfect with my forum, i want just to send the knowledge base sitemap to google.

humbleworld

Novill, are your knowledge base articles already indexed by Google?

novill

No, and that's my problem. The google bot crawls fast other parts my forum.

novill

Any idea how can i solve the mentioned problem with my sitemap to integrate the knowledge base to it?

mikedijital

Quote from: Zuća on May 12, 2012, 12:07:34 PM
Quote from: mkress on May 12, 2012, 08:41:10 AM
version 2.1.1 should now work with simpleportal  http://custom.simplemachines.org/mods/index.php?mod=3393

pls ,update(delete sitemap 1 2 3 4 5 6 7...) in version

Quote from: Zuća on May 10, 2012, 05:06:24 PM
how to hide sitemap 1 2 3 4 5 ....in footer ?


Im still having issues with this, I unclicked the show footer option in admin, i hit save, now i logged out cause i know admins can still see it, but as a guest i could still see it,

I would really like to make the " sitemap 1234567 " go away, Can I manually uncode it and remove it, and if so how would i do that , im using this mod with a direct menu link to help people on cell phones index the site faster, so the footer link is just extra fluff id like to make go away

thanks, excellent mod!

pavan061994

I wanna Uninstall MOD... but itz not getting removed...

Showing:

An Error Has Occurred!
This package was either never installed or was already uninstalled - you can't uninstall it now.


teos55

smf 2.0.3  default theme curve simple portal 2.3.5

  Installed this mod successfuly. 

No problem with google when  sitemap  entered as :  m y s i t e.com//index.php?action=kitsitemap;xml

But problem with the Yandex :

characterset  in error. should begin with :  <? xml version = "1.0" encoding = "UTF-8">

I know you didnt mention yandex at all, but can you shed some light on this ? Maybe adding this line will help to others as well


Skaty

installed with no problem but i have weird display in my sitemap.

it is showing my sideblocks from simple portal. i saw other users they also using simple portal but i'm using it just for blocks.

what is the problem ?


sukafia

Hi, please i don't understand how this mod works, after installing it what and what do i need to do? and also i want to know if the mod will still work properly if its being hidden. Please guide me on all the settings i need to make on the mod for it to work. Thanks!

Skaty

Quote from: Skaty on January 07, 2013, 05:47:00 PM
installed with no problem but i have weird display in my sitemap.

it is showing my sideblocks from simple portal. i saw other users they also using simple portal but i'm using it just for blocks.

what is the problem ?




any idea for this problem ?

johnpaul2k2

what if i want to upload this on my cpanel. how will i go about it?


gebeer

Hello,

thank you for this mod!

I installed successfully on SMF 2.0.4 with EzPortal.

But the XML sitemap has links in the following format:
http://www...../index.php?board=2.0&action=kitsitemap;xml

So &action=kitsitemap;xml gets appended to all links.

When I try to open such a link in the browser, I get an empty page.

Is this behaviour desired?

Also, the sitemap link doesn't show up in the footer.

Only if I choose in Admin: "Sitemap 1,2,3..."

If I choose "Sitemap", nothing gets displayed in the footer.

Please help to resolve. Thank you.

Cheers
gerhard

johnpaul2k2

the mod is working perfectly ok ;D

dianneu

Think this is where I need to post.

How can I set the settings on here? I don't see a link for it.

The sitemap on the bottom of the page looks somewhat funky with 15 hyperlinks?

www.misfitfords.com

Thanks

Advertisement: