• Welcome to Simple Machines Community Forum. Please login or sign up.
October 23, 2021, 07:15:51 PM

News:

SMF 2.0.18 has been released! Please update. Read more.


Tidy Child Boards

Started by Arantor, December 09, 2009, 04:00:36 AM

Previous topic - Next topic

Draffi

Please, it is possible to add support for the cbi-Mod (custom board icons), what you can find here:
http://custom.simplemachines.org/mods/index.php?mod=511

I use cbi 163 with SMF 2 RC5. What code i need to change (in the BoardIndex.template.php) for to make booth mods working?


fullmoonya

i wish there is some one column child in this mod to make this more useful.
do not mark my topic solve unless it is REALLY SOLVED.
my forum

Visit My Blog:
Google SEO Share

Arantor

One column would not be a very effective option, unless you only have a few child boards in the first place.
No good deed goes unpunished
All helpful urges should be circumvented

Shambles

Quote from: fullmoonya on January 10, 2012, 01:32:28 AM
i wish there is some one column child in this mod to make this more useful.

Like in this post?

http://www.simplemachines.org/community/index.php?topic=352963.msg3210101#msg3210101

I too wanted just a single column display... the code changes (to the install package) were very simple indeed.

Arantor

It's funny, when this mod was originally in development, there was a one column display but it was actually removed before distribution, not only because it didn't work properly in IE but mostly because when you went past three children, it looked really stupid.
No good deed goes unpunished
All helpful urges should be circumvented

fullmoonya

January 10, 2012, 04:58:35 AM #345 Last Edit: January 10, 2012, 05:13:15 AM by fullmoonya
Quote from: Shambles on January 10, 2012, 03:29:40 AM
Quote from: fullmoonya on January 10, 2012, 01:32:28 AM
i wish there is some one column child in this mod to make this more useful.

Like in this post?

http://www.simplemachines.org/community/index.php?topic=352963.msg3210101#msg3210101

I too wanted just a single column display... the code changes (to the install package) were very simple indeed.

yes sir, like the one in your link. but now i figured out how to do that so its fine now for me. :)

but now my problem is putting a notification icon beside each childboards that will turn to unread icon if someone posted on the topic of my childboard or someone created a topic on my child boards and will turn into a read icon if the user have viewed the those childboards.
do not mark my topic solve unless it is REALLY SOLVED.
my forum

Visit My Blog:
Google SEO Share

coldy316

i'm using SMF 2.0.2 and the original code still works.
Would you believe it that i live in gods country
Australia

Shambles

Quote from: fullmoonya on January 10, 2012, 04:58:35 AM
but now my problem is putting a notification icon beside each childboards that will turn to unread icon if someone posted on the topic of my childboard ...
That happens automatically on my forum... no further changes were needed after the mod to the mod :)


fullmoonya

January 16, 2012, 10:07:17 PM #348 Last Edit: January 16, 2012, 11:02:11 PM by fullmoonya
Quote from: Shambles on January 16, 2012, 05:17:36 AM
Quote from: fullmoonya on January 10, 2012, 04:58:35 AM
but now my problem is putting a notification icon beside each childboards that will turn to unread icon if someone posted on the topic of my childboard ...
That happens automatically on my forum... no further changes were needed after the mod to the mod :)



how to do that sir? i didn't install some mod for childboards. i just manually edit the default template of my smf2.0.2 just to make my childboard place in 1 column.

EDIT:
no help needed now. i figured out now how. thank you for the idea sir. :)
do not mark my topic solve unless it is REALLY SOLVED.
my forum

Visit My Blog:
Google SEO Share

Kimmie

it doesnt work properly in IE9. The columns should be side to side, but they are top/bottom





what can I do to fix this?


Arantor

Making it work in IE has been discussed before in this very thread, more than once.

If only IE operated like all the other browsers, there wouldn't be a problem.
No good deed goes unpunished
All helpful urges should be circumvented

Kimmie

Quote from: Arantor on January 20, 2012, 10:44:58 AM
Making it work in IE has been discussed before in this very thread, more than once.

If only IE operated like all the other browsers, there wouldn't be a problem.

I never had a problem with it in IE till I upgraded to 9.

So am I to assume there is no fix?

mageguild

Does anyone have a version that is Compatible with 2.0? 

Arantor

Quote from: Kimmie on January 20, 2012, 11:05:07 PM
Quote from: Arantor on January 20, 2012, 10:44:58 AM
Making it work in IE has been discussed before in this very thread, more than once.

If only IE operated like all the other browsers, there wouldn't be a problem.

I never had a problem with it in IE till I upgraded to 9.

So am I to assume there is no fix?

Oh, there is. It's just in this thread somewhere.

Quote from: mageguild on January 20, 2012, 11:22:55 PM
Does anyone have a version that is Compatible with 2.0? 

Also as discussed in this thread multiple times, it will work using version emulation.
No good deed goes unpunished
All helpful urges should be circumvented

mrtarkhan

thanks Spoogs, your nice mod :)

persian translate attached  ;)

هر پرسش خردمند، نيمي از پاسخ را در خود دارد.((سليمان ابن گاويرول))

Heardy

I can't get this mod to work with the Glacier theme, it's saying that "//Show Basic" doesn't exist in my BoardIndex template so I don't know where one part of the code goes :(
Mindless Junk - A haven for forumers.

chr05210084

I can't make it work on vertex theme, maybe I missed something during the installation. I'm using smf 2.0.2 and vertex theme. I installed the mod using package manager without any error.  I enabled the mod and configured  in "Administration Center » Features and Options » Layout" but it didn't work. Do I need to edit something on my themes? Can you please post the instructions. Thanks.

scan06disk

Oh please tell me there is a 2.0.2 compatible version, I am dying for something like this especially moving from MyBB where I had columns.... :(

I did try this on 2.0.2 and it says that error of not being compatible.... STUCK now....

So far I am loving SMF !!!

Kat9119

June 29, 2012, 02:16:50 PM #358 Last Edit: June 29, 2012, 02:31:19 PM by Kat9119
Quote from: Arantor on January 21, 2012, 07:12:56 AM
Also as discussed in this thread multiple times, it will work using version emulation.

I just tried it on a local forum (v 2.0.2) and I got fatal error by emulating 2.0 RC3.

I was using this on an old forum and starting over from scratch trying to use it again and the error I get is:

Fatal error: Cannot redeclare template_tidy_children() (previously declared in C:\xampp\htdocs\CB\forum\Sources\Load.php(2151) : eval()'d code:551) in C:\xampp\htdocs\CB\forum\Sources\Load.php(2151) : eval()'d code on line 627

Update: If I don't allow it to put the code in for BoardIndex or MessageIndex the mod works fine. . . in reading up on this kind of error it seems like there might be a duplicate code when those files are updated. Since the mod works without updating those files, do I still need to update them and just do it manually?

Arantor

Sounds like the code has been included twice for some reason...
No good deed goes unpunished
All helpful urges should be circumvented

Advertisement: