• Welcome to Simple Machines Community Forum. Please login or sign up.
October 17, 2021, 12:41:11 AM

News:

SMF 2.1 RC4 has been released! Try it out and help us test! :) Read more.


SMF 1.1.x incompatibility with recent PHP versions (PHP5.5+)

Started by margarett, March 20, 2015, 09:19:38 PM

Previous topic - Next topic

vbgamer45

Naro yeah I  did the same for my sites that are on SMF 1.1.x
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Arantor

I really couldn't encourage persisting in 1.1.x support.

There is now at least one (proven) SQL injection vulnerability in the base software that will not be patched. It's possible there are more vulnerabilities that are also unpatched.
No good deed goes unpunished
All helpful urges should be circumvented

anodi

HI,

How to disable error log on SMF 1.1? I had 8GB database before I cleaned log table...

Need to update to 2.xx but until that would be nice to not get thousands of errors in minutes.

Thanks!

Aleksi "Lex" Kilpinen

Admin -> Features and Options -> Enable error logging.

Do note that disabling the error log is not a solution to the problems, it just hides them from sight.
A Finnish Project Manager (Support Specialist)
 Happily running multiple SMF 2.x installations.
  Fooling around with i7-10700 @ 2,90GHz-4.80GHz / 16Gb / RTX-2070 Super / 3840x2160 / Win 10 x64


How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum. Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

_sebas_

Quote from: naro on January 08, 2018, 02:47:53 AM
I have extracted fixes for preg_replace(_callback) from SMF 2.0.15 into a XML mod file which I use together with my own mod for 1.1.21.
If you have your own modifications, you can add this XML file and apply it or you can create new mod with that modifications.


How do I apply it?
Can you explain something else, or give some clue?
Thank you

Kindred

since there are also a whole pile of security releases in 2.0 that were never applied in 1.1.21, it is recommended that you upgrade rather than trying to keep patching an outdated and sunset version...
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

wattie

Here's a fixed Subs.php from the Sources directory. There were lots of "deprecated" warnings for "create_function" in PHP 7.2. Now they are gone.

If anybody gets warnings regarding deprecated calls from other files, PM me - I have them all fixed.


vbgamer45

If your site is already updated to support php 7.1 there are some other files though.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Kindred

Wattie,

Unfortunately, the license for SMF 1.1.x does not allow distribution of modified source files.
It only allows modification packages which instruct the system on what changes to apply to source files.

That being said - anyone who is still using 1.1.x should really upgrade.
Although vbgamer has made mod packages with some of the updates, I am fairly certain that some of the security fixes have not been backported - and as the systems diverge more and more, it's going to be harder.

Additionally, Study Force... SMF 2.0.x doesn't support php7.2 yet - so there is no backport for that.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

wattie

Thanks, I did not know that, sorry.

I have no much time to learn how to make it as a package. In mean time I backported some of the important CVE vulnerabilities too.

I know it's good to upgrade - no doubt in that. The reason I am keeping it is that the forum theme is not working with 2.0.x and my forum is inactive for few years - I am keeping it up for historical reasons (registration is disabled, users are gone).

I used some patch for PHP 7.1 which someone gave me some time ago. Then I patched it myself to work for PHP 7.2 because I fount it to be very easy. That's all.

wattie

P.S. Yes, there are other files as well. It looks like Load.php is not very trivial to fix.

cuion


Kindred

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Advertisement: