• Welcome to Simple Machines Community Forum. Please login or sign up.
October 24, 2021, 02:44:12 AM

News:

Join the Facebook Fan Page.


topic views bug?

Started by danhhh, April 04, 2004, 04:55:41 AM

Previous topic - Next topic

danhhh

the "views" column in a forum screen doesn't seem to work properly :-\.  I've got one topic atm that's got 26 replies and 6 views.  from a quick search i can't see any mention of this previously.

hxxp:www.itsunbelievablejeff.com/test_bb/index.php?board=1.0 [nonactive] for an example

[Unknown]

This is to avoid "double counting".  You see, this topic is a good example:

http://www.itsunbelievablejeff.com/test_bb/index.php?topic=193.0

Notice that only two people are posting in this topic.  Because this is the only topic these two people are reading, the view is not going up.

Currently, if you view a topic... wait.... go back to it... *without* going to any other topics in between, the view count will NOT increase.  This seems logical, because it's really not "another view" so to speak.

-[Unknown]

danhhh

I see.  cheers.  is there an easy edit to the code I could make to go back to the way it was with yabb?

[Unknown]

I've changed it so that when you post in a topic, it will let you increase the view count again... this way the views will never be lower than the replies.

But what does it really matter anyway?

-[Unknown]

danhhh

I don't know, I guess it just looks untidy when there's a topic with 90 replies and 12 views ;)

Advertisement: