Wondering if this will always be free?  See why free is better.

Main Menu

2 errors-attachments and smtp email-

Started by mhuppman, June 06, 2009, 04:35:20 PM

Previous topic - Next topic


I had just reinstalled windows server 2003 so i had to use a fresh install of everything(mysql, smf...) I got everything but two things working.

1. when i go to do anything with avatars/attachments i get:
Your attachment couldn't be saved. This might happen because it took too long to upload or the file is bigger than the server will allow.

Please consult your server administrator for more information

2: rename(C:\Inetpub\forums\upload/avatar_tmp_1,C:\Inetpub\forums\upload/) [<a href='function.rename'>function.rename</a>]: File exists

8: Undefined variable: destName

8: Undefined variable: file_hash

2.My SMTP server and POP3 server do work, but when someone goes to recover a password or register i get this:
Ran into problems sending Mail. Error: 504 5.7.4 Unrecognized authentication type

I have edited my php.ini and my forum settings say i should be able to add an attachment that is 3.4M.


I did restart and its still there. If i can get both fixed that would be great, but the main problem is that it wont allow anyone to upload anything.


Ok,Noob question.

How do i check phpinfo() becuse php.exe when i type anything in, nothing happens.


I did a quick restart while i was waitin for the reply. Now when i go to upload something(avatars and attachments) i get this:

Your session timed out while posting. Please try to re-submit your message.

I cleared my cookies and check the timeout settings, and its at 2800 seconds,it gave me that error after 3 seconds.

i also ran the command, it says im running PHP Version 5.2.9-2 and Windows NT GAMESERVER 5.2 build 3790


I think alot of stuff is messed up. I tried uploading an avatar and i get:

The database value you're trying to insert does not exist: file_hash

Im guessing that once i fix that im going to get:

The database value you're trying to insert does not exist: destName

Also i tried unchecking and checking database-driven sessions. it dident work :/


I am running it,well at least that what it says:

Forum version: SMF 2.0 RC1-1
Current SMF version: SMF 2.0 RC1-1

How would i sync the database?


Yes i did, i installed everything from fresh(php,mysql,smf...)



Im hoping to get this fixed by tonight if anyone can help.


srry about being away,
i set it to 50 mbs, but i was trying to upload a 4 kb file.
i just had to get a new hd so i had to reinstall everything again. It is all up to date. i am still having the problem though :/


Im fine with 8mb, but i am just trying to upload an avatar to the server, and it says i cant because its to big or took to long to upload.