News:

SMF 2.0.19 has been released! Please update. Read more.

Main Menu

Menu Editor Lite

Started by Matthew K., March 06, 2012, 01:05:26 PM

Previous topic - Next topic

Matthew K.

It appears that the installation PHP file was not run. Extract the package, and run it in your browser after you've uploaded the file.

lastlight2703

Quote from: Labradoodle-360 on August 22, 2014, 04:27:42 PM
It appears that the installation PHP file was not run. Extract the package, and run it in your browser after you've uploaded the file.

Sorry can you explain 

what do you mean run it in you browser ?
upload which file?
upload to where?
menu_db_install.php?

do i need to unistall the mod first ?

thanks

lastlight2703

i had found the files under public_html/Packages/temp

and on my brpswer i type in hxxp:www.xxxxx.com/Packages/temp/menu_db_install.php [nonactive]

You don't have permission to access /Packages/temp/menu_db_install.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Matthew K.

Copy the file to your main forum directory (where index.php, Settings.php, and SSI.php) are.

lastlight2703

ok i got it.

Its really an awesome mod

Cheers !!!!  ;D

Matthew K.


ben sisko

first of all thanks for creating this mod.

i have installed it and it's running ok. still it generates lots (more like tons) of errors on my site. i guess is a conflict with another mod installed.

the examples bellow are from right after installation:

Quotehttp://xxx/index.php?action=admin;area=menueditorApply Filter: Only show the errors with the same message8:
Undefined index: titleApply Filter: Only show the errors from this file File: /home/xxx/public_html/Themes/default/index.template.php
Line: 422

Quotehttp://xxx/index.php?action=admin;area=menueditorApply Filter: Only show the errors with the same message2: array_merge(): Argument #1 is not an arrayApply
Filter: Only show the errors from this file File: /home/xxx/public_html/Sources/PortaMx/PortaMxIntegrate.php
Line: 284

any help would be appreciated. this mod is a nice addition to my forum and i would hate to drop it because of these errors.

Matthew K.

Thanks for the kind words. Unfortunately, PortaMX is one of two portals that aren't compatible with Menu Editor. There is very little third-party support in Menu Editor Lite. I tried making sure that Menu Editor Pro was compatible with all of the portals, but PortaMX does some very weird things to the menu, and DreamPortal has it's own menu management system that replaces the menu, so neither of them are compatible as of now.

live627

QuoteDreamPortal has it's own menu management system that replaces the menu
It's a supplement.

Burke ♞ Knight

I still use Menu Editor Lite on all my sites, along with SimplePortal, with it's pages feature.
With these two, I can make any SMF forum into a complete site. :)

Thank you again, Labradoodle-360, for a great mod, and the help you gave me a while back. :)

MyTime

#410
I tried adding a button but it's not working out for me. It gives me this error
"Sorry! But we encountered 1 error. Here it is...
Internal Link Selection is required."

I'v tried External link with no luck also.

I'm not sure how to check if I have javascript enabled or not.
I have a premium theme.

Edit: I went to inspect elements>console, and it's ready a lot of errors. Should I list them here?
What would you guys suggest?



Any help please? This is mod should help me get closer too finishing my site!

Mstcool

When you chose the internal link option, did you choose a link from the option underneath it? For external, did you put a link in the url field? :P

MyTime

It does not give me those options  :o

Mstcool

hmm, seems like ur mod didn't get installed properly. Uninstall it, and delete it and then install a fresh file again :p

Matthew K.

No, it probably did indeed install properly. It sounds like you have JavaScript disabled, or another modification's JavaScript is conflicting with Menu Editor Lite's. Can you open your browser's console and see if there are any JavaScript errors?

ovidole91

hello
labradoodle-360 i  want to ask for you help on  a issue that i have

on smf editor menu lite  i create  a  section name : Moduri ( Mods) then a  child of this section named Tractors then i create  a subchild of the Tractors  name Claas ,and when i came on the first page  in menu  i can't reach the subchild of Tractors

like in this image:

http://prntscr.com/59l196

please help me

Matthew K.

That's an issue with your theme, not my modification.

ovidole91

can you help me to fix it please?
or suggest me what to do ?

Matthew K.

Contact your theme author, and request that they add support for grandchildren menu items.

SilverKnight

I find that with smf 2.0.8 the menu editor lite link box for either internal\external no longer appear. But did in previous versions? I have No issues\errors uninstalling\re installing.

Advertisement: