• Welcome to Simple Machines Community Forum. Please login or sign up.
November 28, 2021, 01:43:28 AM

News:

Follow SMF on Twitter.


Responsive Curve

Started by SMF Customization Team, April 20, 2015, 06:33:49 AM

Previous topic - Next topic

petewadey

Very hostile. I was only asking a question, not in any way doubting anyone's knowledge. I give up. 

vii

Quote from: petewadey on November 16, 2018, 08:10:25 AM
Very hostile. I was only asking a question, not in any way doubting anyone's knowledge. I give up.

I assume you mean SMFHack's Gallery Mod, in which case you should post your question to their support thread:

https://www.simplemachines.org/community/index.php?topic=114291.0

Indeed this isn't the right thread for this question.

petewadey

Quote from: Virginiaz on November 16, 2018, 11:33:39 AM
Quote from: petewadey on November 16, 2018, 08:10:25 AM
Very hostile. I was only asking a question, not in any way doubting anyone's knowledge. I give up.

I assume you mean SMFHack's Gallery Mod, in which case you should post your question to their support thread:

https://www.simplemachines.org/community/index.php?topic=114291.0

Indeed this isn't the right thread for this question.

I have done just that, and SMFHacks is looking into my issue. I have also been PM'd by someone who is willing to help. The hostile remark was towards Arantor. Totally unnecessary to be so rude. Everyone else has always been so helpful on this forum............

Arantor

I consider people dismissing what I have to say out of hand because it disagrees with how they think things work to be pretty damn hostile, for the record.
No good deed goes unpunished
All helpful urges should be circumvented

Gwenwyfar

Quote from: Arantor on November 16, 2018, 01:38:03 PM
I consider people dismissing what I have to say out of hand because it disagrees with how they think things work to be pretty damn hostile, for the record.
How is asking a question about something you don't understand a dismissal of anything? He didn't disagree with you and even thanked your answer despite how you wrote it...

Just because some people that come here here are rude, demanding and so on, doesn't mean everyone is.
"It is impossible to communicate with one that does not wish to communicate"

Arantor

Because I said it was the gallery and the response was what amounts to "it can't be because I installed this mod and then it broke therefore it is this mods fault". Not all questions are meant with innocence and not all questions are in good faith, especially when a world view is being challenged.

But whatever, I'm clearly too hostile for his place. Being here just makes me angry and bitter.
No good deed goes unpunished
All helpful urges should be circumvented

Gwenwyfar

No, they are not always in good faith. But neither do I see any post from this person being rude to anybody or anything to be worthy of that response.

Though, you could say I have a bias on the other side. Because I made someone angry frequently by merely forgetting to put a "yes" in front of questions I made.

"Assuming is a dangerous thing"...
"It is impossible to communicate with one that does not wish to communicate"

petewadey

Thank you Gwenwyfar for recognising my words were not meant as Arantor chose to interpret them.

Dylert

Thanks a lot for this great responsive version of the Curve theme! I have installed it and there is one problem. My attachments (pictures) gets too wide for small screens like mobile phones. I have to scroll sidewards to see the whole image. Is it possible to set attachments to "max 100% of the screen" ex. in the index.css file or other files?

Any suggestions? Thanks a lot for any help! :)

Gwenwyfar

December 06, 2018, 10:20:38 AM #449 Last Edit: December 06, 2018, 10:40:34 AM by Gwenwyfar
There is an update for this mod in the works that fixes the issue (among many others). Could take a while longer since we're focusing on 2.1.

Until then, you can add this to your css file:


.attachments img {
max-width: 100%; }
"It is impossible to communicate with one that does not wish to communicate"

Dylert

Quote from: Sir Osis of Liver on August 14, 2018, 02:42:06 AM
Well, got rid of the silly menu icons and have normal Curve menu buttons wrapping where they should be.  A little neater with submenus disabled.  Seems like an obvious solution, why wasn't it done this way?





How did you do this?

Dylert

Quote from: Gwenwyfar on December 06, 2018, 10:20:38 AM
There is an update for this mod in the works that fixes the issue (among many others). Could take a while longer since we're focusing on 2.1.

Until then, you can add this to your css file:


.attachments img {
max-width: 100%; }


Thanks a lot! That was kind of you! :) 

EL34

During the install of this mod, it searches to find the code below in index.template.php

Searched code


<a class="', $button['active_button'] ? 'active ' : '', 'firstlevel" href="', $button['href'], '"', isset($button['target']) ? ' target="' . $button['target'] . '"' : '', '>





My template had this code under that line


<a class="', $button['active_button'] ? 'active ' : '', 'firstlevel" href="', $button['href'], '"', isset($button['target']) ? ' target="' . $button['target'] . '"' : '', '>
<span class="', isset($button['is_last']) ? 'last ' : '', 'firstlevel">', $button['title'], '</span>





I replaced the responsive code manually with the mod code replacement shown here


<a class="', $button['active_button'] ? 'active ' : '', 'firstlevel" href="', $button['href'], '"', isset($button['target']) ? ' target="' . $button['target'] . '"' : '', '>
<span class="responsive_menu ', $act, '"></span>





Then I noticed that the template menu no longer displayed as shown in my screen shot
So I put the old code back for now and the template menu displays again

Why does the responsive code not print the template menu?
Thanks





Forum History -> EZBoard -> YABB -> SMF 1.1.19 -> SMF 2.0.17

EL34

Duh, I figured out what I did wrong
I was supposed to replace that one line with two lines and leave the existing 3rd line
Nevermind  :-\
Forum History -> EZBoard -> YABB -> SMF 1.1.19 -> SMF 2.0.17

Gwenwyfar

Quote from: EL34 on February 15, 2019, 05:44:11 PM
Duh, I figured out what I did wrong
I was supposed to replace that one line with two lines and leave the existing 3rd line
Nevermind  :-\
Happens. Glad you got it sorted :)
"It is impossible to communicate with one that does not wish to communicate"

EL34

Quote from: Gwenwyfar on February 16, 2019, 04:58:52 AM
Happens. Glad you got it sorted :)

Got it all working
The forum shrinks down nicely now for small screens
And the main forum entry page passes mobile device test on google and Bing :)

I looked at it on my old Samsung galaxy 4 and it's way more friendly to that sort of device
Not that I use my phone for that
That is what desktops with multiple 23 inch monitors is for :P

I will fiddle with it some more
I need the postings text and some other text to be a bit larger
I am still getting - "Clickable elements are too close together"  for some of the links text

Thanks for the mod
Forum History -> EZBoard -> YABB -> SMF 1.1.19 -> SMF 2.0.17

EL34

I would like to increase the text size in the boards

Overall the responsive mod looks good and passes Google and Bing mobile comparability test
but the text looks too small when I test the forum on my phone

I did a test where I changed the index.css file body code and increased the text size to medium
It looks pretty good on my desktop and my galaxy 4 phone set at medium

Is this the best place to do that?

Here's the before and after body code in the index.css file

before code


/* original body */
bodyX {
background: #787878;
font: 78%/130% "Verdana", "Arial", "Helvetica", sans-serif;
margin: 0 auto;
padding: 15px 0;
}


Changed code

/* Set a fontsize that will look the same in all browsers. */
body {
background: #787878;
font: medium Verdana, Arial, Helvetica, sans-serif;
margin: 0 auto;
padding: 15px 0;
}

Forum History -> EZBoard -> YABB -> SMF 1.1.19 -> SMF 2.0.17

njtweb

Quote from: EL34 on February 17, 2019, 02:29:02 PM
I would like to increase the text size in the boards

Overall the responsive mod looks good and passes Google and Bing mobile comparability test
but the text looks too small when I test the forum on my phone

I did a test where I changed the index.css file body code and increased the text size to medium
It looks pretty good on my desktop and my galaxy 4 phone set at medium

Is this the best place to do that?

Here's the before and after body code in the index.css file

before code


/* original body */
bodyX {
background: #787878;
font: 78%/130% "Verdana", "Arial", "Helvetica", sans-serif;
margin: 0 auto;
padding: 15px 0;
}


Changed code

/* Set a fontsize that will look the same in all browsers. */
body {
background: #787878;
font: medium Verdana, Arial, Helvetica, sans-serif;
margin: 0 auto;
padding: 15px 0;
}


Did it change webmaster tools strike for text too small on mobile to passing?

EL34

Quote from: njtweb on March 27, 2019, 04:08:18 PM
Did it change webmaster tools strike for text too small on mobile to passing?

Yes, the forum now passes all webmaster test on Google and Bing
They both say that it is mobile friendly now :)
Forum History -> EZBoard -> YABB -> SMF 1.1.19 -> SMF 2.0.17

njtweb

Interesting. I'm using default curve and vers 2.0.15 with responsive curve mod. My index.css file does not have any of this code.



/* original body */
bodyX {
background: #787878;
font: 78%/130% "Verdana", "Arial", "Helvetica", sans-serif;
margin: 0 auto;
padding: 15px 0;
}



Advertisement: