• Welcome to Simple Machines Community Forum. Please login or sign up.
October 26, 2021, 04:29:49 AM

News:

SMF 2.0.18 has been released! Please update. Read more.


Forum not working

Started by ruskan, August 02, 2021, 11:10:05 AM

Previous topic - Next topic

shadav

are you using a custom theme? you will need to update the theme to 2.0.x or use the default theme
any themes for smf 1.x will not work on smf 2.x

in your forums root folder make sure that all files named upgrade are deleted, there may be 6 of them.

Aleksi "Lex" Kilpinen

You can delete it through your hosting control panel or FTP, if it wasn't deleted at the end of the upgrade.
A Finnish Project Manager (Support Specialist)
 Happily running multiple SMF 2.x installations.
  Fooling around with i7-10700 @ 2,90GHz-4.80GHz / 16Gb / RTX-2070 Super / 3840x2160 / Win 10 x64


How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum. Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

ruskan

I have deleted all the upgrade files.

I am using Esintiler, which I guess is a custom theme (?) . How do I upgrade that to 2?

Gary

From the look of things, you'd have to recreate it in 2.0 from scratch as there doesn't seem to be a 2.0 compatible version. (ref).

That or hire someone to do it for you in the Help Wanted board, indicating if you want it done for free or paid.
Gary M. Gadsdon
Do NOT PM me unless I say so
War of the Simpsons
Bongo Comics Fan Forum
Youtube Let's Plays

^ YT is changing monetisation policy, help reach 1000 sub threshold.

ruskan

When I go to the forum page, it is showing in Esinteler. However, there are no options in the menu bar for me as the administrator to go deeper into the guts of the program. So how would I recreate if from scratch?

ruskan

Or if Esentiler is not available in 2.0, how do I get the program to work in default theme? To reiterate, I have entered my admin data into the login, have gone to the forum page, but there are no options in the menu bar except for 'my messages'

shadav

https://wiki.simplemachines.org/smf/Repair_settings.php
download and upload the repair settings tool to the root of your folder and run it
make sure to set
Set SMF default theme as overall forum default for all users
this will revert the forum to the default theme

ruskan

Ok, that all went well. I'm back in the default theme with all the admin options showing. Now I would like to install a mod which I previously used. Its the verification where a simple question is asked of the registrant. I'm looking in the mod packages, and can't determine which package is the one I want. There's no explanation of each. Is it 'anti spam verification questions' If so, theres no install command next to it.

shadav

any mods that you previously used would need to be updated as they won't work on smf 2.0.x since they were made for smf 1.x and the few that were made for both have probably had many updates since you last download them

as for asking a question at registration, that is a core feature of 2.0.x
in your admin under configuration go to security and moderation then go to anti-spam
Number of verification questions user must answer
(0 to disable; questions are set below)
Verification Questions

ruskan

Thank you - that worked. I'm now trying to replace the default theme Anone with Esentiler. I see Esentiler is an option in the Themes and Layout Settings window. I change the overall forum default from Anone to Esentiler and hit save. The Esentiler theme now shows, but the admin options are now gone in the menu bar across the top . All I see is the 'my messages'  I'm still in the admin configuration page however. I'm afraid to get out of this page since I don't see the admin options at the top. I am able to back out of here and return to Anone.

shadav

again you can not use a smf 1.x theme on smf 2.0.x
you will need to either update the theme to work for smf 2.0.x or download a new theme that does work for smf 2.0.x

set your theme back to default
then in your admin under configuration go to themes and layouts then go to theme settings and click the red x on all of your old themes to delete them from the list (do not delete the default curve theme)
then in your hosting file manager or via ftp in your themes folder delete those themes (do not delete the default curve theme) because they will not work on smf 2.0.x without A LOT A LOT of work and for that you'd have either see if the theme creator made a 2.0.x version or hire someone to do it if you really really want to keep that theme

ruskan

ok, thanks. I didn't realize that it still refering to the 1.0 Esentiler. I may try to change the theme in the future, but have to leave it for now. Thanks so much for the help/

Steve

So your questions are resolved then and you are no longer on version 1.1?
Please do not PM me for support.

Advertisement: