• Welcome to Simple Machines Community Forum. Please login or sign up.
October 17, 2021, 08:18:59 AM

News:

SMF 2.0.18 has been released! Please update. Read more.


Integrating the forum into your site...

Started by [Unknown], November 09, 2004, 11:18:05 PM

Previous topic - Next topic

Kleidi

Quote from: Tyrsson™ on January 07, 2010, 02:49:57 AM
I took a look at the file and there is no need to change anything with the default functions. Just add the two functions. If I find time I will try to edit the file you have attached so that it will work (as long as the db changes have been made).
Thank you Tyrsson for the reply.
I have made the database modification as Unknown said at the first page of this post.
When you get time, pls, made the needed modification on that template. Please ...
Thank you again ;)

ACAMS

After I got my forum looking like I wanted it to, I opened the forum and then right clicked selected View Source then I made an index.php (with a few hours work) and made the rest of my site look like the forum.

http://gametechmods.com/

Kindred

that, of course, does not take into account any of the conditional php code that the templates use to display the forum header, footer or anything else.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Kleidi

Quote from: ACAMS on January 10, 2010, 04:24:29 PM
After I got my forum looking like I wanted it to, I opened the forum and then right clicked selected View Source then I made an index.php (with a few hours work) and made the rest of my site look like the forum.

http://gametechmods.com/
It's a good idea, but, when u make any changes on forum like adding/deleting/editing  forum/subforum or adding any mod on it, those modifications will not appear... or i'm wrong ?

ACAMS

Right, I have to manually add any extras......like snow.

Joey Smith™

Remember to declare any variables that you will need as global within the functions you add.

Kleidi

Quote from: Kleidi on January 09, 2010, 04:53:41 PM
Quote from: Tyrsson™ on January 07, 2010, 02:49:57 AM
I took a look at the file and there is no need to change anything with the default functions. Just add the two functions. If I find time I will try to edit the file you have attached so that it will work (as long as the db changes have been made).
Thank you Tyrsson for the reply.
I have made the database modification as Unknown said at the first page of this post.
When you get time, pls, made the needed modification on that template. Please ...
Thank you again ;)

Any idea Tyrsson ? You got any time to take a look there ?
Thx anyway

Josh79

January 25, 2010, 11:26:35 AM #267 Last Edit: January 26, 2010, 12:07:06 AM by Josh79
I am using 2.0 and trying to add my own headers and footers.  I followed the directions to my ability and was finally able to get my page to load, but it is an index instead of a forum.  I created my website in rapidweaver, if you are familiar, and have been using an HTML editor.

Should I upload my index.template?

Here is what I am using for a header template and index template

Joey Smith™

Quote from: Kleidi on January 20, 2010, 07:33:47 PM
Quote from: Kleidi on January 09, 2010, 04:53:41 PM
Quote from: Tyrsson™ on January 07, 2010, 02:49:57 AM
I took a look at the file and there is no need to change anything with the default functions. Just add the two functions. If I find time I will try to edit the file you have attached so that it will work (as long as the db changes have been made).
Thank you Tyrsson for the reply.
I have made the database modification as Unknown said at the first page of this post.
When you get time, pls, made the needed modification on that template. Please ...
Thank you again ;)

Any idea Tyrsson ? You got any time to take a look there ?
Thx anyway
Actually it will be faster if I just post a template that has been edited in the way I suggested. Will try to get to it today, just a lot going on.

Kleidi


yitwail

I'd just like to acknowledge that I tried the simple method outlined here (because I don't need SSI functionality) and it worked flawlessly. My last project was embedding WordPress in my site, and this was so much easier.  :) And with most other Forum software, I probably would have had to create a new template/style/whatever. I just hope the process will work again when SMF 2.x is released.

Joey Smith™

Quote from: Kleidi on February 20, 2010, 03:57:52 PM
Thx bro ... just waiting for it ;)
Kleidi, Can you please send me a copy of the file and I hope I can get to it tomorrow. YOU can email it to support [at] tyrsson.com

Advertisement: